No announcement yet.

KDE updates

  • Filter
  • Time
  • Show
Clear All
new posts


    Each time boot-repair still complains of the NVram being locked.

    So far I have had no success overcoming the "locked NVram" message from "boot-repair."
    I have shorted the pins for the CMOS memory multiple times. The message from the motherboard then is to
    press F1 to work on the BIOS, and then it recommends pressing F5 to restore defaults. Either way it always
    has the correct date and time even if I never press F5. Obviously not all data is cleared. "boot-repair" said to
    limit items to date and time.

    I got another SSD with Ubuntu on it. It's from a former co-worker who is unfamiliar with "boot-repair" software.
    I plan to swap it and my SSD with my system and see how it fares with "boot-repair." That will be a hassle so I am thinking
    of what else to try as well.

    I don't know if I can learn anything from ASUS as my 3 years of phone support are over. I am thinking of starting a chat when I get back.

    Removing the battery will be a hassle as it is under a double wide video card. I would have to disconnect the cables to the box and get inside.
    I see it as walking "the last mile" to clear the NVram/CMOS so I think it may be at a lower cost than reinstalling, etc.

    I have not tried other ways of reinstalling grub... yet.
    Neon 18.04.1 User on desktop and on Asus Transformer 3 Pro laptop


      I did remove the video card and removed the battery temporarily. Unfortunately I still got the NVram locked message.

      I screwed a new 500 gb SATA SSD onto the case bottom. It already has Ubuntu 20.04 installed on it. I ran it under "boot-repair"
      and got it fixed (small changes) and no NVram locked message. Longer term I want to put MS windows on it for a dual boot as running
      Windows in a VM was tedious and did not invite confidence in my earlier system.

      I continued reading about restoring EFI and GRUB on the larger SSD that had Neon, and I still do not have a clear vision of how to get it restored, so I am backing up
      the partition of the main SSD (with an image by Clonezilla) before trying to explore boot and EFI information and making the partition EFI and Grub enabled.

      The image was successfully created and is restorable. It included a GPT 1st and 2nd partition tables, and a MBR file was found.

      My next step will be to chroot to the partition(s) from a live USB and attempt to install EFI and Grub. I will take a break first.
      Neon 18.04.1 User on desktop and on Asus Transformer 3 Pro laptop


        I will go back to a suggestion by Schwarzer Kater to use Back-in-time as a backup system and see about working on setting it up. If others have
        different back-up solution ideas I would be glad to hear them.

        Meanwhile, my KDE Neon main computer has a workaround way of booting at least--that I do not understand and which may be fragile.

        Continuing the story....
        I had decided to begin with Reinstalling GRUB as in using the
        Ubuntu 22.04 live USB.

        But instead I used "boot-repair" advanced options to try to get GRUB restored and do it with EFI links.
        First I did sudo fdisk -l to find the drives
        The one I am most interested in is /dev/nvme0n1
        Then I ran sudo blkid that revealed the partitions in it
        sda2 vfat EFI System partition
        sda3 ext4 the Linux partition

        So I used many "boot-repair" discussion ideas while invoking the automated "boot-repair" tool.

        It failed, and so I restored the old Clonezilla image of the drive's nvme0n1 and got a warning I might have to do modifications of /etc/fstab.

        As I understand it that means my booting and EFI situations should be non-viable....

        I fiddled some more with shorting the CMOS on the x570 Asus motherboard. When you start up it insists you go to BIOS setup and recommends F5 to
        restore defaults. I did F1. I skipped F5. I believe that the NVram is locked problem still is with me.

        I went through the hurdles to open a chat with Asus but only waited and then a miracle happened, at least I think so....

        I started up the box and booted the 500 GB SATA SSD with Ubuntu 22.04 and then restarted and chose the GRUB option to boot Neon
        on the 1 TB nvme board and it booted and is apparently OK.

        I want to go back to setting up backup protection and doing what I need to do to preserve my revived system.

        I expect I can't directly boot into Neon, but I will find out.

        I am lucky for now. I need to pay credit card bills.
        I will check out Back in Time....

        I am keeping my fingers crossed figuratively....
        Neon 18.04.1 User on desktop and on Asus Transformer 3 Pro laptop


          On Sunday I got help from a couple people in the Linux user group and chose their proposed solution of backing up my data and doing a fresh install of Neon on the m.2 drive.
          (Replacing is a lot easier.)

          I backed up that new Neon system with Timeshift.
          I plan to back up my data today with BackInTime.
          Neon 18.04.1 User on desktop and on Asus Transformer 3 Pro laptop