Announcement

Collapse
No announcement yet.

Default Applications are not fixed / randomly changing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [RESOLVED] Default Applications are not fixed / randomly changing

    System Information:

    Operating System: Kubuntu 22.04
    KDE Plasma Version: 5.24.4
    KDE Frameworks Version: 5.92.0
    Qt Version: 5.15.3
    Kernel Version: 5.15.0-10047-tuxedo (64-bit)
    Graphics Platform: X11
    Laptop: TUXEDO InfinityBook S 15 - Gen6
    Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
    Memory: 31.2 GiB of RAM
    Graphics Processor: Mesa Intel® Xe Graphics
    Grub Version: 2.06-2ubuntu7
    Storage Drivers: 1 x Samsung SSD 860 EVO M.2 1TB [internal]; 1 x Samsung SSD 970 EVO Plus 250GB [internal]

    In the past few days, I have installed Kubuntu 22.04 onto my laptop, replacing Ubuntu 20.04 as my OS. I'm a Newbie with much of the Linux world but i can follow instructions well enough.

    I was seeking out a solution to my issue but couldn't find anything specific enough so decided to make a new post about it.

    I am trying to change the Default Applications via System Settings > Applications > Default Applications, after noticing some strange behaviour when opening links from my email. It would open to random browsers every time, as I have a few installed on my system, one time its Chrome, then its Firefox, then its Opera... with no logical reason why it is doing this. I want to set it to Opera but it makes up its own mind!

    I then discovered an error when trying to set the Default Applications, it kept crashing or coming up with this error message:

    Configuration file "/home/USER/.config/mimeapps.list" not writable.

    Please contact your system administrator.


    [i removed the username as it would reveal my identity]

    I found a mimeapps.list file, but it was at the following path: /home/USER/.local/share/applications/mimeapps.list - I opened it up and it was empty? It appears to be in a different location to the one referred to in the error message but i cannot locate that one specified. Then i also found a number of identical files on my computer in other locations that had conflicting information, so i wasn't sure which one I should be referring to or how to even fix this, so I'm asking for help on this forum.

    I wonder if this is a bug related to this specific version, or if this can be amended. I don't mind doing it manually if someone can guide me to the right resources or explain the steps.

    If there is already a thread or post that relates to resolving this issue, please let me know where I can find it. I tried searching across the web and on this forum but to not avail. There were related threads, such as this one and this one, but felt like they were not specific enough to my situation.

    Thanks!
    Last edited by AlphaBetaGamma; Aug 19, 2022, 09:17 AM.

    #2
    Originally posted by AlphaBetaGamma View Post
    I have installed Kubuntu 22.04 onto my laptop, replacing Ubuntu 20.04 as my OS.
    Did you in fact, totally replace 20.04 (formatting the existing /home partition), or was this an 'upgrade' from 20.04 to 22.04 (keeping the existing /home partition)?
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holme

    Comment


      #3
      Originally posted by Snowhog View Post
      Did you in fact, totally replace 20.04 (formatting the existing /home partition), or was this an 'upgrade' from 20.04 to 22.04 (keeping the existing /home partition)?
      I used this installation system from my laptop provider, called WebFAI method. Stands for "Fully Automated Installation".

      Google/search for "tuxedo WebFAI" and it should appear at the top under Tuxedo Computers website, you can read about it there (can't post external links yet)

      Super easy install method, I believe it completely erases all data and does everything from scratch. I had to back up all my files before doing it. It states there on that link: "TUXEDO WebFAI will format all built-in hard drives and partition them as we do it per default."

      So there should be no trace of Ubuntu on my computer at all.

      Comment


        #4
        If you don't want to expose your username, you can reference the home folder with ~ It means "/home/username"

        As far as the mimesapps.list, you are correct. The one under ~/.local/applications/ is empty. I'm unsure way you would look there instead of where the error told you to look. I noticed the .local file is executable while the .config file is not. Probably left over from a previous version of KDE to maintain backward compatibility.

        I've never heard of the WebFAI installation method so I can't speak to that but it seems unlikely it would be the problem - but you never know. However, to say "There's no trace of Ubuntu on my computer at all." is mistaken. Kubuntu IS Ubuntu, just with a different desktop environment. This is an import distinction to know because anything that applies to Ubuntu also applies to Kubuntu except things specifically related to the desktop environment.

        To the issue at hand; first look and see if the file exists. If it doesn't, create it with permissions -rw-rw-r-- (taken from my install). Then try using the Default Applications settings again.

        Please Read Me
        Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

        Comment


          #5
          Originally posted by oshunluvr View Post
          If you don't want to expose your username, you can reference the home folder with ~ It means "/home/username"
          Yes forgive my newbie status, I'll use ~ instead of the username from now on.

          Originally posted by oshunluvr View Post
          As far as the mimesapps.list, you are correct. The one under ~/.local/applications/ is empty. I'm unsure way you would look there instead of where the error told you to look. I noticed the .local file is executable while the .config file is not. Probably left over from a previous version of KDE to maintain backward compatibility.

          I've never heard of the WebFAI installation method so I can't speak to that but it seems unlikely it would be the problem - but you never know. However, to say "There's no trace of Ubuntu on my computer at all." is mistaken. Kubuntu IS Ubuntu, just with a different desktop environment. This is an import distinction to know because anything that applies to Ubuntu also applies to Kubuntu except things specifically related to the desktop environment.
          I used clumsy language there, what i meant was there should be no trace whatsoever of the previous Ubuntu version, as it was completely wiped using WebFAI method. Of course, Ubuntu is fundamental part of Kubuntu, as you say.

          Originally posted by oshunluvr View Post
          To the issue at hand; first look and see if the file exists. If it doesn't, create it with permissions -rw-rw-r-- (taken from my install). Then try using the Default Applications settings again.
          So I have found this file now, at location ~/.config/mimeapps.list. I'm still new to navigating all these documents, so I did a lazy search for all mimeapps.list files and found other locations, my mistake there. Should follow instructions to the tee.

          I opened it up and there wasn't much information in there, only one or two lines. I deleted one line as it was related to an app that's malfunctioning (separate issue being settled elsewhere). i saved the document, closed it, then navigated over to the Default Applications settings.

          I saved my preferred Default Apps and experienced no issues. Opened a link from my email and it used the correct browser!

          So I would say this issue has been solved now. Thank you for your support and sorry to bother you with this. I can see now that if I just followed the instructions and actually looked for that file path, I could have resolved this by myself.

          I'll reach out again in future if there's anything else

          Comment


            #6
            Originally posted by AlphaBetaGamma View Post
            So I would say this issue has been solved now. Thank you for your support and sorry to bother you with this.
            Great!

            Don't be sorry. This how we all learn. Welcome to Kubuntu!
            Using Kubuntu Linux since March 23, 2007
            "It is a capital mistake to theorize before one has data." - Sherlock Holme

            Comment


              #7
              Originally posted by Snowhog View Post
              Great!

              Don't be sorry. This how we all learn. Welcome to Kubuntu!
              Thank you, currently taking an Introduction to Linux course on edX, so i'm getting up to speed slowly but surely. Coming from a pretty non-technical background but since getting Linux, and also while working in a job answering more technical questions this past year as part of a new support role, I realise you need to become familiar with the system to extract the greatest advantages from it, even if it is fairly amateur proficiency, it is better than nothing. Much like learning how your car works helps you if you break down along the way.

              Also just to say, this has been resolved now. Is there a way I can mark the Topic as resolved or is that something the mods take care of? Noticed it on other topics.

              Comment


                #8
                Originally posted by AlphaBetaGamma View Post
                Is there a way I can mark the Topic as resolved
                Return to the first post. Click on Edit (IP Edit Quote Comment Flag Like Bottom Top) at the bottom of the post. Then, to the left of the Title click on No Prefix to see the list of Title prefixes. Select [RESOLVED] or [SOLVED] as appropriate. Then click Save.
                Using Kubuntu Linux since March 23, 2007
                "It is a capital mistake to theorize before one has data." - Sherlock Holme

                Comment


                  #9
                  Originally posted by Snowhog View Post
                  Return to the first post. Click on Edit (IP Edit Quote Comment Flag Like Bottom Top) at the bottom of the post. Then, to the left of the Title click on No Prefix to see the list of Title prefixes. Select [RESOLVED] or [SOLVED] as appropriate. Then click Save.
                  Thank you, on another forum we can't edit our posts after one hour has passed, so i didn't think to check that.

                  Comment

                  Working...
                  X