Announcement

Collapse
No announcement yet.

This morning's update seems to have broken QEMU/KVM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    This morning's update seems to have broken QEMU/KVM

    This morning The Virtual Machine Manager" reported "no connection..." so I rolled back to yesterday and it now works fine.

    I captured the list of installed packages and decided these were related to libvirt:
    Code:
    libspice-server1
    libvirglrenderer1
    libvirt-clients
    libvirt-daemon-config-network
    libvirt-daemon-config-nwfilter
    libvirt-daemon-driver-qemu
    libvirt-daemon-system-systemd
    libvirt-daemon-system
    libvirt-daemon
    libvirt-l10n
    libvirt0
    ovmf
    python3-libvirt
    qemu-block-extra
    qemu-system-common
    qemu-system-data
    qemu-system-gui
    qemu-system-x86
    qemu-utils
    seabios
    spice-vdagent
    virt-manager
    virtinst

    so I updated all but these and rebooting in a few minutes to test.

    Please Read Me

    #2
    This seems to have temporarily solved the issue.

    I have turned off my auto-update for now. I'll try it again in a week or so...

    Please Read Me

    Comment


      #3
      I thought this was from my using Canonical's Server Team Backports PPA, which had a few updates yesterday. Today? My yesterday, anyway.
      A few packages were removed, but I decided to go with it, because I can roll back, or use my laptop for virt-manager for now.
      Last edited by claydoh; Jul 10, 2024, 12:18 AM.

      Comment


        #4
        Updated yesterday and this is still happening. Seeks like this might be the issue:

        Code:
        Starting pkgProblemResolver with broken count: 1
        Starting 2 pkgProblemResolver with broken count: 1
        Investigating (0) libvirt-daemon-system:amd64 < 9.0.0-2ubuntu1.2~backport22.04.202309270211~ubuntu22.04.1 @ii mK Ib >
        Broken libvirt-daemon-system:amd64 Depends on libvirt-clients:amd64 < 9.0.0-2ubuntu1.2~backport22.04.202309270211~ubuntu22.04.1 -> 10.0.0-2ubuntu8.2~backport22.04.202405071150~ubuntu22.04.1 @ii umU > (= 9.0.0-2ubuntu1.2~backport22.04.202309270211~ubuntu22.04.1)
        Considering libvirt-clients:amd64 2 as a solution to libvirt-daemon-system:amd64 -1
        Removing libvirt-daemon-system:amd64 rather than change libvirt-clients:amd64
        Done
        Entering ResolveByKeep
        Calculating upgrade... Done
        The following packages were automatically installed and are no longer required:
        acpi-support acpid libvirt-daemon-config-network libvirt-daemon-config-nwfilter libvirt-daemon-system-systemd mdevctl
        Use 'sudo apt autoremove' to remove them.
        The following packages will be REMOVED:
        libvirt-daemon-system​

        Please Read Me

        Comment


          #5
          Based on the above output, I installed "libvirt-clients" and it's depends:

          Code:
          The following packages were automatically installed and are no longer required:
          libvirt-daemon-config-network libvirt-daemon-config-nwfilter libvirt-daemon-system-systemd mdevctl
          Use 'sudo apt autoremove' to remove them.
          The following additional packages will be installed:
          libvirt-daemon libvirt-daemon-driver-qemu libvirt-l10n libvirt0
          Suggested packages:
          libvirt-clients-qemu libvirt-login-shell libvirt-daemon-driver-storage-gluster libvirt-daemon-driver-storage-iscsi-direct libvirt-daemon-driver-storage-rbd
          libvirt-daemon-driver-storage-zfs libvirt-daemon-driver-lxc libvirt-daemon-driver-vbox libvirt-daemon-driver-xen libvirt-daemon-system numad passt
          The following packages will be REMOVED:
          libvirt-daemon-system
          The following packages will be upgraded:
          libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu libvirt-l10n libvirt0
          5 upgraded, 0 newly installed, 1 to remove and 16 not upgraded.
          Need to get 6,984 kB of archives.
          After this operation, 850 kB of additional disk space will be used.
          and this IMMEDIATELY broke QEMU/KVM. I assume it's the removal of libvirt-daemon-system that causes the problem.

          For the last several days I've NOT upgraded these 22 packages:​​

          Code:
          libvirglrenderer1
          libvirt-clients
          libvirt-daemon-config-network
          libvirt-daemon-config-nwfilter
          libvirt-daemon-driver-qemu
          libvirt-daemon-system-systemd
          libvirt-daemon-system
          libvirt-daemon
          libvirt-l10n
          libvirt0
          ovmf
          python3-libvirt
          qemu-block-extra
          qemu-system-common
          qemu-system-data
          qemu-system-gui
          qemu-system-x86
          qemu-utils
          seabios
          spice-vdagent
          virt-manager
          virtinst​

          Please Read Me

          Comment


            #6
            Assuming you are using the same PPA source, I think that there is a packaging misconfiguration on libvirt-daemon-system​, I think. (I am AFK ATM)

            I think this package depends on a version of something from a later release than 22.04 privides, and not in the PPA. I'll report which thing later.

            Comment

            Working...
            X