No announcement yet.

RH, Cononical and SuSE boiling the GPL Frog?

  • Filter
  • Time
  • Show
Clear All
new posts

  • TWPonKubuntu
    Guest, It's not clear to whom you are addressing your question. For me, I don't use Whatsapp, so the answer would be no.


    Leave a comment:

  • Schwarzer Kater
    Both KDE neon and TUXEDO OS 2 could be options for you, if you don't want to use Kubuntu anymore and a "proper" installation of Debian with KDE Plasma is too time-consuming for you - see
    Overview: Kubuntu, its parent and some of its siblings

    Leave a comment:

  • rec9140
    Originally posted by TWPonKubuntu View Post
    How about the rest of you? Can you "vote with your feet" and move to another platform?
    Can I vote with my feet HMMMM...

    Where to go I guess the next logical backstep would be Debian.... I've played with it in the past... but never cared for it.. there are issues at play there, DFSG for one...Looking at the post here, if I have to do that to Debian to make it even remotely KUbuntu-ish ... Nope.. that ain't going to fly! Which this post reflects the other issues... Even if I did it once to the base VM image.. that still leaves other boxes to do this to as they come up for replacement and the latest OS .... ummm.. I ain't got time for all that... I barely have the time to deal with the desnapping and the other stuff I have to do in Kubuntu adding that pages long steps... Nope don't got time for that...

    Which leads me to ask the question I've asked before.. just how are these distro release ISO's etc. created What software does this Where is it for US TO USE!?!!?!?! Nope Cubic is not the answer, Alex... It deals with the ISO's and it seems to have a slew of issues from what I see.. and at this point doesn't deal with 23.10 dailys at all.. yes its early for that, but I would need to be testing with that at this point to see if the things I need to do are possible...)

    So I guess that means Debian is out for me.....

    Looks like I am going to have to ride the horse I've got till it dies.. by desnapping and till they borq things up with wayturkey (which is the other hard red line in the sand for me, you can skip the replies about the future of the Linux GUI is not X11.. it ain't .. and we won't agree on that...)

    Going outside the Debain sphere is not an option really.. as I am not dealing with RPM's.. and leaving KDE is not an option either, at least not as a full time replacement.. on systems which I don't use on a daily basis but for some very specific setups I've got them using LXqtDE... which is KDEish enough to pass for that use case it used in.

    The issues of RHBM don't really apply to me... as I don't use their stuff... could Canocial pull the same? I am not sure.. being based off Debian... how much of what Canocial does is more than just doing what the post here does? Maybe that view of things is I've always just seen them taking Debian, doing what that post here does, jettison many of the DFSG issues by including things that Debian would be in full meltdown over, like MP3 at the time.. Yeah Unity may have been their thing.. its dead Jim!

    So honestly there are some issues for me... and honestly this is DRAMA I DON'T WANT OR LIKE In my software!

    Originally posted by TWPonKubuntu View Post
    Before you ask; NO, Windows/Microsoft is not an option for me.
    Have not used in 23 years, don't intend to "run to some cruddy cousins house" to solve an issue... Linux can't do it, then I don't need to do it. Period.

    Leave a comment:

  • GreyGeek
    I just finished using Flatpak to install Firefox 115 into my Bookworm installation. Imported my logins and bookmarks from the old Firefox 102 and I am running out of surfaces to polish. Bookworm is running like a champ.

    Leave a comment:

  • Schwarzer Kater
    This has become a bit of a mantra amongst some Debian users I know:
    "Don't use the "debian-live-XXX-kde" ISO. Full stop."
    (I'm sorry for the developers who put their effort into them, but the Debian KDE Plasma live ISOs have always been "not that good" and perhaps should never have been put out there in the first place IMHO…).

    If you want a pre-configured Plasma, choosing the software selection "KDE Plasma" of the "DVD-1" or "netinst" ISOs is the better way (but never forget to de-select "Debian desktop environment" or you will get an unpleasant GNOME surprise… ).
    Installing from "DVD-1" or "netinst" should also include things like e.g. Bash completion OOTB. They are a different beast (and made by different people I think) than those "debian-live-XXX-kde" ISOs.

    But installing Plasma "manually" from "DVD-1"/"netinst" is the best way hands down (and my suggestions are not even refined up to the smallest detail yet - there probably still is room for improvement, but I have been too lazy ).
    Last edited by Schwarzer Kater; Jul 24, 2023, 10:36 AM.

    Leave a comment:

  • GreyGeek
    I got to hand it to you, Schwarzer Kater, your advice to install the Debian server and then install KDE Plasma from the repository was advice I should have followed. Having experience in using KDE ISO's in the past I felt I would have no problems installing Bookworm from the KDE ISO. What I didn't count on was the Debian devs not putting the same care into that ISO as they did in the server ISO. Leaving out the bash-completion package was, in my mind, just an indication as to how sloppy (rushed?) the KDE ISO was put together. My printer is the HP Laserjet Pro P1606dn, which I bought about 10 years ago. It has and still works flawlessly. Since about Kubuntu 16.04 all I had to do to configure my printer was to plug it in. Everything else was automatic. Not so with Debian 12. It lacks the FOSS ppd that includes the duplex feature. I ended up having to use CUPS and hp-plugin from HPLIP to get the proprietary ppd so I could print both sides of a page.

    But, all the bumps being in the rear view mirror I am very pleased with the results. Were I to do it over I would use your suggested method.

    Leave a comment:

  • GreyGeek
    The last major thing I needed to do was install my two steam apps, Universe Sandbox^2 and Kerbal space program. Kerbal installed and started right up. My favorite steam app, US^2, threw an error on startup. The last time I played it was April 5th, and it ran beautifully. The last time I used Steam support, about 5 years ago, they had a support staff. This time, however, all the their links to support direct one to (in the case of US^2) the app creators, Army Giant. Also, the recommended PC configurations showed only Windows and Mac. The Linux config was missing. Army Giant, however, still showed the Linux config and advertised it for Linux. A notation showed that an update was installed today. Was it the problem? Don't know.

    I bought Kerbal because Scott Manley pushed it so much, but I never became a fan because it wasn't close enough to the real physics to suit me, so I rarely played it. My prefered program was Orbiter 2010, which I ran under WINE.

    So, I decided to chuck both of them and delete the steam app altogether. My real joy has been analyzing data using Jupyter Notebook and Python3, which is what I spend my time on when not surfing videos on YT.

    There are still some niggles here and there, and I'm working them out as I run into them. Comparing Kubuntu 22.04 LTS and Debian Bookworm I'd match them up as essentially equal, with an edge to Bookworm for speed. A 10 second boot up to the desktop is not too shabby!

    Leave a comment:

  • Schwarzer Kater
    Keep us posted!

    Leave a comment:

  • GreyGeek
    Well, after a bumpy start, and running into a lot of minor but annoying problems like bash-completion not being installed so the tab key didn't work, I'm pretty much done installing Debian Bookworm. My GPU, the Intel IRIS Xe Meta, which has 2GB of onboard RAM but can borrow what additional RAM in needs from the 16GB of RAM installed on this laptop, does not work well with Wayland. I noticed that problem in Kubuntu 22.04 but my two neurons didn't make the connection when I encountered a group of similar problems in Bookworm. Once I switched to X11 99.99% of the problems disappeared and Bookworm is demonstrating itself to be a VERY fast Plasma desktop. The only major task left to complete is installing my Steam apps.

    Leave a comment:

  • GreyGeek
    Originally posted by Schwarzer Kater View Post
    Are you member of the lp / lpadmin groups? IIRC I had to make sure in Debian for Plasma System Setting's printer stuff.

    And I have to ask again: did you also make sure that non-free-firmware, non-free and contrib is in every line of your /etc/apt/sources.list ?
    Yes on both counts. I had to check the lp group membership.

    I was thinking about the HP GUI needing the root password (but not allowing one to change the name 'root' to user's name) and wondered what would happen if I ran hp-plugin in a root konsole. It worked! But no duplex and no way to set it from the HP GUI. So, with the proprietary plugin installed I used CUP again, and while going through the settings a new "N-Page UP" setting appeared. "AutoLetterDuplex 8.5 X11". I chose it and now I am printing duplex. Cups prints the "Debian test page" on both sides of a sheet!

    Did I mention that Bookworm is FAAAASSSTTT? Like 10 sec boot to working desktop fast.

    When I was configuring the SSD I decided to label the / subvolume with "rootfs". Now my rootfs is @rootfs
    I tried deleting the label with KPartiionmanager but that didn't work. So, I "mv @rootfs @" and edited fstab to show @ instead of @rootfs.
    It gave me the grub screen. So, I'm leaving it the way it is for now and just rewrite my backup scripts.

    I need to get my steam account installed and my dozen Python3 Jupyter notebook environments restored and that should be the last major events of the installation.

    Thanks for the encouragement and hints. My two neurons needed them!

    Leave a comment:

  • Schwarzer Kater
    Are you member of the lp / lpadmin groups? IIRC I had to make sure in Debian for Plasma System Setting's printer stuff.

    And I have to ask again: did you also make sure that non-free-firmware, non-free and contrib is in every line of your /etc/apt/sources.list ?
    Last edited by Schwarzer Kater; Jul 22, 2023, 04:12 PM.

    Leave a comment:

  • GreyGeek
    And then the rose drooped.

    I got the ECG monitor app moved over and when I click on the exe from Dolphin it runs beautifully. However, when I try to add a KMenu entry for it I get a failure msg "can't find /usr/bin/wine". In a Konsole using 'wine xxx' or '/usr/bin/wine xxx" both works. Something to play with.

    Another thing I spent most of the day playing with is my HP P1606dn laser duplex printer. I bought this printer for my birthday in 2010 or 2011, for around $200, and it has been faultless. Zero problems. It's on Amazon now for $89. I've put 9,000 pages and 3 1/2 drums through it. In my first month of usage I got frequent paper jams, so I stopped being cheap and used only heavy 20-30lb high white paper. Jams ceased.

    In the early days of Kubuntu 12.04 I had to use HPLIP and download the proprietary ppd file from HP's support for linux website in order to make the duplex feature work. Then, around 2015, IIRC, the foo2zjs/HP-Laserjet_Pro_P1606dn.ppd driver was released and it allowed duplex activity. For the last seven years all I had to do to configure my printer was to merely plug it into the USB port. Done. Not so with Bookworm. I'm back in 2015 again, putzing with CUPS and HPLIP and PPDs. The is no problem getting the printer to print on one side. Duplex, however, is off the table. First, HP doesn't supply the P1606dn printer ppd driver, like it used to do, in the list of HP printers CUPS uses. Dozens of printer that are listed are marked proprietary. So I downloaded and used the foo2zjs ppd driver. To no avail. Without it I can print on one side. With it I get a "Filter failed" error and no printout.
    Installing the HPLIP GUI is no better because it forces you to use CUPS, so HPLIP is just a more graphical CUPS interface. Graphical bloat.

    The last time I played HP's game of "you gotta download the driver from our site" the result was that the driver required one to log into root as root. Not good in a sudo environment. I could never get HP's driver installed and luckily the FOSS ppd driver came out at about that time.

    Plasma 5.27 is the same in both Kubuntu, Neon and Debian 12. However, the background admin tasks and features that are not part of plasma are on a different level. But, in for a dime, in for a dollar, I'm going to hammer it into shape. No turning back.

    Leave a comment:

  • GreyGeek
    Attempting to compile wxqt, my weather app, I found that bash (in a Konsole) would not honor the "~/" prefix and when I used the complete path it reported that the Qt4 core and guicore and other central modules were missing.
    I noticed that wayland was the DM.
    I switched to X11 and things turned around. I retried compiling the rtl88x2bu and it worked so now I no longer need the cat-5 cable.
    The shine is coming back!

    Leave a comment:

  • Schwarzer Kater
    cat /etc/apt/sources.list ?
    apt policy firmware-linux firmware-linux-nonfree firmware-misc-nonfree firmware-realtek ?
    Last edited by Schwarzer Kater; Jul 21, 2023, 08:06 PM.

    Leave a comment:

  • GreyGeek
    I am writing this from my newly (partially) minted Debian Bookworm installation!

    Sorry Katz, I decided to use the Live USB install and go through the graphical installer because I'm from the "install as much as Plasma offers" school and I have plenty of space. Went smooth as silk.

    My first gotcha was when I decided to add a label, rootfs, to my @ subvolume. I didn't expect it to add that label to @ to create a @rootfs subvolue.

    With my cat-5 cable plugged into my left USB port and the Cudy dongle plugged into the right USB port I pulled the 88x2bu driver from GitHub - cilynx/rtl88x2bu: rtl88x2bu driver updated for current kernels.​ and compiled it. It failed.
    CC [M] /home/jerry/Downloads/rtl88x2bu/platform/platform_ops.o
    CC [M] /home/jerry/Downloads/rtl88x2bu/core/rtw_mp.o
    LD [M] /home/jerry/Downloads/rtl88x2bu/88x2bu.o
    MODPOST /home/jerry/Downloads/rtl88x2bu/Module.symvers
    CC [M] /home/jerry/Downloads/rtl88x2bu/88x2bu.mod.o
    LD [M] /home/jerry/Downloads/rtl88x2bu/88x2bu.ko
    BTF [M] /home/jerry/Downloads/rtl88x2bu/88x2bu.ko
    Skipping BTF generation for /home/jerry/Downloads/rtl88x2bu/88x2bu.ko due to unavailability of vmlinux
    make[1]: Leaving directory '/usr/src/linux-headers-6.1.0-10-amd64'
    It looks like the 6.1.0-10-amd64 kernel wasn't compile properly?
    $ locate vmlinux
    Yes, I am running the amd64 kernel, which was installed by default.
    $ uname -a
    Linux GreyGeek 6.1.0-10-amd64 Home SMP PREEMPT_DYNAMIC Debian 6.1.37-1 (2023-07-03) x86_64 GNU/Linux
    /boot# vdir
    total 184720
    -rw-r--r-- 1 root root 259507 Jul 3 14:28 config-6.1.0-10-amd64
    -rw-r--r-- 1 root root 259446 May 8 15:16 config-6.1.0-9-amd64
    drwx------ 3 root root 4096 Dec 31 1969 efi
    drwxr-xr-x 1 root root 512 Jul 21 16:24 firmware
    drwxr-xr-x 1 root root 94 Jul 21 18:49 grub
    -rw-r--r-- 1 root root 86139714 Jul 21 18:49 initrd.img-6.1.0-10-amd64
    -rw-r--r-- 1 root root 86528263 Jul 21 16:29 initrd.img-6.1.0-9-amd64
    -rw-r--r-- 1 root root 83 Jul 3 14:28
    -rw-r--r-- 1 root root 83 May 8 15:16
    -rw-r--r-- 1 root root 7977184 Jul 3 14:28 vmlinuz-6.1.0-10-amd64
    -rw-r--r-- 1 root root 7962368 May 8 15:16 vmlinuz-6.1.0-9-amd64
    root@GreyGeek:/boot# vdir efi/
    total 4
    drwx------ 3 root root 4096 Jul 21 16:28 EFI
    root@GreyGeek:/boot# vdir efi/EFI/debian/
    total 5960
    -rwx------ 1 root root 108 Jul 21 16:28 BOOTX64.CSV
    -rwx------ 1 root root 87328 Jul 21 16:28 fbx64.efi
    -rwx------ 1 root root 134 Jul 21 16:28 grub.cfg
    -rwx------ 1 root root 4199872 Jul 21 16:28 grubx64.efi
    -rwx------ 1 root root 849616 Jul 21 16:28 mmx64.efi
    -rwx------ 1 root root 948768 Jul 21 16:28 shimx64.efi
    Reinstalling the kernel didn't help.

    The inability to generate an rtl882xbu.ko file is the one thing I feared the most in Bookworm. Without that file I have to drape a cat-5 from the modem/router across the living ceiling fan (not turning) to keep it above our heads, and to my laptop. Can't have it going across the floor and tripping my wife.

    The steam-installer fails to install from the repository.

    The shine has definitely come off of the Debian rose, but I'm not turning back. There is always a solution.

    Leave a comment: