Announcement

Collapse
No announcement yet.

HP Laptop Keyboard

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HP Laptop Keyboard

    Hi! Having two keyboard issues. First one, the mute button works but the LED on it does not. Second, I have the option selected to automatically turn on the numblock key on boot, but this also does not work. Relatively new HP laptop, just a couple years old, if that helps.

    #2
    Where did you set the option to "automatically turn on NumLock on boot"?
    Just in UEFI or also in KDE Plasma's System Settings -> Input Devices -> Keyboard -> Hardware?
    Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
    Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13"

    get rid of Snap scriptreinstall Snap for release-upgrade scriptinstall traditional Firefox script

    Comment


      #3
      I have tried inside plasma but that does not work. Also tried adding numblock=on to /etc/sddm.conf neither worked. In by bios settings, there is no option for numblock.

      Thank you for yhe reply.

      Comment


        #4
        Not sure if you're just making typos - but it's numlock not numblock

        sddm.conf should contain something like:

        Code:
        [Autologin]
        Session=plasma
        ​
        [General]
        Numlock=on
        From what I've read you have to have both sddm,conf and plasma set to numlock=on

        As far as the LED, possibly a boot setting could fix that but you didn't tell us the model of HP.

        Please Read Me

        Comment


          #5
          You are welcome.

          What is the exact name/model number/type of your HP laptop?

          Numlock=on in an sddm configuration file sets NumLock for sddm only.

          Here are some general possibilities for "activating NumLock on bootup": https://wiki.archlinux.org/title/Act...lock_on_bootup

          This could also be too general of an idea, but did you try erasing your user's caches, logging out and in again after this and then trying the System Settings again?:
          Best done from another user account or a tty: sudo rm -r /home/your_user_name/.cache/*
          Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
          Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13"

          get rid of Snap scriptreinstall Snap for release-upgrade scriptinstall traditional Firefox script

          Comment


            #6
            Originally posted by oshunluvr View Post
            Not sure if you're just making typos - but it's numlock not numblock

            sddm.conf should contain something like:

            Code:
            [Autologin]
            Session=plasma
            ​
            [General]
            Numlock=on
            From what I've read you have to have both sddm,conf and plasma set to numlock=on

            As far as the LED, possibly a boot setting could fix that but you didn't tell us the model of HP.
            Hmmmm yes I did make a mistake there in the message, i do have Numlock=on under General, and have it set to on in settings as well. I do apologize for not supplying the make of the pc, which is :

            Operating System: Kubuntu 23.04
            KDE Plasma Version: 5.27.4
            KDE Frameworks Version: 5.104.0
            Qt Version: 5.15.8
            Kernel Version: 6.2.0-20-generic (64-bit)
            Graphics Platform: X11
            Processors: 8 × AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
            Memory: 13.6 GiB of RAM
            Graphics Processor: AMD Radeon Vega 8 Graphics
            Manufacturer: HP
            Product Name: HP Laptop 15-ef0xxx​

            Comment


              #7
              I tried deleting the cache and rebboting, but had no luck with that. I will check out the link you supplied above and see if that helps. Thank you. The make is HP Laptop 15-ef0xxx​.

              Originally posted by Schwarzer Kater View Post
              You are welcome.

              What is the exact name/model number/type of your HP laptop?

              Numlock=on in an sddm configuration file sets NumLock for sddm only.

              Here are some general possibilities for "activating NumLock on bootup": https://wiki.archlinux.org/title/Act...lock_on_bootup

              This could also be too general of an idea, but did you try erasing your user's caches, logging out and in again after this and then trying the System Settings again?:
              Best done from another user account or a tty: sudo rm -r /home/your_user_name/.cache/*

              Comment


                #8
                The LEDs may be just not supported by the kernel. you can try "xset" to manually switch them on or off to see if they work.

                Please Read Me

                Comment


                  #9
                  Unfortunately I couldn't even get xset to turn on and LED that does work (caps lock). Does turn on when i press it though.

                  Originally posted by oshunluvr View Post
                  The LEDs may be just not supported by the kernel. you can try "xset" to manually switch them on or off to see if they work.

                  Comment


                    #10
                    Bit of an update, i tried enabling several different things in modprobe.d/alsa-base.conf, abseloutely no luck at all. By searching around it seems people have had this exact issue for years with realtek alc236. What a shame it's never been implemented. Is there anything else i can do to possibly fix this or report it to the appropriate person to be implemented?

                    Also, i tried a few ways to get numlock to come on before sddm, as i'd like it on when sddm pops, but no luck. as a matter of fact I have to press numlock twice on sddm to get it to come on
                    Last edited by Oderus; Apr 28, 2023, 07:21 PM.

                    Comment


                      #11
                      I am running an 18 month old HP-17cn1*** laptop with LED illuminated keypads. In the BIOS I turned the lights on for the max allowed time.
                      After about 30 seconds of not touching the keyboard the lights go out. If I touch the space bar the come on. Or, I can touch and hold the F4 key to turn on and brighten the lights from off to max.
                      "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
                      – John F. Kennedy, February 26, 1962.

                      Comment


                        #12
                        Alright something is legit wrong with it. My other PC, a very old desktop, which has always worked with numlock in sddm, also is doing the same exact thing (after updating). I have to press numlock twice to get numlock to be active.

                        Comment


                          #13
                          Still having problems with both of these things. SDDM requires (despite configuration, numlockx, etc) numlock to be pressed twice to actually come on. Also, i have tried every kernel module i can think of to try and get my mute button LED to work, and have had zero luck.

                          Comment


                            #14
                            Not that it helps, but here I set numlock on in both sddm and plasma as I described above and it works every time. I also have "Leave unchanged" set in System settings. Point being that it could be an issue specific to 23.04 and/or the kernel you're using.

                            Did you have 22.04 on either of these machines prior to 23.04? Just curious if this behavior is new or if you've seen it before.

                            Please Read Me

                            Comment


                              #15
                              Originally posted by oshunluvr View Post
                              Not that it helps, but here I set numlock on in both sddm and plasma as I described above and it works every time. I also have "Leave unchanged" set in System settings. Point being that it could be an issue specific to 23.04 and/or the kernel you're using.

                              Did you have 22.04 on either of these machines prior to 23.04? Just curious if this behavior is new or if you've seen it before.
                              I did, I had 22.04 on my desktop PC and it worked just fine.

                              Comment

                              Working...
                              X