Announcement

Collapse
No announcement yet.

cannot start KDE after reboot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] cannot start KDE after reboot

    Dear community,

    After a regular reboot, my Kubuntu 22.04 laptop cannot start KDE. I simply cannot understand the messages from in the screen, so I am posting a couple of pictures taken with my phone. I am able to log in on a tty and with the help of a network cable I updated the system (apt update, apt upgrade) and rebooted again to see if the problem solved itself automatically (maybe some critical update was missing?). What can I do to repair my system?

    Regards,

    Tom
    Attached Files
    Last edited by majortom; Feb 29, 2024, 12:06 AM.

    #2
    ...I updated the system (apt update, apt upgrade) and rebooted ...
    Try that again, BUT use
    sudo apt update
    followed by
    sudo apt full-upgrade
    The next brick house on the left
    Intel i7 11th Gen | 16GB | 1TB | KDE Plasma 5.24.7 | Kubuntu 22.04.4 | 6.5.0-18-generic

    Comment


      #3
      Originally posted by jglen490 View Post

      Try that again, BUT use followed by
      Hi, thanks I tried as you suggest but nothing changed

      Comment


        #4
        Try selecting a previous kernel at your grub menu.

        Also, looking at the image, you may want to run a disk check on your /dev/sdb (/media/tommy/DATA)
        I doubt this would stop you from loading the desktop, though, but it will need to be looked at.

        Comment


          #5
          After that, you might try either removing /dev/sdb1 from fstab and rebooting or run fsck on it (unmounted of course). You first screenshot shows an error on that file system. Did you try to shrink that partition?

          Please Read Me

          Comment


            #6
            Originally posted by claydoh View Post
            Try selecting a previous kernel at your grub menu.

            Also, looking at the image, you may want to run a disk check on your /dev/sdb (/media/tommy/DATA)
            I doubt this would stop you from loading the desktop, though, but it will need to be looked at.
            How can i select a different kernel? the booting is too fats and it doesn't show any list.

            I am currently running e2fsk on unmounted /dev/sdb1. It will take some time. There is nothing critical in that partition (it's for temporal storage).

            Comment


              #7
              Originally posted by oshunluvr View Post
              After that, you might try either removing /dev/sdb1 from fstab and rebooting or run fsck on it (unmounted of course). You first screenshot shows an error on that file system. Did you try to shrink that partition?
              Im currently running e2fsck on that partition. I haven't done any resize, it's an old disk that i partitioned long ago to store non critical temporary data.

              Comment


                #8
                Maybe not related to your main problem, but here, I have 6 drives with various partitions on them. All the ones not specifically needed every time I boot up I have in fstab with "noauto" and "users" in the option. That way they never delay or effect my bootups and I can mount them without "sudo" every time.

                Please Read Me

                Comment


                  #9
                  Originally posted by majortom View Post
                  How can i select a different kernel? the booting is too fats and it doesn't show any list.
                  if you aren't seeing the grub menu, then hold the esc key after or near the end of the brand logo screen when first powering on.

                  Comment


                    #10
                    Originally posted by claydoh View Post

                    if you aren't seeing the grub menu, then hold the esc key after or near the end of the brand logo screen when first powering on.
                    Thanks!

                    From the grub menu I selected the last previous kernel "6.2.0-39-generic" and the system booted without problems, and I logged into KDE plasma.

                    I also selected the most recent kernel "6.5.0-14-generic" but with the "recovery mode" option (this is the kernel that failed according the the screenshots). There followed a dialog where I selected "resume" and I was able to get into KDE without problem.

                    So, this means that the problem is essentially solved. But, what can I do next to have more permanent fix? should I wait for a newer kernel update?

                    Have a nice day everybody.

                    Comment


                      #11
                      Originally posted by majortom View Post

                      Thanks!

                      From the grub menu I selected the last previous kernel "6.2.0-39-generic" and the system booted without problems, and I logged into KDE plasma.

                      I also selected the most recent kernel "6.5.0-14-generic" but with the "recovery mode" option (this is the kernel that failed according the the screenshots). There followed a dialog where I selected "resume" and I was able to get into KDE without problem.

                      So, this means that the problem is essentially solved. But, what can I do next to have more permanent fix? should I wait for a newer kernel update?

                      Have a nice day everybody.
                      you may want to change the /etc/default/grub file to this so the grub menu will always show on boot.
                      change these lines
                      GRUB_DEFAULT=0
                      GRUB_TIMEOUT_STYLE=hidden
                      GRUB_TIMEOUT=0​
                      to look like this
                      GRUB_DEFAULT=0
                      GRUB_TIMEOUT_STYLE=menu
                      GRUB_TIMEOUT=5​
                      save the file.
                      then in a terminal type
                      sudo update-grub
                      reboot Menu should show.
                      good luck.
                      Last edited by kc1di; Jan 13, 2024, 05:45 AM.
                      Dave Kubuntu 20.04 Registered Linux User #462608

                      Wireless Script: http://ubuntuforums.org/showthread.p...5#post12350385

                      Comment


                        #12
                        Another temporary solution is to select the working kernel automatically at boot time by changing GRUB_DEFAULT=0 to GRUB_DEFAULT="1>2"

                        This makes grub select the first submenu and third option ( the count is 0 1 2 so 2 is the third choice) by default. This is normally where your second or "old" kernel is listed in grub.

                        Then you can just wait until 6.5 gets updated and test it again until the issues go away. I too am not able to use 6.5 at this point.

                        Please Read Me

                        Comment


                          #13
                          Originally posted by kc1di View Post

                          you may want to change the /etc/default/grub file to this so the grub menu will always show on boot.
                          change these lines

                          to look like this

                          save the file.
                          then in a terminal type
                          reboot Menu should show.
                          good luck.
                          Thank you very much, now I can see the menu.

                          Comment


                            #14
                            Originally posted by oshunluvr View Post
                            Another temporary solution is to select the working kernel automatically at boot time by changing GRUB_DEFAULT=0 to GRUB_DEFAULT="1>2"

                            This makes grub select the first submenu and third option ( the count is 0 1 2 so 2 is the third choice) by default. This is normally where your second or "old" kernel is listed in grub.

                            Then you can just wait until 6.5 gets updated and test it again until the issues go away. I too am not able to use 6.5 at this point.
                            Thank you very much, "6.2.0-39-generic" is the default now. I'm going to wait for the next kernel update as you suggest.

                            Comment


                              #15
                              Originally posted by majortom View Post

                              Thank you very much, now I can see the menu.
                              Your welcome enjoy!
                              Dave Kubuntu 20.04 Registered Linux User #462608

                              Wireless Script: http://ubuntuforums.org/showthread.p...5#post12350385

                              Comment

                              Working...
                              X