No announcement yet.

Neither of my 2 HP printers will print

  • Filter
  • Time
  • Show
Clear All
new posts

    Neither of my 2 HP printers will print

    I have 2 HP printers (MFP M277dw and LaserJet 1022) and a Dell laptop running Ubuntu 16.04. I bought the laptop in March of 2017; so in 3 months, it will be 6 years old. I have had no problem at all until now. The problem seems to be with the CUPS. When I try to print using the M277dw, it doesn’t print, and Ubuntu’s system settings for printers tells me that the /usr/lib/cups/filter/hpps file is missing, and it is. When I try the other printer (the LaserJet 1022), the printer diagnostics tell me it’s not plugged in or turned on—but it is, and it will print a test page. I know zero about CUPS. Any advice you can offer me to solve this problem will be greatly appreciated.

    If you are missing a file - which would be odd IMO - you might reinstall cups. @here that file exists.

    What about HPLIP? Do you have it installed?

    Please Read Me


      The site <> tells me that in order to discover if HPLIP is installed on my computer, I should run in a terminal this command: dpkg -l hplip
      I ran that command, and the terminal replied with this info:

      | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
      |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
      ||/ Name Version Architecture Description
      rc hplip 3.16.3+repac amd64 HP Linux Printing and Imaging Sys

      It appears to me that HPLIP is not installed. Since my version of Ubuntu is almost 6 years old, I'm going to install Ubuntu's latest LTS offering. Thanks though for your willingness to help.


        Yeah, no point in trying to get support for a release that hasn't been updated for 3+years

        Please Read Me


          Since 1966, I have owned only 2 cars, and I still have both of them. The car I now drive daily will be 32 years old in March. It works fine; so why update it to a newer model? I feel the same way about software. As they say, "If it ain't broke, don't fix it!" Ubuntu 16.04 has worked perfectly for me until now. So now I'll update it.



            As I understand Ubuntu's 5 years of support (updates), Ubuntu 16.04's support ended in April of 2021. December of 2022 is now ending; so the updates to my version of Ubuntu ended 1 year and 8 months ago--not 3+ years ago. If just 1 bit of my laptop's solid-state memory that's involved in the path to that hpps file is now defective, then the file will not be found. At least that's my understanding of the way memory works. If I'm wrong, then please correct me. I bought my laptop in March of 2017; so its
            solid-state memory is almost 6 years old. I know almost nil about the longevity of solid-state memory, but this site ( says, "There are two major types of solid-state hard drives - multi-level cell (MLC) and single-level cell (SLC) drives. MLC drives can generally last for five to six years before failure ...." So if my SSD is a MLC drive, then a bit failing after almost 6 years of use seems reasonable to me.

            I wish you a healthy and prosperous 2023.


              I am unsure what you're getting at with this post. Are you suggesting your SSD is the cause of your printers not working? That doesn't make sense to me. Even assuming your drive lost a sector, it wouldn't cause an entire package to magically disappear. The fact that your OS is way out of date seems more likely. Even more likely is something unrelated to either.

              Maybe there's some misconceptions floating around that need clarification...

              Firstly, hardware:

              "Memory" is RAM, not drive space. I assume you mean an SSD when you say "solid state memory." Drive space is "storage" not memory. Either of those can fail but RAM doesn't "wear out" like a drive might. It can die but I've never heard of "1 bit" of RAM failing, so I again assume you mean a sector on your SSD. A memory chip might fail from age on an old RAM stick, but then the whole stick would "die" and need replacement. You would know it immediately and unlikely any storage would be effected unless you were literally in the middle of saving a file.

              No offense intended, but IMO that website you posted a link is totally garbage information. It's just not that simple. Websites like that are "click-bait" that get ad revenue from visitor count and that's their sole purpose. The "predictions" of drive life are all bunk. I've had drives that died within a few months and others that have decades of hours on them. I just removed two Samsung 840 Pro SSDs from my personal system because I am upgrading to NVMe drives. I bought them in 2014. Heavy, daily use for over 8 years, 64,000+ power-on hours, and ZERO issues. These are MLC drives. They are going back into service on another computer I own and I have no doubt they are good for many more years. I also have a hard drive that I use for backups that is 12 years old. It has more than 75,000 power on-hours. They break when they break, not when some so-called "expert" says they are too old. I have replaced many many more storage devices because I wanted faster and larger ones than those that failed. In my experience (using computers since 1977) a drive fails in the first 30 days or will outlast it's usefulness. CDROMs are the exception. I wouldn't trust one for more than a year.

              Again - in my opinion - I would be very skeptical of junk websites like that one. If you want information, look for real data from real providers of it. They're out there - manufacturers, professional hardware testing companies, even "Tom's Hardware" is a good source for real hardware data.

              Sectors on storage devices - whether they are hard drives, SSDs, USB thumb drives or CDROMs can and do fail. Modern platter drives and SSDs (2017 is "modern") will detect a bad sector and, for want of a better term, turn it off and stop using it. If you have a file stored on a sector that fails while in use, then sure, you could have a corrupted file. Most of the time it goes unnoticed or has no real effect. I provide support for 65 computer systems all over the USA that have anywhere from 4 to 25 each computers on site. I replace 20-30 drives a year (out of over a thousand) due to some unknown corruption in the data. Mostly it's the users messing it up. Other times the cause is unknown. 95% of the time, I re-image the drive and put it back in use. The point is - make a backup of important data and worry less (or not at all) about the age of your drive.

              The age of your laptop in not relevant to the OS in any way except that if it's old, it doesn't have newer features. If it works, it works. If it's very old it may have devices no longer supported, but it would have to be very old. 5 years old is not old for a laptop if it still works. I have a 16 year old Dell laptop on my junk pile waiting to go to recycling that still boots Linux and Windows XP. It's just too old and too slow to be useful anymore.

              In conclusion, in my opinion there's absolutely no reason to replace your laptop or drive - is that's what you're getting at. There is ZERO evidence that the age of either is the cause of this issue. Check your drive condition using smartctl and then compare what you find with real information on the topic on the web. likely you find there's little or nothing to worry about. It may need replacement, but the date it was made is mostly irrelevant. Just backup your important data and you have little to worry about.

              Secondly, the Operating System:

              I can see why many people just stick with an old Linux install until something finally breaks (like in your case) or the hardware does. It's the easiest course and humans really don't like change much. More comfortable to stick with what you know.

              However, "support" means bug fixes and new features that often make things work faster and better. I fully embrace the idea of only using LTS releases - that's what have done since 2010 because I use my computer every day and need stability. However, letting your OS age out of support is not a good idea. You can easily end up with an unfix-able problem and maybe even an unusable OS. Although it really isn't much of a worry in the real world - you are also more venerable to some sort of hack or attack.

              Ubuntu - the "core" of Kubuntu - is supported for 5 years. However, Kubuntu and the other Ubuntu "flavors" are only supported for 3 years. Luckily, LTS releases come every 2 years.

              My recommendation is to do what I do use the LTS release until a replacement LTS is available, then prepare for the upgrade. You have a whole year before the older release is end-of-life so you have time. I generally wait until the new LTS is 6 months old so most of the major bugs are worked out.

              Since 2012 I always do a "parallel" install. I have had the "do dist-upgrade" thing fail on me and leave a mess behind, so I dual-boot fresh install instead. Once I had the new version up and running to my liking I would switch over to it. The advantages of this are;
              1. Time to transition (get used to) to the new version and set it up to my liking
              2. Time to explore new features and learn major changes
              3. A fresh install leaves possible problems from the old install behind
              4. The old install is still there and usable as a backup in case I "break" the new install
              Lately, I have tried the dist-upgrade path again and didn't have good results. So I'm sticking to my old way of "leap-frogging" my installs.

              If I were you, I'd drop the trouble-shooting of the printer problem, back up my data, install Kubuntu 22.04 and spend some time setting it up and getting used to it. I also recommend creating an additional partition for your new installation so you have two partitions to install to. Then you can begin a leap-frog approach to upgrades if that sound like a good idea to you. April 2024 is just around the corner!

              I use BTRFS so all my installs and homes are on a single partition - but that's another topic...

              Please Read Me


                It seems that my use of the word “memory” has caused some problems. Permit me to say a few words about me. In 1981, I bought an IBM PC, and I paid $1,500 to get with that PC a 10 megabyte hard drive. In 1981, I also joined the Houston Area League of PC Users (aka “HAL PC”). HAL no longer exists. So since 1981, I have had a computer of one form or another. I have built 2 or 3 desktop computers. I bought the parts (case, motherboard, disk drives, RAM, power supply, etc.) and assembled them myself. In March of 2017, I bought a Dell laptop with 4 GB of RAM and a 128 GB Solid State hard drive. Since 1981, I have understood the difference between RAM and a hard drive. You turn the computer off, and what’s in RAM is gone, but what’s on the hard drive remains. To me (but maybe not to others) a hard drive is a form of “memory.” It does remember things, just as my brain’s memory does!

                That missing “hpps” file presumably was sitting on the hard drive. I used Dolphin to see if it’s there. It’s not there. I know absolutely nothing about CUPS or HPLIP. For the last 10 years I’ve been writing books (I’ve written 5 of them—all nonfiction); so I have used Libre Office’s Writer a lot. About a year ago, I built myself a website. It’s URL is I built the site myself from scratch using HTML, CSS, and Javascript. I need to regain SOON the ability to print the documents I prepare.

                I did not say that the diagnostics said that a “package” disappeared. My original post says, “When I try to print using the M277dw, it doesn’t print, and Ubuntu’s system settings for printers tells me that the /usr/lib/cups/filter/hpps file is missing, and it is.” I followed that path, and that “hpps” file is indeed not there!

                Thanks for your info re your way of handling distributions, upgrades, and updates. I’ll think about the advice you have given me.


                  You might try installing the package hplip. If your told it's already installed, then reinstall it: sudo apt install --reinstall hplip
                  Using Kubuntu Linux since March 23, 2007
                  "It is a capital mistake to theorize before one has data." - Sherlock Holme


                    I’m hoping that someone on this forum who understands computers far better than I do can explain to me something that I flat do not understand. I have been been running Ubuntu 16.04 since March of 2017. Everything worked fine until a printing problem arose recently. So I decided to create a bootable USB stick containing Ubuntu 22.04.1. Yesterday I downloaded the ISO file. This morning I launched Ubuntu’s Startup Disk Creator. I inserted a new 64 GB USB drive into my laptop, and the Startup Disk Creator presumably transferred the ISO’s info to the USB stick. When it told me it was finished, I turned off my laptop, and I waited a few minutes. Then I turned the laptop back on without ever removing the USB drive from the laptop. As far as I know, it should boot this time from the USB drive. Surely Ubuntu 22.04.1 should present itself on the screen with something other than that which I’ve been seeing for the last 5 years, but it didn’t. Everything looks just as it has looked for the last 5 years. What am I missing?


                      The answer just dawned on me. I've got to change the boot order.


                        I have Ubuntu 22.04.1 running on that bootable flash drive. It's so different from the Ubuntu 16.04 that I've been running for almost 6 years that I'm in the position of one who went to sleep one night in the 1600s and awoke in the 21 century. It will take me a long, long time to figure things out on this new OS. If you have any suggestions for shortening the learning curve, please offer them. I need all the help I can get!
                        Last edited by wtb32141; Jan 02, 2023, 03:29 PM.


                          Originally posted by wtb32141 View Post
                          I have Ubuntu 20.04.1 running on that bootable flash drive. It's so different from the Ubuntu 16.04 that I've been running for almost 6 years that I'm in the position of one who went to sleep one night in the 1600s and awoke in the 21 century. It will take me a long, long time to figure things out on this new OS. If you have any suggestions for shortening the learning curve, please offer them. I need all the help I can get!
                          Just ask away, really. I'd aslo suggest giving 22.04 a whirl, as it is more current, and won't be very different from 20.04 in terms of layout and learning curves, etc, Plus has a longer shelf life.

                          The *overall* layout and 'feel' for things is going to be the same - system settings, right-clicking things, menus, etc. But of course the appearance is different-ish, and there will be new options, and some things moved around or relocated in the settings -- the search function will be *very* handy here.
                          Try doing things the same way you expect, and take screenshots for reference, so we can see what you see -- especially if you are going back and forth between the two versions.

                          What WILL be different and potentially confusing will be the added self-contained and sandboxed packaging formats available to you, most notably Ubuntu's Snap system.
                          You can kinda-sorta ignore it, usually. They are a bit different from traditional debs, and are (for the most part) an additional format, not a replacement, and are independent of each other. I won't go into this here, as it WILL open a can of worms, as the politics of things always does
                          So, questions on this will come up. There are plenty of discussions on it all over the place, including this forum.


                            Thank you very much for your comments, suggestions, and willingness to help. My original post mistakenly said "Ubuntu 20.04." I edited it to "Ubuntu 22.04", but you read the post before I saw, and changed "20.04" to "22.04". There's little sense in getting "20.04" when "22.04" is available. I have spent several hours this afternoon reading articles about 22.04, but most of them don't address the issues I need to learn now. Color schemes and things like that mean nothing to me right now. I love the Dolphin file manager; so I will be sure to add it to this new distribution. Things like "Activities" are brand new to me. So it's going to be several days of serious studying and learning for me. I tried to launch Firefox this afternoon, and I had no luck. Ditto re LibreOffice's Writer. I haven't thought about BIOS in probably 10 years. It took me an hour this morning before I said to myself, "You dummy! You must go into the BIOS and change the boot sequence."


                              Originally posted by wtb32141 View Post
                              I love the Dolphin file manager; so I will be sure to add it to this new distribution. Things like "Activities" are brand new to me. So it's going to be several days of serious studying and learning for me.
                              Dolphin has been the default file manager since 2008-ish Konqueror is still kicking about, though.
                              Activities have been around since then as well, but those, much like themes and colors schemes can be ignored, too

                              Originally posted by wtb32141 View Post
                              I tried to launch Firefox this afternoon, and I had no luck. Ditto re LibreOffice's Writer
                              Are you running 22.04 from the USB still?
                              This might be an issue. Depending on your system's specs. Can you give us some info on that?
                              Plasma does more resources in 22.04 than in 16.04, but not by a huge amount.
                              (A side note for anyone jumping in to mention System Monitor stats comparing then and now, the current monitor reports ram usage differently than it used to, and quite a bit higher in comparison to the previous tool)

                              The live session runs from ram, which can be slow as it has to load software (like Firefox) from the compressed OS image on the USB.
                              Also For Firefox, this is one area where Snap can rear its head. In *buntu now, Firefox by default comes as this new type of package system. It is quite slow to load the first time after a boot on a normal bare-metal install, which is probably also being affected in your case here even more by the live session and your system's capabilities.

                              Firefox and Chromium browser are the only applications that are only available by default as Snap packages in *bunutu.
                              There are alternatives to replace FF with a classic deb, which takes some extra work, but is not difficult, and may be worth doing on your system after installing 22.04

                              With Libreoffice, this is NOT a snap, and may just again be in part your system perhaps running out of resources to load things into ram.