No announcement yet.

"Picture of the Day" Wallpaper doesn't show up

  • Filter
  • Time
  • Show
Clear All
new posts

    [Settings] "Picture of the Day" Wallpaper doesn't show up

    Hi guys,
    This is somewhat similar to this thread, but the thing is, for me, whenever I set the Wallpaper type to be "Picture of the Day", no matter the Provider I choose, what I get is only the Background color I set (black, by default). I'm using Kubuntu 22.04.
    Any thoughts/ideas about what might be the issue and/or how to debug it?

    Hello silvian86, Welcome to the Kubuntu forums,
    I don't know what might be the problem with your install but picture of the day works well here. I use the NASA one and it's worked for me.
    I can only guess at what may be hindering your set up. How do you connect to the internet? Do you have any VPN's or firewalls set up? any of those things could be the problem.

    So I would first for a short time try disabling any fire walls I have and VPN's see if that makes a difference. Do you connect via a proxy that can be problematic also.
    But just guessing here. Good luck in finding the cure.
    Dave Kubuntu 20.04 Registered Linux User #462608

    Wireless Script:


      I tried "Astronomy (NASA)" as provider and... same black screen...
      Do you have any idea where I could find the logs for this plugin? And/or how to trigger and/or interact with "Desktop Folder Settings" or with this plugin from the console? (it might throw errors in there...)


        I think NASA wants you to use an API key these days. I went to their site and applied for one, and they e-mailed it to me IIRC. With the key, a 40 character, mixed case, alphanumeric string, in the file apod.key, this script gets it:
        wget -O apod.dict "$(<apod.key)"
        awk -F '"' -v RS=, '/^"url"/{print $4}' apod.dict
        wget -O apod-${dt@P}.jpg $url​
        (The script is time zone unaware, and if your time zone is significantly different to NASA's, run it at the same time each day.)

        Several wallpaper plugins will load backgrounds from a directory. I use VallPaper.
        Regards, John Little


          Thanks John!
          I would really like, though, that the picture of the day would work... It seems I'm not the only one with the issue:
          I'll keep researching...


            I think I narrowed it down to this issue, which I see in the logs:
   QSslSocket: cannot resolve SSL_get1_peer_certificate
   QSslSocket: cannot resolve EVP_PKEY_get_base_id
   QSslSocket: cannot resolve SSL_CTX_load_verify_dir
   QSslSocket: cannot call unresolved function SSL_CTX_load_verify_dir
   An error encountered while to set root certificates location: ""
   QSslSocket: cannot call unresolved function SSL_get1_peer_certificate
   QSslSocket: cannot call unresolved function SSL_get1_peer_certificate
            kf.newstuff.core: "SSL handshake failed"​
            But I don't know how to solve it... yet