Announcement

Collapse
No announcement yet.

[SOLVED] start menu items disappear

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] start menu items disappear

    The Digikam development team figured it out and compiled a new appimage for me.

    digiKam-7.10.0-20230126T171749-x86-64.appimage

    You can get it from the Digikam website.



    Kubuntu 18.04 - fully updated
    Digikam 7.9.0 Appimage

    When using Digikam for about 5 hours or more, if I click on the kde start menu, all but a few items have disappeared. This is repeatable for me. It's happened 4 times in 4 days so far. If I close Digikam after using it for over 5 hours, the start menu items are still gone. Rebooting doesn't help.

    All I'm doing in Digikam is tagging photos.

    I can recover the menu by deleting ~.config/menus/Iapplications-kmenuedit.menu, logout and back in.

    Questions:

    Why is this happening?

    What does using Digikam have to do with the start menu items?

    When I delete​ ~.config/menus/Iapplications-kmenuedit.menu​, and reboot, a new one appears which is identical to the one I deleted. What's going on here? The last time I did this, no new one appeared. There is nothing in the 'menus' directory.

    How can I prevent this from happening?

    Bonus question. Where does kde get the stored menu items from?

    Any help would be greatly appreciated. It's very frustrating.

    Thank you.

    Last edited by snorkelface; Jan 27, 2023, 01:23 AM.

    #2
    Originally posted by snorkelface View Post
    Kubuntu 18.04
    Kubuntu parts of 18.04 reached End of Life nearly two years ago.
    The only thing I can think of is the quite old GUI libraries from Plasma 5.12 in your OS and the newer libraries used in the appimage (probably based on Plasma 5.18, possibly 5.24) might be duking it out after being loaded into ram for a while.
    My first though was that 18.04 uses an older glibc, but Digikam's appimage explicitly supports 18.04's version as the minimum version for that.

    This sort of situation is likely not well tested by Digikam, so you probably need to also take this to Digikam's support for better information, as well as general KDE support areas, for many more eyeballs than our small corner of the KDE world has.

    That file, ​ ~.config/menus/Iapplications-kmenuedit.menu is created when editing menu items either from KDE's menu editor (kmenuedit), or by other GUI means from within Plasma, such as right-clicking on a menu entry (also using kmenuedit, in a different form). It might be worth peeking at this file, if you have a copy in your trash. The file format and location is not specific to Plasma, it is a standard linux/XDG location for menus. The name of the file is indicating the tool that created it.
    I don't see how an appimage would want or need to call kmenuedit,, but who knows. 'Deleting' a menu item in a user's menus actual hides it via files such as this, which is why deleting the file restores things. it does not explain what or why this is happening.

    You do NOT need to logout to fix this after deleting the file, for sure. kbuildsycoca5 *should* do it. You can do it from Krunner (alt-f2)
    Last edited by claydoh; Jan 24, 2023, 06:07 PM.

    Comment


      #3
      Thanks clydoh,

      I posted help at the digikam forum but there is very little activity over there and haven't seen a response for 3 days. I also posted at kde forum but again, no response in 3 days.

      I tried running digikam appimages 7.5, 7.6. 7.7, but all require glibc 2.9. I have glibc 2.7. I find it strange that the latest version 7.9 runs on 18.04, but earlier ones don't.

      "duking it out after being in ram for awhile". LOL. I'm not sure what to make of that. Why would it take at least 5 hours for the menu items to disappear? Why just the menu items? Why would any program make the menu items to disappear? Those were rhetorical questions.

      p.s. I use 18.04 because it just works. At least with the other hundreds of programs that I use. I tried later versions including 22.04 but ran into too many problems right out of the chute. I've always been very happy of how backward compatible Linux has been. Been using Linux since 1994. Until now, I haven't had a need to upgrade and spend gobs of time troubleshooting it to make it work.

      I'm not sure that if I found the source code and compiled it, that it would behave differently.

      Comment


        #4
        A long shot, but something that should be checked... maybe you're running low on space. digikam leaks memory, and the swap file fills up space gradually, till after 4 hours it's nearly all gone and things start failing.

        I suggest checking storage space generally, and monitoring memory usage while you're running digikam.
        Regards, John Little

        Comment


          #5
          Thanks for the suggestion. I checked each time it happened. Memory usage is around 7GB (out of 16GB) and no swap space used.

          I can't fathom how, even if that was a problem, it would cause the start menu items to disappear. Everything else (GUI) related on the system seemed to be ok.

          Please keep suggestions coming. I really don't want to upgrade to 22.04.

          Comment


            #6
            other than swapping for a native implementation of digikam, and hoping it doesn't do the same things:
            https://launchpad.net/~savoury1/+archive/ubuntu/digikam

            This guy has been around a long time nad maintains a lot of repos. I have used some in the past.
            It is a bit more work than the usual PPA, as you need to add more than one -- read the instructions.

            imo, the time spent troubleshooting this may equal the time it takes to troubleshoot the issues with a new OS install. or more. A dual boot with a new install might be useful here, maybe? Even if just to run the appimage or a newer set of native packages.

            Comment


              #7
              Thanks, claydoh.

              I'm working with the digikam developer on this. Hopefully we can figure out what's going on. I will keep your suggestion as a backup, Barring that, I might just have to upgrade or use Digikam on another computer, running a different OS.

              Comment

              Working...
              X