No announcement yet.

Black screen with only a mouse pointer after startup

  • Filter
  • Time
  • Show
Clear All
new posts

    [RESOLVED] Black screen with only a mouse pointer after startup

    Is there anyone else here having only a black screen with a mouse pointer after startup? Recently I had to do a fresh reinstall of Kubuntu 22.04 because of a GPU problem, Nvidia of course. :P
    I could not startup the system at all. That seem to be solved now by choosing the second latest driver (525).

    But now sometimes, not always, I get a black screen with only a pointer after startup. Ctrl-Alt-Delete makes it possible for me to restart of shutdown, fortunately and a second startup did go properly all the time. But I just want a proper startup just in one attempt.

    Does anyone know of a solution?

    Try hittalt alt-f2 or alt-space, and see if Krunner appears. If it does, then enter this to try and (re)start plasmashell manually, which may have crashed for some reason and could not restart itself: plasmashell --replace


      Thank you for the info so far.

      plasmashell --replace

      Is this a command that has some use for repairing the problem?

      By the way: both alt-f2 and alt-space did not have any effect.
      Last edited by Gromm; Aug 09, 2023, 04:57 AM.


        If those don't work, then it is something more than just Plasma not starting, or crashing.

        Plasmashell is the command that starts the desktop manually. It doesn't repair, or anything.

        Another potential workaround would be to hit ctrl-alt-f2 (or f3, 4, etc). log in the the TTY, and restart SDDM to get you to a login screen again
        systemctl restart sddm
        This could save you from needing to do a full reboot.

        Troubleshooting why this is happening randomly will be difficult, I think.


          It did not work. Ctrl -alt-f2 made it possible to type the command: systemctl restart sddm. The system tried to restart but the black screen returned. Could it perhaps be that I made too fancy cosmetic changes?


            By the way: we are in 2024 now, 4 months later and the problem is gone. Do not know if it had anything to do with it, but the problem stopped since I changed the startup screen...Did not change any kernel whatsoever, but some updates might have done the trick?


              Chances are the Nvidia driver was updated to work with newer kernel. Glad it's working for you though. enjoy!
              Nvidia cards can be such a pain in Linux.
              Dave Kubuntu 20.04 Registered Linux User #462608

              Wireless Script:


                Well, yes they are. But as soon as you have the right working driver life is nice and quiet again. Right now I have a problem with my cintiq tablet and monitor configurations, no idea if the NVIDIA gpu might have something to do with it. Look out for my topic about another kind of nuisance.