Announcement

Collapse
No announcement yet.

Problem with nvidia after update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Problem with nvidia after update

    Hi all.

    I have a MSI laptop with a RTX 3080 on which I installed Kubuntu 21.10. All was working perfectly and I was using good performance with my video card (using the proprietary driver version 470).
    Yesterday however there was a system update which I always do as soon as I can and I noticed it contained some nvidia things. I updated and after that worked on. However, later that day I booted my laptop again and I now have several problems:
    • My second monitor is no longer recognized. In Display Configuration there is only one screen (my laptop screen) and nothing else
    • The nvidia driver no longer appears to be working even though the driver manager still says: 'Using NVIDIA driver metapackage from nvidia-driver-470 (proprietary, tested). I know it is not working because 3D games (like Vintage Story now run at 70 seconds per frame instead of 70 frames per second)

    If I try to run nvidia-settings I get an empty window and this appears on the console:

    jorrit@jorrit-Raider:~$ nvidia-settings

    ERROR: NVIDIA driver is not loaded


    ERROR: Unable to load info from any available system


    (nvidia-settings:33846): GLib-GObject-CRITICAL **: 05:22:14.696: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
    ** Message: 05:22:14.697: PRIME: No offloading required. Abort
    ** Message: 05:22:14.697: PRIME: is it supported? no

    dkms status
    The prime-select command is set to 'nvidia'

    Also nvidia-smi says:

    jorrit@jorrit-Raider:~$ nvidia-smi
    NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
    What can I do to get my second monitor back and a working nvidia driver? Also is it to be expected that system updates do such breaking changes on drivers?

    Thanks in advance!
    Last edited by jorritTyb; Nov 29, 2021, 10:40 PM.

    #2
    Never mind, solved both problems with:



    sudo update-initramfs -u

    Still wondering though. I like Linux a lot and when my system works it works so nicely. However, this kind of problem leaves me wondering how less tech-savy people are going to be able to fix things like this.

    Comment


      #3
      I'm going to guess here, that in 'yesterdays' system update there was a kernel update (new kernel)? Do you have the package dkms installed? If not, install it. dkms (Dynamic Kernel Module Support) ensures that kernel modules separately installed; not part of the kernel; are dynamically maintained when the kernel using such modules is updated or a newer kernel comes down the pike.
      Using Kubuntu Linux since March 23, 2007
      "It is a capital mistake to theorize before one has data." - Sherlock Holme

      Comment


        #4
        Indeed there was a kernel update. Thanks for the tip! Why isn't dkms installed standard then? Seems like something pretty essential

        Comment


          #5
          Oh, just noticed I actually already have dkms installed. Do I need to do anything special to make it work?

          Comment


            #6
            Originally posted by jorritTyb View Post
            Oh, just noticed I actually already have dkms installed. Do I need to do anything special to make it work?
            You shouldn't have to. The update procedure is supposed to update initramfs and dkms automatically. Next time you do a "full-upgrade" that includes a kernel update, do it from the command line and observe the actions. You should see update-initramfs and dkms update during the process. If you don't - something is amiss.
            Please Read Me
            Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

            Comment

            Working...
            X