Announcement

Collapse
No announcement yet.

Connecting to windows server shared folder under active directory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Connecting to windows server shared folder under active directory

    Hi, all!
    I am trying to connect to a windows server shared folder from my Kubuntu 20.04 LTS.

    In my home (a 192.168.X.X LAN) I can access shared folders from a windows 10 laptop and the winodws 10 can access the shared folders in my kubuntu, so it works both ways

    Here in my work, I try to access a shared folder from a windows server from dolphin writing smb://<server_ip>/shared_folder_name and I get a Timeout from server mesage.

    From a windows 7 (which is joined to the windows domain) I can access the shared folder without problems using \\<server_ip>\shared_folder_name in the windows explorer route bar.

    The shared folder in the windows server is shared to "All" but not to "Anyone", so I guess the problem I getting is related to some autentication. I guess the windows server doesnt allow the kubuntu to access because is not a domain memeber.

    There is any way to access this shared folder from my kubuntu?

    Thank you all in advance.
    Last edited by Snowhog; Jan 18, 2022, 12:52 PM.

    #2
    https://linuxize.com/post/how-to-mou...hare-on-linux/

    Pay attention to the part about /etc/win-credentials

    Generally, it's better to trouble-shoot mounting a samba connection from the command line first - to make sure there's nothing in the way, Then attempt using Dolphin. Dolphin can be a bit problematic directly accessing samba shares sometime.
    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

    Comment


      #3
      I believe that I tried that exact link, but I will check it again in case I missed something...

      Thanks! =)

      Comment


        #4
        I checked that but I cant access either.

        I am now focus in access through terminal first and then by GUI.

        I try several "smbclient" commands and in all of them I get "protocol negotiation failed: NT_STATUS_IO_TIMEOUT"

        some of the commands I try were:

        smbclient -L '\\10.XX.XX.XX\'
        smbclient -L \\\\110.XX.XX.XX
        smbclient -L \\\\110.XX.XX.XX\\

        smbclient -L //10.XX.XX.XX
        smbclient -L //10.XX.XX.XX/

        smbclient -L //10.XX.XX.XX/sharedfolder -U domain_name/username
        smbclient //10.XX.XX.XX/sharedfolder -U username=domain_name/username
        smbclient \\\\10.XX.XX.XX\\sharedfolder -U username%userpassword
        smbclient //10.XX.XX.XX/sharedfolder -U username%userpassword
        smbclient \\\\10.XX.XX.XX\\sharedfolder -U domain_name/username%userpassword
        smbclient //10.XX.XX.XX/sharedfolder -U domain_name/username%userpassword

        Thank you for your help



        Comment


          #5
          Try adding this to the Global section of smb.conf:

          client min protocol = NT1
          Please Read Me
          Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

          Comment


            #6
            Thank you, thank you, thank you, thank you, thank you! =)
            I could connect! I couldn't be happier! =)

            Comment


              #7
              Great. That was easy. The clue was in the error message: "protocol negotiation failed: NT_STATUS_IO_TIMEOUT"

              This simply says the default NT protocol was mismatched - as in the server didn't match the client. Most OSs do not allow NT1 by default anymore as it's unsafe.
              Please Read Me
              Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

              Comment


                #8
                Ok, great! Thanks for the info!

                I will ask you another question: now I can access the shared network files only by Dolphin but not from Gimp for example, so I am trying to mount that shared folder to a folder in my home, with this command:

                sudo mount -t cifs -o credentials=/home/username/credencials //<ip_server>/ /home/username/sahredfoldername

                where credencials is a text file which has this:

                username=myusername
                password=mypassword
                domain=domainname

                and I get this error:

                mount error(2): No such file or directory
                Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)


                But the route is ok since I copy it to dolphin and can access without problem.

                Any idea?

                Thanks!

                Comment


                  #9
                  For Gimp to have access to external folders may depend on which sort of package it was installed from. Snaps and Flatpaks only have access to local home directories by default, but this can be changed.
                  So this may still be an issue after you mount the share.


                  Does /home/username/sahredfoldername exist already? You do need to create the directory if you haven't already done so.
                  Your personal search bot

                  Comment


                    #10
                    Hi! Thank you for your answer!

                    Originally posted by claydoh View Post
                    For Gimp to have access to external folders may depend on which sort of package it was installed from. Snaps and Flatpaks only have access to local home directories by default, but this can be changed.
                    So this may still be an issue after you mount the share.
                    I really dont remember how I installed GIMP. I guess it was by Snaps, but Im not sure.
                    Could you tell me what should I change in order to grant GIMP access to remote folders?

                    Originally posted by claydoh View Post
                    Does /home/username/sahredfoldername exist already? You do need to create the directory if you haven't already done so.
                    Yes, the folder exist.

                    Thanks!

                    Comment


                      #11
                      either your mount point is missing, or incorrect (typo?), or the path to the credentials file is. or maybe the server address? In any case, the "No such file or directory" indicates something of this nature.

                      Not sure if Discover's Snap interface has GUI options for this in 20.04 or not, but check and see if you have this:

                      Click image for larger version  Name:	Screenshot_20220119_132111-1.png Views:	0 Size:	83.6 KB ID:	659978
                      Last edited by claydoh; Jan 19, 2022, 12:27 PM.
                      Your personal search bot

                      Comment

                      Working...
                      X