Announcement

Collapse
No announcement yet.

What is the Monospace font in Kubuntu Groovy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] What is the Monospace font in Kubuntu Groovy

    I recently installed Kubuntu 20.10 on a machine and the default monospace font in Konsole and other locations is "Monospace". When I go to an older installation of Kubuntu (which has now been upgraded to 20.10) and choose "Monospace" as the font, it does not look anything like the one I see in my new machine. I think "Monospace" is just a symlink to some other font in both the cases. It looks like the older machine's "Monospace" points to Liberation Mono (it's just my guess). How can I find out which monospace font the latest version of KDE's "Monospace" is pointing to?

    #2
    In my Kubuntu 20.04.2 installation "Monospace" fonts are brought in by various packages, mainly Python ones.

    In the KMenu click on Settings -> Fonts -> Font Management and then put "Monospace" in the search bar. On my system none are shown because they are not system fonts. If you search for "mono" instead you'll see a list of fonts that have a mono style included.

    IF I open Muon and search for "Monospaced" I see a list of 7 monospaced fonts, none of which are installed on my machine. You can install one or all of them. I suspect that you can also download monospaced fonts from various internet sites (trust but verify) and install them as well
    Last edited by GreyGeek; Feb 14, 2021, 01:02 PM.
    "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
    – John F. Kennedy, February 26, 1962.

    Comment


      #3
      "Monospace" is a font alias (configured by fontconfig settings), you can check which font is used as "Monospace" with:
      Code:
      fc-match Monospace

      Comment


        #4
        You know you can select whatever monospaced font you want in System Settings > Fonts > Fixed width, right? WHen the selection windows opens, click the "Show only monospaced fonts" box and you'll get only those.

        IDK why the developer decided to name it "Fixed Width" rather than "Monospaced", the latter being a more accurate description IMO.
        Please Read Me
        Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

        Comment


          #5
          Thank you everyone for the helpful answers. I know how to install and change fonts. What I was not able to find out was which monospace font it is that "Monospace" is matched to, by default. Thank to you @kubicle now I know that in my older system, "Monospace" points to "Cousine" whereas the in the newer machines it points to "Noto Sans Mono" (not "Noto Mono"; don't know why there are two of them). For example, my old system shows this:
          Code:
          $ fc-match Monospace
          Cousine-Regular.ttf: "Cousine" "Regular"
          Now that I know what "Monospace" is matched to, is there a way I can change it to something else?

          Comment


            #6
            Originally posted by kayvee View Post
            Now that I know what "Monospace" is matched to, is there a way I can change it to something else?
            You'd need to change your fontconfig configuration.

            System wide fontconfig settings are in /etc/fonts, but since it can be a bit intimidating (with some wizardry involved), I'd recommend starting out with per-user configuration (unless you really really need a system wide setting).

            Example per-user config file ($HOME/.config/fontconfig/conf.d/90-mymonospace.conf):
            Code:
            <?xml version='1.0'?>
            <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
            <fontconfig>
            <!-- Set preferred monospace font. -->
            <alias>
             <family>monospace</family>
             <prefer><family>Hack</family></prefer>
            </alias>
            </fontconfig>
            This will change the "Monospace" font to Hack (which obviously needs to be installed, or the setting will fall back to the system wide default).

            You need to relog (or reboot) for the change to take effect.

            Code:
            [FONT=monospace][COLOR=#18B218]fc-match[/COLOR] Monospace
            Hack-Regular.ttf: "Hack" "Regular"
            [/FONT]

            Comment


              #7
              This does not work? Or am I missing something?

              Click image for larger version

Name:	Screenshot_20210214_181040.jpg
Views:	1
Size:	45.6 KB
ID:	645048
              I'll ask Jeeves

              Comment


                #8
                Originally posted by kayvee View Post
                ..."Noto Sans Mono" (not "Noto Mono"; don't know why there are two of them)...
                The "Sans" is shorthand for "Sans Serif." Sans is a word of French origin that has been adopted by English speakers without translation. It means "without." A "serif" is a line finishing off the main strokes of a character. This character S has serifs - the two ending lines at the top and bottom of the S, note this "S" does not have serifs. Therefore, the reason you have both "Noto Sans Mono" and "Noto Mono" is the first one has no serifs and the second one does. The font naming is shorted for the sake of brevity. "No more Tofu, Sans Serif, Monospaced" is the actual name of the font. As you can see, rather long. I believe, (I could be making this up) traditionally printed text used serifs because it was considered more elegant looking. However, the invention of computers and the very poor resolution of early monitors necessitated a cleaner, more simple font because serifs made the letters harder to read. So "sans serif" fonts became desirable.
                Last edited by oshunluvr; Feb 14, 2021, 05:59 PM.
                Please Read Me
                Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

                Comment


                  #9
                  When Kubicle talks EF Hutton listens!
                  "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
                  – John F. Kennedy, February 26, 1962.

                  Comment


                    #10
                    Originally posted by claydoh View Post
                    This does not work? Or am I missing something?
                    Of course it does, but the OP probably has a reason why he wants to change the "Monospace" font, since he specifically said he knows "how to install and change fonts". He could be using software that does not respect KDE font settings, or have a multitude of paragraph styles configured to use "Monospace" in publishing software, for example.

                    Comment


                      #11
                      Originally posted by kubicle View Post
                      Of course it does, but the OP probably has a reason why he wants to change the "Monospace" font, since he specifically said he knows "how to install and change fonts". He could be using software that does not respect KDE font settings, or have a multitude of paragraph styles configured to use "Monospace" in publishing software, for example.
                      Thank you again @kubicle. Indeed I have inherited some internal program that does not allow me to change the fonts and the default in it is set to use whatever the system calls "Monospace".

                      Comment

                      Working...
                      X