Announcement

Collapse
No announcement yet.

KMail has stopped working. "Akonadi not operational"

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    KMail is the default mail handler. No other setting changes were made, now I have made changes to some default programmes.

    Kmail gives an error:
    "The Akonadi personal information management service is not operational."
    below Red label with X mark on it. Below is Details...... When I click "Details" label: I get the same message Akonadi personal information manager is not operational
    Last edited by vsmmath; Oct 06, 2016, 11:08 PM.

    Comment


      #17
      In msg #5 you posted:
      2016-09-25T06:18:01.783233Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
      2016-09-25T06:18:01.783291Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
      2016-09-25T06:18:01.783343Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.15-0ubuntu0.16.04.1) starting as process 2291 ...

      2016-09-25T06:18:01.789853Z 0 [Warning] Can't create test file /home/muglurmat/.local/share/akonadi/db_data/muglurmat-desktop.lower-test
      2016-09-25T06:18:01.789917Z 0 [Warning] Can't create test file /home/muglurmat/.local/share/akonadi/db_data/muglurmat-desktop.lower-test
      2016-09-25T06:18:01.789941Z 0 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

      2016-09-25T06:18:01.789964Z 0 [ERROR] Aborting

      2016-09-25T06:18:01.789995Z 0 [Note] Binlog end
      2016-09-25T06:18:01.790085Z 0 [Note] /usr/sbin/mysqld: Shutdown complete"
      exit code: 1
      process error: "Unknown error"
      That you cannot create "test file"s suggests that you have a permissions problem. Check in ~./local/share/akonadi/db_data to see if muglurmat-desktop.low-test exists and if it does what permissions it and the akonadi/db_data directories have.

      One way you can approach this problem is to purge my_sql and KMail from your system, then reinstall KMail. It should bring in my_sql and an other additional packages.

      When you uninstall a package you should be careful to make sure it doesn't drag along other parts of the KDE desktop, as some packages often do. If that happens you can re-install the KDE metadesktop package, which will restore mission packages.
      Last edited by GreyGeek; Oct 07, 2016, 12:07 PM.
      "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
      – John F. Kennedy, February 26, 1962.

      Comment


        #18
        Originally posted by GreyGeek View Post
        One way you can approach this problem is to purge my_sql and KMail from your system, then reinstall KMail. It should bring in my_sql and an other additional packages.
        Purged my_sql and KMail from system.
        Reinstalled Kmail, anxiously clicked on KMail ........ same result. Akonadi is not operational

        In a situation like this as a newbie I would have re-installed OS. but after your suggestion reinstalling is never a solution, this has become a challenge. I want to know what has gone wrong.

        Comment


          #19
          How are you performing your package management; the updating of installed package? If you are using the command line (konsole), what commands are you using?

          What repositories are you using?
          Slava Ukraini! πŸ‡ΊπŸ‡¦
          Windows no longer obstruct my view.
          Using Kubuntu Linux since March 23, 2007.
          "It is a capital mistake to theorize before one has data." - Sherlock Holmes​

          Comment


            #20
            Originally posted by Snowhog View Post
            How are you performing your package management; the updating of installed package? If you are using the command line (konsole), what commands are you using?

            What repositories are you using?
            sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-core-5.5 mysql-client-core-5.5
            sudo rm -rf /etc/mysql /var/lib/mysql
            sudo apt-get autoremove
            sudo apt-get autoclean

            KMail i removed using Synaptic package manager.

            After re-install it did not work. This was at 3:30 in the morning. I gave feed back here and slept. Got up now, switched on the system, got a message Akonadi is requesting for pass word !
            Entered password and KMail is working. Problem solved. Thanks you for reading my attempts to correct the problem.

            GreyGeek, Thanks for the guidance. Now I will configure mail ID and start download of emails.
            Last edited by Snowhog; May 28, 2017, 06:08 PM.

            Comment


              #21
              Great!

              Also, Muon's problem with the one-off search has been fixed and now it works the way it always has, perfectly, so there is little need to re-install Synaptic.
              "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
              – John F. Kennedy, February 26, 1962.

              Comment


                #22
                Thank you GreyGeek,
                your guidance was really kept me going. I have installed Muon, had not tried recently.

                Comment

                Users Viewing This Topic

                Collapse

                There are 0 users viewing this topic.

                Working...
                X