Thank you GreyGeek,
your guidance was really kept me going. I have installed Muon, had not tried recently.
Announcement
Collapse
No announcement yet.
KMail has stopped working. "Akonadi not operational"
Collapse
This topic is closed.
X
X
-
Great!
Also, Muon's problem with the one-off search has been fixed and now it works the way it always has, perfectly, so there is little need to re-install Synaptic.
- Top
- Bottom
Leave a comment:
-
sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-core-5.5 mysql-client-core-5.5Originally posted by Snowhog View PostHow are you performing your package management; the updating of installed package? If you are using the command line (konsole), what commands are you using?
What repositories are you using?
sudo rm -rf /etc/mysql /var/lib/mysql
sudo apt-get autoremove
sudo apt-get autoclean
KMail i removed using Synaptic package manager.
After re-install it did not work. This was at 3:30 in the morning. I gave feed back here and slept. Got up now, switched on the system, got a message Akonadi is requesting for pass word !
Entered password and KMail is working. Problem solved. Thanks you for reading my attempts to correct the problem.
GreyGeek, Thanks for the guidance. Now I will configure mail ID and start download of emails.Last edited by Snowhog; May 28, 2017, 06:08 PM.
- Top
- Bottom
Leave a comment:
-
How are you performing your package management; the updating of installed package? If you are using the command line (konsole), what commands are you using?
What repositories are you using?
- Top
- Bottom
Leave a comment:
-
Purged my_sql and KMail from system.Originally posted by GreyGeek View PostOne way you can approach this problem is to purge my_sql and KMail from your system, then reinstall KMail. It should bring in my_sql and an other additional packages.
Reinstalled Kmail, anxiously clicked on KMail ........ same result. Akonadi is not operational
In a situation like this as a newbie I would have re-installed OS. but after your suggestion reinstalling is never a solution, this has become a challenge. I want to know what has gone wrong.
- Top
- Bottom
Leave a comment:
-
In msg #5 you posted:
That you cannot create "test file"s suggests that you have a permissions problem. Check in ~./local/share/akonadi/db_data to see if muglurmat-desktop.low-test exists and if it does what permissions it and the akonadi/db_data directories have.2016-09-25T06:18:01.783233Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
2016-09-25T06:18:01.783291Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
2016-09-25T06:18:01.783343Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.15-0ubuntu0.16.04.1) starting as process 2291 ...
2016-09-25T06:18:01.789853Z 0 [Warning] Can't create test file /home/muglurmat/.local/share/akonadi/db_data/muglurmat-desktop.lower-test
2016-09-25T06:18:01.789917Z 0 [Warning] Can't create test file /home/muglurmat/.local/share/akonadi/db_data/muglurmat-desktop.lower-test
2016-09-25T06:18:01.789941Z 0 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!
2016-09-25T06:18:01.789964Z 0 [ERROR] Aborting
2016-09-25T06:18:01.789995Z 0 [Note] Binlog end
2016-09-25T06:18:01.790085Z 0 [Note] /usr/sbin/mysqld: Shutdown complete"
exit code: 1
process error: "Unknown error"
One way you can approach this problem is to purge my_sql and KMail from your system, then reinstall KMail. It should bring in my_sql and an other additional packages.
When you uninstall a package you should be careful to make sure it doesn't drag along other parts of the KDE desktop, as some packages often do. If that happens you can re-install the KDE metadesktop package, which will restore mission packages.Last edited by GreyGeek; Oct 07, 2016, 12:07 PM.
- Top
- Bottom
Leave a comment:
-
KMail is the default mail handler. No other setting changes were made, now I have made changes to some default programmes.
Kmail gives an error:
"The Akonadi personal information management service is not operational."
below Red label with X mark on it. Below is Details...... When I click "Details" label: I get the same message Akonadi personal information manager is not operationalLast edited by vsmmath; Oct 06, 2016, 11:08 PM.
- Top
- Bottom
Leave a comment:
-
That's interesting. I used Chromium for a while but removed it because it didn't allow video downloads. It never once complained about my KMail. I don't know why Chromium would complain about KMail, it is none of Chromium's business, unless you linked KMail and Chromium (like I do with FF) so that I can click on a letter icon to open an email with the URL in body and the title of the URL in the subject line, add some comments and then send it.Originally posted by vsmmath View Postchromium, that was handling mail also. It kept warning me that I am using un-secure apps to access mail and kept bugging me to enter PW again and again, so removed. Now I am working with only FF.
What are your settings for email and browser in SystemSettings5-->Applications-->Default Applications?
- Top
- Bottom
Leave a comment:
-
chromium, that was handling mail also. It kept warning me that I am using un-secure apps to access mail and kept bugging me to enter PW again and again, so removed. Now I am working with only FF.
- Top
- Bottom
Leave a comment:
-
What package did you remove?
Sent from my iPhone using Tapatalk
- Top
- Bottom
Leave a comment:
-
Now I am completely confused. Three files you mention, are not on my system. Searched from \ from Dolphin and tried locate each file from console, as su.Originally posted by GreyGeek View PostCheck the owner and permissions on mysql.conf, db_data and mysql.socket. One of them is not owned by you or has no write permission.
Where am I going wrong ?
I updated and upgraded and removed one software from system. After that Kmail stopped functioning. It was working perfect up to that point.
Thanks for any suggestion.
- Top
- Bottom
Leave a comment:
-
Thank you GreyGeek,
I am away from my system in Bangalore. I will check it on Wednesday.
- Top
- Bottom
Leave a comment:
-
Check the owner and permissions on mysql.conf, db_data and mysql.socket. One of them is not owned by you or has no write permission.
Sent from my iPhone using Tapatalk
- Top
- Bottom
Leave a comment:
-
I reinstalled all the mentioned files, no use Kmail is giving the same error. Akonadi exits with error 1 even now
- Top
- Bottom
Leave a comment:
-
Users Viewing This Topic
Collapse
There are 0 users viewing this topic.
Leave a comment: