Results 1 to 7 of 7

Thread: Volume always muted when system is booted

  1. Back To Top    #1
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,594
    Threads
    1012
    Local Date
    May 26th 2020
    Local Time
    07:43 AM

    Volume always muted when system is booted

    It's a minor annoyance only, but every time I boot up my laptop, the System Volume is muted. I can set the volume from the System Tray, but it won't survive a reboot. Thoughts?
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  2. Back To Top    #2
    Kubuntu as a Second Language
    Join Date
    Apr 2008
    Location
    Auckland, New Zealand
    Posts
    1,881
    Threads
    68
    Local Date
    May 27th 2020
    Local Time
    12:43 AM
    A root owned file or directory? On my Eoan,
    Code:
    $ touch ts
    $ # change the audio volume...
    $ find .config -newer ts
    .config/pulse/a112c35e9614496caa1b3e9cdf66b7f5-device-volumes.tdb
    is where the the volume is saved, you might check around there. .tdb files, "trivial database", are some awful (IMO) samba format that pulseaudio uses.
    Regards, John Little

  3. Back To Top    #3
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,594
    Threads
    1012
    Local Date
    May 26th 2020
    Local Time
    07:43 AM
    Not an ownership problem. All the files in .config/pulse are owned by me, and all have rw attributes.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  4. Back To Top    #4
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,475
    Threads
    1168
    Local Date
    May 26th 2020
    Local Time
    07:43 AM
    Have you tried to use alsamixer?

    Execute:
    sudo alsactl store Set your volume levels and other levels, then hit ESC
    This should save alsamixer configurations to /etc/asound.state which gets loaded every startup.

    Another option is using "sudo alsactl store" after setting your sound volumes in the system tray.

    DISCLAIMER: Some advise against using alsamixer when pulseaudio is installed. It hasn't given my setup any problems. But, if that were the case then why the following:

    /usr/share/pulseaudio/alsa-mixer
    /usr/share/pulseaudio/alsa-mixer/paths
    /usr/share/pulseaudio/alsa-mixer/profile-sets
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-aux.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-dock-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-fm.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-front-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-headphone-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-headset-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic-always.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-linein.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic-line.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf.common
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-rear-mic.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-tvtuner.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input-video.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf.common
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones-2.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-mono.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker-always.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf
    /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-0.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-1.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-2.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-3.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-4.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-5.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-6.conf
    /usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-7.conf
    /usr/share/pulseaudio/alsa-mixer/paths/iec958-stereo-input.conf
    /usr/share/pulseaudio/alsa-mixer/paths/iec958-stereo-output.conf
    /usr/share/pulseaudio/alsa-mixer/paths/steelseries-arctis-output-chat-common.conf
    /usr/share/pulseaudio/alsa-mixer/paths/steelseries-arctis-output-game-common.conf
    /usr/share/pulseaudio/alsa-mixer/paths/usb-gaming-headset-input.conf
    /usr/share/pulseaudio/alsa-mixer/paths/usb-gaming-headset-output-mono.conf
    /usr/share/pulseaudio/alsa-mixer/paths/usb-gaming-headset-output-stereo.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/cmedia-high-speed-true-hdaudio.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/dell-dock-tb16-usb-audio.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/force-speaker-and-int-mic.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/force-speaker.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/kinect-audio.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/maudio-fasttrack-pro.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-audio4dj.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-audio8dj.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-korecontroller.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktor-audio10.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktor-audio2.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktor-audio6.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktorkontrol-s4.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/sb-omni-surround-5.1.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/steelseries-arctis-common-usb-audio.conf
    /usr/share/pulseaudio/alsa-mixer/profile-sets/usb-gaming-headset.conf
    AND:
    /usr/lib/systemd/system/alsa-restore.service
    /usr/lib/systemd/system/sound.target.wants/alsa-restore.service
    The alsa-restore.service contains:
    Code:
    $ cat /usr/lib/systemd/system/alsa-restore.service 
    #
    # Note that two different ALSA card state management schemes exist and they
    # can be switched using a file exist check - /etc/alsa/state-daemon.conf .
    #
    
    [Unit]
    Description=Save/Restore Sound Card State
    Documentation=man:alsactl(1)
    ConditionPathExists=!/etc/alsa/state-daemon.conf
    ConditionPathExistsGlob=/dev/snd/control*
    After=alsa-state.service
    
    [Service]
    Type=oneshot
    RemainAfterExit=true
    ExecStartPre=/bin/mkdir -p /run/alsa
    ExecStart=-/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime restore
    ExecStop=-/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime store
    which uses alsactl.

    I checked my alsa-restore.service status and was shown this:

    Code:
    $ sudo systemctl status alsa-restore.service
    [sudo] password for jerry: 
    ● alsa-restore.service - Save/Restore Sound Card State
         Loaded: loaded (/lib/systemd/system/alsa-restore.service; static; vendor preset: enabled)
         Active: active (exited) since Fri 2020-03-20 11:29:00 CDT; 1h 5min ago
           Docs: man:alsactl(1)
        Process: 916 ExecStartPre=/bin/mkdir -p /run/alsa (code=exited, status=0/SUCCESS)
        Process: 973 ExecStart=/usr/sbin/alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime>
       Main PID: 973 (code=exited, status=0/SUCCESS)
    
    Mar 20 11:29:00 Aspire-V3-771 systemd[1]: Starting Save/Restore Sound Card State...
    Mar 20 11:29:00 Aspire-V3-771 systemd[1]: Started Save/Restore Sound Card State.
    Last edited by GreyGeek; Mar 20th 2020 at 05:37 PM.

  5. Back To Top    #5
    Kubuntu as a Second Language
    Join Date
    Apr 2008
    Location
    Auckland, New Zealand
    Posts
    1,881
    Threads
    68
    Local Date
    May 27th 2020
    Local Time
    12:43 AM
    If Greygeek's suggestions don't help, a workaround could be to set the volume in a startup script.
    Code:
    $ pactl set-sink-volume @DEFAULT_SINK@ 32768
    sets the default volume to 50%, 32768 being 50% of 65536.
    Regards, John Little

  6. Back To Top    #6
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,594
    Threads
    1012
    Local Date
    May 26th 2020
    Local Time
    07:43 AM
    So, attempting to run sudo alsactl store resulting in:

    sudo: alsactl: command not found

    Seems that alsa-utils needs to be installed. So, I installed it.

    sudo alsactl store then executes; at least, it doesn't present the error; I'm returned to the prompt.

    With alsa-utils or without, I still don't have even notification sounds (Configure Notifications - System Settings Module). None of the events that are 'active' play the specified .ogg file. What is interesting, is that if I right-click on the speaker icon in the System Tray and click on Configure Audio Volume... and click on Audio > Advanced and click on Front Left or Front Right, I hear "Front left" and "Front right", so obviously sound functions.

    Also of note: After installing alsa-utils and rebooting (ensuring that the volume was not zero (System Tray > Audio Volume), rebooting resulted in the volume not being muted; it retained the volume setting. This was true even after I purged alsa-utils and rebooted.
    Last edited by Snowhog; Mar 21st 2020 at 01:37 AM.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  7. Back To Top    #7
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,594
    Threads
    1012
    Local Date
    May 26th 2020
    Local Time
    07:43 AM
    This issue is now 'Solved'. Not sure if it was the installation of alsa-utils (installed it; purged it; installed it again), or following the guidance found here. What ever. alsa-utils is installed, and I followed that links guidance and added options snd-hda-intel model=generic to the end of /etc/modprobe.d/alsa-base.conf. A reboot and I have system notification sounds.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •