Results 1 to 8 of 8

Thread: logs filling up with PCIe bus errors, can't disable

  1. Back To Top    #1
    Senior Member
    Join Date
    Jul 2013
    Posts
    231
    Threads
    60
    Local Date
    Apr 9th 2020
    Local Time
    09:13 AM

    logs filling up with PCIe bus errors, can't disable

    I have just done a fresh install of KDE Neon user edition (system setup described in my signature - it's the first machine listed there).

    I am experiencing the same error described here: http://askubuntu.com/questions/77189...rity-corrected
    In my case, although I see the errors fill the screen when booting, they don't interfere with anything, I can boot as normal. However, as long as my system is running, these errors fill up the kernel and system logs to the point where my used disk space is increasing by gigabytes each hour.

    Prior to installing Neon, I was using Kubuntu 16.04, and although I had the same error there, I was able to disable it by adding pci=noaer to the bootline. I tried the same thing with my Neon installation but it had no effect. I also added pci=nomsi for good measure; no luck.

    Any suggestions? I could possibly work around the issue by setting up a cron job to routinely clear the logs, but someone suggested the constant writing to disk might actually harm it in the long run. I'd rather stop it happening altogether.
    "Stella", HP Pavilion 15-ak006TX: KDE Neon User Edition dual-booted with Windows 10, 8gb RAM, Intel i7-6700HQ CPU, NVIDIA GeForce GTX950M graphics, 2 TB hard drive

  2. Back To Top    #2
    Senior Member
    Join Date
    Jul 2013
    Posts
    231
    Threads
    60
    Local Date
    Apr 9th 2020
    Local Time
    09:13 AM
    I seem to have found a solution, albeit a bit of a hack.
    In this thread:
    http://forums.fedoraforum.org/showthread.php?t=292543

    I tried the masking trick:
    systemctl mask systemd-journald.service

    Now my logs aren't filling up anymore, hard disk isn't making constant creaking noises, and CPU usage is even lower! nice.
    Last edited by dbaker; Oct 9th 2016 at 11:16 AM.
    "Stella", HP Pavilion 15-ak006TX: KDE Neon User Edition dual-booted with Windows 10, 8gb RAM, Intel i7-6700HQ CPU, NVIDIA GeForce GTX950M graphics, 2 TB hard drive

  3. Back To Top    #3
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,319
    Threads
    1153
    Local Date
    Apr 8th 2020
    Local Time
    05:13 PM
    That is a solution, but it shuts down journalctl listing all together.
    Individual services have conf files that can be edited in systemd-gui to selectively turn off logging for the offending service. That will allow future problems to warn you in the journal.

    Here is the systemd-gui:
    Click image for larger version. 

Name:	sysstemd-gui.jpg 
Views:	9 
Size:	111.2 KB 
ID:	6733
    When you select one of the entries and then click on the "Conf" tab you will get this screen:
    Click image for larger version. 

Name:	systemd-gui-conf.jpg 
Views:	6 
Size:	75.6 KB 
ID:	6734
    You can click on the right column adjacent to the property you want to change and that column entry will change to a drop-down combo box. Select the appropriate destination. Then save (apply) the changes.
    For a specific PCI service, you can modify the "LogTarget" or the "DefaultStandardOutput", or both, to another destination.

    That way, all the other services, even other PCI services, can continue logging and warn you if a problem arises.

    EDIT: I forgot to mention that this ability to use systemd-gui (systemd-ui) is one reason why I've become a fan of systemd. It is a one point of control of ALL system services, devices, sockets, targets, mounts, automounts, swaps, paths, timers (cron), etc...

    Why Systemd?
    Last edited by GreyGeek; Oct 10th 2016 at 02:53 AM.

  4. Back To Top    #4
    Senior Member
    Join Date
    Jul 2013
    Posts
    231
    Threads
    60
    Local Date
    Apr 9th 2020
    Local Time
    09:13 AM
    I installed systemd-ui but it looks a bit different to your screenshot and doesn't have a "conf" tab and I couldn't figure out what to do with it:
    Click image for larger version. 

Name:	Screenshot_20161010_143048.png 
Views:	3 
Size:	94.8 KB 
ID:	6736
    "Stella", HP Pavilion 15-ak006TX: KDE Neon User Edition dual-booted with Windows 10, 8gb RAM, Intel i7-6700HQ CPU, NVIDIA GeForce GTX950M graphics, 2 TB hard drive

  5. Back To Top    #5
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,319
    Threads
    1153
    Local Date
    Apr 8th 2020
    Local Time
    05:13 PM
    That is the poor version. That';s what I had running initially as well. Then I noticed that Neon had the good version and I compared what I had installed with what Neon had installed.
    I installed
    systemd-gui (which is a transitional package for systemd-ui)
    but I also installed (or systemd-gui did, I don't remember which)
    python3-systemd
    systemd-manager
    kde-config-systemd
    libsystemd0
    libsystemd-sysv
    libpam-systemd

    I think that kde-config-systemd is the one that creates the better gui, but that is just a guess.

    :~$ apt-cache rdepends systemd-ui
    systemd-ui
    Reverse Depends:
    systemd
    systemd
    systemd
    systemd-gui
    and
    :~$ apt-cache rdepends systemd-sysv
    systemd-sysv
    Reverse Depends:
    initramfs-tools
    libpam-systemd
    systemd-sysv:i386
    |init
    systemd-sysv:i386
    upstart-sysv
    systemd-sysv:i386
    libpam-systemd
    systemd-sysv:i386
    initramfs-tools
    |init
    systemd-sysv:i386
    xfce4-session
    systemd-sysv:i386
    tuxonice-userui
    systemd-sysv:i386
    systemd-cron
    systemd-sysv:i386
    |numad
    systemd-sysv:i386
    gpsd
    systemd-sysv:i386
    freeipa-server
    systemd-sysv:i386
    dbus-user-session
    systemd-sysv:i386
    upstart-sysv
    systemd-sysv:i386
    ubuntu-standard
    systemd-sysv:i386
    libpam-systemd
    systemd-sysv:i386
    friendly-recovery
    systemd-sysv:i386
    |init
    systemd-sysv:i386
    and
    :~$ apt-cache depends kde-config-systemd
    kde-config-systemd
    Depends: systemd
    systemd:i386
    Depends: libc6
    Depends: libgcc1
    Depends: libkf5auth5
    Depends: libkf5configwidgets5
    Depends: libkf5coreaddons5
    Depends: libkf5i18n5
    Depends: libkf5kiocore5
    Depends: libkf5widgetsaddons5
    Depends: libqt5core5a
    Depends: libqt5dbus5
    |Depends: libqt5gui5
    Depends: libqt5gui5-gles
    Depends: libqt5widgets5
    Depends: libstdc++6
    Depends: libsystemd0
    Last edited by GreyGeek; Oct 10th 2016 at 05:05 PM.

  6. Back To Top    #6
    Senior Member
    Join Date
    Jul 2013
    Posts
    231
    Threads
    60
    Local Date
    Apr 9th 2020
    Local Time
    09:13 AM
    Thanks, I found it! Installing kde-config-systemd gave me the nicer GUI, it shows up as "Systemd: configure the systemd daemon" when I search in the launcher.

    I set the DefaultStandardOutput of the rogue service to null, hope that's right.
    I then reversed the masking I did earlier using:
    Code:
    systemctl mask systemd-journald.service
    I'll keep you posted on whether it works.

    UPDATE: I've rebooted since taking the steps mentioned in this post and so far there have been no PCIe bus errors written to the log, or displayed during boot. Looks like it worked!
    Last edited by dbaker; Oct 11th 2016 at 09:24 AM.
    "Stella", HP Pavilion 15-ak006TX: KDE Neon User Edition dual-booted with Windows 10, 8gb RAM, Intel i7-6700HQ CPU, NVIDIA GeForce GTX950M graphics, 2 TB hard drive

  7. Back To Top    #7
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,319
    Threads
    1153
    Local Date
    Apr 8th 2020
    Local Time
    05:13 PM

    logs filling up with PCIe bus errors, can't disable

    Great!
    BTW, the new Systemd GUI should be at the bottom of the systemsettins5 GUI, in a section by itself.

    Using the GUI makes controlling the services and other things as easy as falling off a log.

    16.04 is only half way between Upstart and full Systemd control. This is evident by the number of scripts still in /etc/init, and the fact that 16.04 still has upstart installed and running at boot up. RedHat's latest release does not have any scripts in /etc/init.d. Everything is controlled by systemd.
    Last edited by GreyGeek; Oct 11th 2016 at 12:47 PM.

  8. Back To Top    #8
    Senior Member
    Join Date
    Jul 2013
    Posts
    231
    Threads
    60
    Local Date
    Apr 9th 2020
    Local Time
    09:13 AM
    ah yep, it's showing up in system settings now. it wasn't there before.

    as easy as falling off a log... a log, eh... I'm sure that pun wasn't intended but it's a good'un!
    "Stella", HP Pavilion 15-ak006TX: KDE Neon User Edition dual-booted with Windows 10, 8gb RAM, Intel i7-6700HQ CPU, NVIDIA GeForce GTX950M graphics, 2 TB hard drive

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •