Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: KDE screw up: baloo-file indexer - how to shut it down

  1. Back To Top    #1
    Esteemed Member
    Join Date
    Sep 2007
    Location
    Spokane, Washington
    Posts
    747
    Threads
    189
    Local Date
    Jun 3rd 2020
    Local Time
    06:20 PM

    KDE screw up: baloo-file indexer - how to shut it down

    Just updated my last box - my main one - to KB 14.04. As I'm adjusting various things, I notice that something is seriously devouring CPU cycles. It turns out to be something I've never heard of - "baloo-file". Here I learn that it's an improvement on Nepomuk. But I detest Nepomuk and have never used it. Recoll (it's in the packages) does the job of desktop file indexing far better, and I've been delighted with it since SnowHog suggested it to me a while back. (thank you thank you!)

    Now I find that in System Settings there is no entry for Nepomuk. Can't shut the damned thing off. No entry for baloo either. We're having this monster forced on us? THIS is the much touted configurability of Kubuntu in action? Huh?

    This comment on the Arch Linux bbs tells you how to shut this thing down: Go to System Settings -> Desktop Search, and make sure your home directory is in the exclusion list. Mine was, but somehow it wasn't turned on. Simply clicking "Apply" did the trick. I got back control of my computer...at least until the next upgrade.

    What's very odd is that this problem did NOT occur on the other box I merely updated, nor on the two boxes on which I did a clean install of KB 14.04. On all of these 3, the Desktop search exclusion list is simply empty, and search is not running. I have no idea how to make sense of this.


    Last edited by tomcloyd; Apr 21st 2014 at 08:16 PM. Reason: added information

  2. Back To Top    #2
    Contributing Member Shaika-Dzari's Avatar
    Join Date
    Apr 2014
    Posts
    27
    Threads
    3
    Local Date
    Jun 3rd 2020
    Local Time
    02:20 PM
    I personnally used the trick from gentoo forum : symlink baloo to /bin/true :

    Code:
    sudo mv /usr/bin/baloo_file /usr/bin/baloo_file-orig
    sudo ln -s /bin/true /usr/bin/baloo_file
    sudo mv /usr/bin/baloo_file_cleaner /usr/bin/baloo_file_cleaner-orig
    sudo ln -s /bin/true /usr/bin/baloo_file_cleaner
    sudo mv /usr/bin/baloo_file_extractor /usr/bin/baloo_file_extractor-orig
    sudo ln -s /bin/true /usr/bin/baloo_file_extractor
    Maybe a little overkill but it get the job done

  3. Back To Top    #3
    Esteemed Member
    Join Date
    Sep 2007
    Location
    Spokane, Washington
    Posts
    747
    Threads
    189
    Local Date
    Jun 3rd 2020
    Local Time
    06:20 PM
    Quote Originally Posted by Shaika-Dzari View Post
    Maybe a little overkill but it get the job done
    You may have the right approach. After updating the System Settings > Desktop Indexer exclusion list as I described, I discovered a process with "baloo" in its name still running. I killed it.

    As a test, after reading your post, I just now rebooted to see what would get automatically launched.

    Now, the only live process with "baloo" in its name now is "akonadi_baloo_indexer", but it's asking nothing of the CPU.

    I note that this "akonadi_baloo_indexer" program is not one to which you gave any attention. Watching my System Monitor, it does not appear to be a problem. I'll keep watching to see if it activates. However, if it does, I'm not sure if your "overkill" solution would deal with it. What do you think?

  4. Back To Top    #4
    Emergent AI kubicle's Avatar
    Join Date
    Dec 2005
    Posts
    4,692
    Threads
    90
    Local Date
    Jun 3rd 2020
    Local Time
    09:20 PM
    Quote Originally Posted by tomcloyd View Post
    You may have the right approach. After updating the System Settings > Desktop Indexer exclusion list as I described, I discovered a process with "baloo" in its name still running. I killed it.

    As a test, after reading your post, I just now rebooted to see what would get automatically launched.

    Now, the only live process with "baloo" in its name now is "akonadi_baloo_indexer", but it's asking nothing of the CPU.

    I note that this "akonadi_baloo_indexer" program is not one to which you gave any attention. Watching my System Monitor, it does not appear to be a problem. I'll keep watching to see if it activates. However, if it does, I'm not sure if your "overkill" solution would deal with it. What do you think?
    Akonadi baloo indexer is separate from the file indexer. The Akonadi Agent indexes your mail (it enables a few things in kmail such as email text searching and autocompletion of emails from addressbook, for example). IME, it behaves better than the file indexer, but if you really want to also disable the akonadi agent, you can do it with:
    1. copy /usr/share/akonadi/agents/akonadibalooindexingagent.desktop as ~/.local/share/akonadi/agents/akonadibalooindexingagent.desktop
    2. edit ~/.local/share/akonadi/agents/akonadibalooindexingagent.desktop and change:
    X-Akonadi-Capabilities=Unique,Autostart --> X-Akonadi-Capabilities=Unique
    3. remove the baloo indexing agent with "akonadiconsole" (you may need to install package "akonadiconsole")

  5. Back To Top    #5
    Esteemed Member
    Join Date
    Sep 2007
    Location
    Spokane, Washington
    Posts
    747
    Threads
    189
    Local Date
    Jun 3rd 2020
    Local Time
    06:20 PM
    Very interesting. Yeah, I want it GONE. Recoll is perfectly manageable and does an excellent job without becoming intrusive.

    Thanks for the additional info. Am making careful notes.

  6. Back To Top    #6
    Insert Pithy Nothingness here claydoh's Avatar
    Join Date
    Sep 2005
    Location
    Savannah GA
    Posts
    8,240
    Threads
    228
    Local Date
    Jun 3rd 2020
    Local Time
    02:20 PM
    Homepage: Go to claydoh's homepage
    to disable baloo, you just have to have your /home dir in the Do Not Search area.

  7. Back To Top    #7
    Emergent AI kubicle's Avatar
    Join Date
    Dec 2005
    Posts
    4,692
    Threads
    90
    Local Date
    Jun 3rd 2020
    Local Time
    09:20 PM
    Quote Originally Posted by claydoh View Post
    to disable baloo, you just have to have your /home dir in the Do Not Search area.
    This only affects the baloo file indexer, not the baloo akonadi agent.
    Last edited by kubicle; Apr 22nd 2014 at 04:46 AM.

  8. Back To Top    #8
    Esteemed Member
    Join Date
    Sep 2007
    Location
    Spokane, Washington
    Posts
    747
    Threads
    189
    Local Date
    Jun 3rd 2020
    Local Time
    06:20 PM
    Quote Originally Posted by claydoh View Post
    to disable baloo, you just have to have your /home dir in the Do Not Search area.
    My experience this evening confirms this. This change alone fixes the problem.

  9. Back To Top    #9
    Esteemed Member josefko's Avatar
    Join Date
    May 2009
    Location
    Czech Republic
    Posts
    516
    Threads
    17
    Local Date
    Jun 4th 2020
    Local Time
    01:20 AM
    This is the second thread with the same theme, the first was here https://www.kubuntuforums.net/showth...ng-performance
    After Greygeek's advice to start baloo again I removed home folder from the removed list and baloo now works without problems.
    Kubuntu 16.04 on two computers and Kubuntu 17.04 on DELL Latitude 13

  10. Back To Top    #10
    Esteemed Member
    Join Date
    Sep 2007
    Location
    Spokane, Washington
    Posts
    747
    Threads
    189
    Local Date
    Jun 3rd 2020
    Local Time
    06:20 PM
    Quote Originally Posted by josefko View Post
    This is the second thread with the same theme, the first was here https://www.kubuntuforums.net/showth...ng-performance
    After Greygeek's advice to start baloo again I removed home folder from the removed list and baloo now works without problems.
    But getting it to WORK is absolutely NOT what this thread is about! Did you read my first post? I didn't want or use Nepomuk and am even less happy with baloo. Stopping baloo is what this thread is about, and it appears (to me) that the problem is solved, as has already been detailed.

Page 1 of 2 12 LastLast

Similar Threads

  1. Baloo links
    By Rog132 in forum KDE Support
    Replies: 11
    Last Post: Nov 20th 2015, 08:27 PM
  2. [SOLVED] File indexer not running
    By doctordruidphd in forum KDE Support
    Replies: 14
    Last Post: Jul 12th 2012, 05:08 PM
  3. When the U.S. feds shut off "excessive file sharing" we could do this...
    By woodsmoke in forum Kubuntu or Linux Discussions
    Replies: 1
    Last Post: Feb 22nd 2011, 02:02 PM
  4. Replies: 2
    Last Post: Nov 15th 2010, 05:02 PM
  5. System won't shut down after choosing "Shut Down" command
    By dazedboy in forum Software Support
    Replies: 3
    Last Post: Sep 25th 2009, 06:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •