No announcement yet.

Can't boot after install in to an USB drive.

  • Filter
  • Time
  • Show
Clear All
new posts

    Can't boot after install in to an USB drive.

    My situation is this:

    I want to install kubuntu 22.04 into an USB drive (1TB NVME Team drive inside a USB SSK portable case)

    I have to work with an old Lenovo desktop PC with 4gb RAM and an I3-2120. It has a HDD with windows only as limited user.

    Mi plan is to arrive at work, connect my USB drive, and use my OS from there letting the local HDD intact and not using a live USB because it's not enough to my needs.

    I'm allowed to open it`s case and disconnect the local drive only certain days, so I can test this in a limited amount of time.

    I haven't permission to make permanent system modifications, and I shouldn`t cause this PC could be gone whithout warning.

    There is no Secure Boot option to select.

    My problem is:

    System default boot is in AUTO; UEFI first, but Windows is installed in BIOS (legacy CSM) mode. I changed to Legacy Only and boots correctly always.

    I tried install kubuntu on my USB dive in UEFI, doesn`t boot in all tries, Result is Error Code 1962 "No Operating System Found".

    I tried to trick the Lenovo UEFI into think is booting a Windows, but it din`t work either.

    The only thing that kind of worked is installing in BIOS (legacy CSM), then first boot it's OK, but after reboot it keep failing to never boot again with same error code.

    My drive has a GPT partition table, It doesn't let me create a MBR table. It gives me error.

    Why it manages to boot only once? What can I do?

    Also, How I can record the relevant information before first boot and after reboot (with a live distro)? so I can post the differences.

    Originally posted by Megapija View Post
    Also, How I can record the relevant information before first boot and after reboot (with a live distro)? so I can post the differences.
    A bit cumbersome, but it should work without knowing the specifics of your setup or your skill level (you only need a free USB port and an additional empty USB stick (preferably formatted in exFAT so different operating systems can read it):
    • Wipe your external USB NVMe (you could also already prepare it/make partitions accordingly with something like GParted live).
    • Boot into a Kubuntu live session ( -> "Try Kubuntu").
    • After you have installed Kubuntu from the live USB stick to your external USB NVMe ( -> do not select "Download updates while installing Kubuntu"), insert your empty USB stick, open Konsole and Kate (still in the live session).
    • In Konsole get some relevant information, e.g. with df -hT ; lsblk ; lsblk -f ; sudo fdisk -l ; lsusb -tvv - and whatever else you think could be important.
    • Copy the output from Konsole to Kate and save it as a text file to your empty USB stick. You can use this method again after reboot (something like cat /etc/default/grub et altera could also be useful then).
    • Unmount the USB stick with the text and put it into another computer - now you can post this text (or parts of it) for example in this thread from there.
    Hope this helps at all…

    PS: I don't think there is any need to disconnect the local HDD from the Laptop during installation, if you are careful to install everything to the external USB NVMe (including the bootloader).
    Last edited by Schwarzer Kater; Feb 23, 2023, 05:44 PM. Reason: added PS
    Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
    Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13" • and others

    get rid of Snap script (20.04 +)reinstall Snap for release-upgrade script (20.04 +)
    install traditional Firefox script (22.04 +)​ • install traditional Thunderbird script (24.04)


      Ok. Thank you. I'll do that next week.

      I know a just a bit about bootloaders and grub, but not enough to save its data.

      How do I perform a complete grub relevant data saving of my new grub? (new installed on USB nvme)

      Also I have to mention that Boot Repair from ppa:yannubuntu/boot-repair couldn`t help me not even once.

      Boot Repair always says that UEFI grub is needed and corrected with success but after power off and restart my system can't find a boot disk.
      This happens on UEFI and BIOS.

      Next try I'll prepare a MBR live USB stick, and delete the EFI files. Maybe the Kubuntu installer tries to install UEFI anyway.
      I'll try to create a MBR partition table again but I think it won't let me.



        Ok. All done. Same results as expected.

        This time it let me create a MBR table instead.

        I deleted efi files from live usb stick, just in case.

        Then reboot to the first boot from USB SSD.
        System is set to legacy only but it doesn't boot.

        I have to select as alternative Boot mode with F12, and then from two booting options that appear, USB Legacy and UEFI, select UEFI.
        Wich is strange cause it's not what I have intended​

        ​​​​​​System boots and run fine. No updates, just notifications. And now first system reboot wich leads to no boot loop.

        Last edited by Megapija; Mar 02, 2023, 12:52 PM.


          Anyone has an idea?


            Try this:
            "A nation that is afraid to let its people judge the truth and falsehood in an open market is a nation that is afraid of its people.”
            – John F. Kennedy, February 26, 1962.


              Hi. Thanks for you suggestion of "Mkusb" for my installation.

              Point in case:

              I'd tried a bunch of persistent portable distros that allowed me to work in the past, ie: MX LINUX, Knoppix, Etc. All of them share the same issue;

              File System adds new files in a separate file that loads on memory every time you update or install new software; It creates secuencial large files that modify previous changes. It grows as a summatory (maybe exponentialy)

              This has a severe impact on memory usage.
              I have only 4gb.
              Just to put in perspective, once I tried with MX LINUX (Lxde), to sudo update/upgrade the "base distro" and ran out of memory for the reason above.

              Does this method make the same memory use or it behaves like a normal distro installation?​
              Last edited by Megapija; Mar 10, 2023, 07:35 AM.


                Are you making sure that the boot loader files are going to the USB drive?

                See step 5 here
                One doesn't need to do an overly complex manual install, but no matter if it is EFI or MBR, for an external drive you need to specify where the boot stuff goes. This needs to be done using the manual options.
                For efi, /dev/sdX[number]
                For MBR /dev/sdX (no number)

                The live session is a compressed OS image that is loaded/unloaded from ram, so yes, memory usage can rise as you use it more - even with persistence.
                A full install to a large drive is better suited for the purpose.


                  Thanks claydoh for your reply.

                  I will inspect and try that.

                  I must reiterate that using my method (auto install, auto partition, all disk, only live distro and USB SSD dentiny pluged in) "first boot is totally successful", It works like a charm at reboot.

                  I thought the issue was updating the system files, but no. Even not doing update/upgrade, just booting up, and restart, with only USB SSD pluged in, second time, seems not to find a valid boot loader.

                  Also, there is no other drive than USB SSD to asignate boot sector to.


                    Originally posted by Megapija View Post
                    Also, there is no other drive than USB SSD to asignate boot sector to.
                    The one on the internal drive. (which you say is removed?)
                    I use a USB drive regularly as a removable portable OS with a full OS install, and have not ever seen this sort of thing, though HP systems I have used have sometimes been inconsistent with whether they would see a USB drive as EFI or MBR.
                    Maybe your system just has crappy EFI /bios implementation?
                    But, recent Linux isos do seem to have issues with some older MBR bios, particularly Ubuntu.
                    Lack of user testing and reporting, as these systems age.
                    Maybe try a non-Ubuntu and non-Debian distro, for comparison.
                    Last edited by claydoh; Mar 10, 2023, 09:50 AM.


                      Hi again.

                      And thank you Claydoh for your suggestion.

                      I installed and use Manjaro KDE desktop succesfully. So this problem is Kubuntu (or debian) related. I would be good to know where's the error exactly.

                      Issues for Manjaro's forum I'll investigate:

                      Although it works, sometimes I have to reset when booting up couse it's get stuck in Manjaro three point black loading screen. And something eates up my CPU periodically for a few minutes when running normally.

                      If someone knows how to compare Manjaro boot with Kubuntu boot, in this specific case, please submit.

                      Thank you all.