Announcement

Collapse
No announcement yet.

How to adjust amount of mouse acceleration (NOT sensitivity) in KDE/Plasma?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] How to adjust amount of mouse acceleration (NOT sensitivity) in KDE/Plasma?

    Hi,

    I'm coming from Linux Mint and I've just installed Kubuntu 21.10 and I can't find a way to adjust the amount of mouse acceleration. I can only turn it on or off.
    I would like to have SOME acceleration but when it is enabled, it is just too much for me.

    In Mint I have a bar to adjust the amount of mouse sensitivity and one for acceleration.

    I also couldn't find something regarding that on the web, which I find rather strange. Is this really such a uncommon thing to ask for?

    Cheers

    ----------------------------------------------------------------------------------------------------------------------

    SOLUTION:

    Mouse acceleration can obviously not be changed within Kubuntu's settings. However, it is doable with very few commands.

    I found the solution here: https://wiki.archlinux.org/title/Mouse_acceleration

    Step 1: Identify device ID with
    Code:
    xinput list
    Step 2: Change acceleration factor with
    Code:
    xinput --set-prop <device ID> 'libinput Accel Speed' <acceleration factor>
    while <acceleration factor> has to be a value between -1 and 1. Note: -1 means no (=zero) acceleration and any other value >-1 implies a positive acceleration.

    To make this settings permanent see paragraph "Persistent configuration" in the provided link at the top of this post.

    Troubleshooting: If "property 'Device Accel Speed' doesn't exist" error message appears you have chosen the wrong ID. To identify the right one, look again at the output from "Step 1" and write down all the IDs that can be associated with your mouse. Then try all these IDs with this command:
    Code:
    xinput list-props <device ID> | grep 'libinput Accel Speed'
    until it returns anything. Then you have found the right ID and can use the command from "Step 2" to adjust the mouse acceleration.

    Last edited by tanni; Jan 11, 2022, 02:22 PM.

    #2
    System Settings > Input Devices > Mouse and adjust Pointer speed.
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holme

    Comment


      #3
      Originally posted by Snowhog View Post
      System Settings > Input Devices > Mouse and adjust Pointer speed.
      This adjusts sensitivity, not acceleration.

      Comment


        #4
        It affects acceleration here. Admittedly, I'm on 22.04, but I really doubt that the settings in 21.10 are different. When you say acceleration, to you mean that if you move the mouse at a constant 'speed' and then suddenly move it 'faster', that you expect the cursor to 'accelerate' in speed?
        Using Kubuntu Linux since March 23, 2007
        "It is a capital mistake to theorize before one has data." - Sherlock Holme

        Comment


          #5
          If acceleration is 0 (or "flat"), then the mouse cursor always travels the same distance when the mouse is beeing moved a certain distance. The cursor travel distance here is independent from how fast you move the mouse.

          If acceleration is >0, then the travel distance of the mouse cursor is dependent from how fast you move the mouse.

          You can test it like this: Move the mouse very slowly from the very left of your mousepad to the very right. Then do the same thing again but this time faster. If the mouse cursor traveled the same distance in both scenarios, then acceleration is 0. If the cursor traveled further when you moved the mouse faster, then acceleration is >0.
          Last edited by tanni; Jan 11, 2022, 01:36 PM.

          Comment


            #6
            Understand. Thank you for the clarification. I could be wrong (wouldn't be the first time), but I don't think that function exists; it doesn't in 22.04.
            Using Kubuntu Linux since March 23, 2007
            "It is a capital mistake to theorize before one has data." - Sherlock Holme

            Comment


              #7
              I found the solution here: https://wiki.archlinux.org/title/Mouse_acceleration

              Step 1: Identify device ID with
              Code:
              xinput list
              Step 2: Change acceleration factor with
              Code:
              xinput --set-prop <device ID> 'libinput Accel Speed' <acceleration factor>
              while <acceleration factor> has to be a value between -1 and 1. Note: -1 means no (=zero) acceleration and any other value >-1 implies a positive acceleration.

              To make this settings permanent see paragraph "Persistent configuration" in the provided link at the top of this post.

              Troubleshooting: If "property 'Device Accel Speed' doesn't exist" error message appears you have chosen the wrong ID. To identify the right one, look again at the output from "Step 1" and write down all the IDs that can be associated with your mouse. Then try all these IDs with this command:
              Code:
              xinput list-props <device ID> | grep 'libinput Accel Speed'
              until it returns anything. Then you have found the right ID and can use the command from "Step 2" to adjust the mouse acceleration.

              Comment


                #8
                At some point in the fairly recent past,m Ubuntu/Mint/etc, and most Linux distros, moved from user-space drivers (evdev for mice iirc) to libinput.

                Similar info and explanation HERE

                I *think* this involves replacing xserver-xorg-input-libinput with the older (and I believe unmaintained) xserver-xorg-input-evdev.
                I'll ask Jeeves

                Comment

                Working...
                X