Announcement

Collapse
No announcement yet.

Most KWin keyboard shortcuts have stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Most KWin keyboard shortcuts have stopped working

    I am new to plasma. I have been with Ubutntu for a long time. After update 21.10 I got Gnome 4.0 which doesn't work well for me and I installed KDE a month ago. KDE looked more stable, but since yesterday I have a strange problem. Most of the standard KWin shortcuts have stopped working. I can't zoom in / out, my favorite KDE feature. Meta += Meta+- simply types "+" or "-", as if I hadn't pressed the Meta key. The same is with Ctrl+F6, F7, F8, F9, F10,F11. Pressed Ctrl key is ignored. But, Ctrl+F12 works. Physical Meta key also works. I tried Onscreen keyboard, and it was the same as the physical keyboard. PC restart doesn't change anything. The shortcut settings are default. I confirmed in ~/.config/kglobalshortcutsrc . I have no idea what's going on.
    Last edited by Snowhog; Jan 06, 2022, 03:49 PM.

    #2
    I added custom key for all not working functions: zoom in zoom out, toggle present windows. Custom keys also don't work . That means that my Plasma is corrupted. This is not a shortcut problem, but not working Plasma functionality. How can I fix it? If I can.

    Comment


      #3
      I posted recently:
      in the past the KDE shortcut handling has been quite flaky and non-deterministic. I think its file for saving shortcuts, ~/.config/kglobalshortcutsrc, becomes a mess. To regain determinism, I've had to resort to clearing out all the existing settings, then adding just the shortcuts I want.
      Regards, John Little

      Comment


        #4
        Finally I got it to work. After I realized that not a keyboard shortcut problem, but not working zoom and present windows features I found an article https://archived.forum.manjaro.org/t...-working/96120 which says that the problem is due to not working compositing. I tried Alt+Shift+F12 to enable compositing. Zoom started to work, but soon stopped again. I checked rendering. It was set as OpenGL 2.0. Then I changed to XRender. Zoom (Meta += Meta+-), and present windows, (Ctrl+F6, F7, F8, F9, F10,F11), started to work. Then I changed back to OpenGL 2.0, and all features are still working. Thus, I concluded that it was some kind of KWin glitch. Probably, I reset some corrupted settings on rendering backend change (in Settings--Display and Monitor-Compositor). I use KDE Plasma 5.22.5

        Comment

        Working...
        X