Announcement

Collapse
No announcement yet.

disable touchpad when mouse plugged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    disable touchpad when mouse plugged in

    Hi! Anyone have work solution for disabling touchpad when mouse plugged in?
    Installing xserver-xorg-input-synaptics add options to touchpad settings, but not working. Notification about disabling touchpad is showed, and touchpad still active.

    #2
    You have to log out and back in before this takes effect.
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes

    Comment


      #3
      Originally posted by Snowhog View Post
      You have to log out and back in before this takes effect.
      Even reboot not fixed it

      Comment


        #4
        Originally posted by DesertRatUa View Post
        Notification about disabling touchpad is showed, and touchpad still active.
        There are two entries in Enable/Disable Touchpad that have to be checked: Disable touchpad when typing and Disable touchpad when mouse is plugged in I'm assuming that these are checked.

        What PC do you have? Make/model. What mouse do you have? Make/model. Also, ensure that your mouse isn't listed under Ignored devices.
        Last edited by Snowhog; Jan 30, 2023, 12:02 PM.
        Using Kubuntu Linux since March 23, 2007
        "It is a capital mistake to theorize before one has data." - Sherlock Holmes

        Comment


          #5
          Originally posted by Snowhog View Post
          There are two entries in Enable/Disable Touchpad that have to be checked: Disable touchpad when typing and Disable touchpad when mouse is plugged in I'm assuming that these are checked.

          What PC do you have? Make/model. What mouse do you have? Make/model. Also, ensure that your mouse isn't listed under Ignored devices.
          Both are checked.
          HP 630 G5.
          Bloody G80 Wireless mouse
          Not listed under ignored devices.
          When mouse connected, i have notification that touchpad will be disabled. But it still active.

          Comment


            #6
            IME this became flaky at some point. I found out about it trying to join a zoom call with no touchpad and no mouse. After wasting some time trying to get it to work, I gave up and set a shortcut to toggle the touchpad on and off.
            Regards, John Little

            Comment


              #7
              Originally posted by DesertRatUa View Post
              Bloody G80 Wireless mouse
              That's the issue IMO. The trigger for the setting is a wired mouse "plugged into the PC" (USB port). A wireless mouse isn't going to trigger the feature.
              Using Kubuntu Linux since March 23, 2007
              "It is a capital mistake to theorize before one has data." - Sherlock Holmes

              Comment


                #8
                Originally posted by Snowhog View Post
                That's the issue IMO. The trigger for the setting is a wired mouse "plugged into the PC" (USB port). A wireless mouse isn't going to trigger the feature.
                On windows this functional is working properly. Mouse isn't on ignore list. When mouse connected, i'm got notification that touchpad will be disabled, but still enabled.

                Comment


                  #9
                  Did you already check if it works with a mouse with a tail (aka cable)?
                  Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
                  Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13"

                  get rid of Snap scriptreinstall Snap for release-upgrade scriptinstall traditional Firefox script

                  Comment


                    #10
                    Originally posted by DesertRatUa View Post
                    On windows this functional is working properly.
                    What works in Windows isn’t a guarantee it works in Linux.
                    Using Kubuntu Linux since March 23, 2007
                    "It is a capital mistake to theorize before one has data." - Sherlock Holmes

                    Comment


                      #11
                      in Kubuntu 22.04 you need to install Synaptics and use it in place of libinput then disable touchpad when mouse is installed works. libinput which is the default does not offer this function.

                      Once installed you will have to reboot the machine.
                      you can also install touchpad-indicator from this ppa if you want. It will work also.
                      https://ubuntuhandbook.org/index.php...ntu-18-04-lts/
                      Last edited by kc1di; Feb 03, 2023, 05:28 AM.
                      Dave Kubuntu 20.04 Registered Linux User #462608

                      Wireless Script: http://ubuntuforums.org/showthread.p...5#post12350385

                      Comment

                      Working...
                      X