No announcement yet.

Frame Issue When Low FPS on Kubuntu With Samsung LC27G7 and Nvidia

  • Filter
  • Time
  • Show
Clear All
new posts

    Frame Issue When Low FPS on Kubuntu With Samsung LC27G7 and Nvidia


    I am having quite an odd issue with my frames when my FPS is lower. Hard to notice at 60 FPS or higher, probably nonexistent at 150 or so when gaming, but can still be seen in game if the framerate is capped. However, it is quite easy to notice at 30 or lower, such as when watching anime. Here are some videos where I try to capture the issue [

    Interestingly, it is difficult to see at normal speed, such are camera oddities. In the half speed video it is a lot easier to pick up. To me, it looks like it is trying to show a frame from too far ahead then showing the frame that should be next. You should be able to notice that the place where the object is going to be shows up before the object moves there and it kind of flickers back and forth between the frame that is too far ahead and the frame that it should be on. I think the easiest place to see that is the wing of the plane.

    There's a decent chance it is a monitor issue. I have a little skepticism for that if it is showing frames too early.

    Software and Hardware
    Kubuntu: 22.04

    KDE Plasma Version: 5.24.7

    KDE Frameworks Version: 5.92.0

    QT Version: 5.15.3

    Kernel Version 6.2.0-37-generic

    Graphics Platform: X11

    Samsung Odyssey G7 Monitor. Gsync compatible.

    Using a 3090. Also have a 3080 connected, but the display is running on the 3090.
    I fixed an issue recently where the 3080 had an Xorg window on it and I wasn't
    able to turn on the Gsync indicator by editing the Xorg conf file to include
    Option "AutoAddGPU" "false" and Option "AutoBindGPU" "false" under ServerLayout.

    Nvidia Drivers: 535.104.05 - proprietary

    Things I've Tried
    I tried removing the xorg conf file to see if the defaults would change anything. I tried turning Gsync off/on, the compositor off or on, full composition pipeline on/off, flipping off/on. I tried a number of changes to the xorg conf such as vsync and triple buffering. I tried switching to Wayland and using all the environment variables you're supposed to set to get that to work with Nvidia, but that didn't change the problem and introduced new ones so I went back. I also tried changing my Nvidia drivers back to 525.

    Also willing to look into the code if anyone knows where I might start and how I would re-compile things so I could try to debug it.

    Could it be a video codec/player/video-source issue?

    What video, what format, resolution and what player/web browser?
    It seems like the video isn't being rendered in hardware or there is no acceleration (same thing?), but I am no expert at all.


      Perhaps, but it's ubiquitous, from YouTube to mkv files in VLC to watching anime online.