Announcement

Collapse
No announcement yet.

Writer problem re endnotes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Writer problem re endnotes

    I’ve been trying off and on for weeks to solve a Writer problem but without success! Every now and then I stumble across the (or a) solution, but “stumbling across” is not “understanding”. I want to know how to do it every time without it being a trial-and-error process. Hopefully someone on this site will be kind enough to tell me the solution. The problem concerns one aspect of endnotes. I want each endnote’s unique ID in the endnotes area to be a superscripted number while the endnote’s text is in the normal position. I know how to get the number aspect, but getting the superscript aspect is my problem. Somewhere in LibreOffice’s help literature it says that editing an endnote is just like editing regular text. That statement is not 100% true. To get a character of regular text superscripted, one should (1) select the character, (2) choose the Format menu’s “Character…” option, and (3) set the Position to be “superscript” rather than “normal” position. That procedure does not work for an endnote’s unique ID character (its number). It doesn’t work because the endnote’s unique ID cannot be selected the way regular text is selected.

    I’m running Ubuntu 22.04 and LibreOffice version 7.3.7.2. If you can tell me the solution, I sure will be grateful.

    #2
    Have you tried Libreoffice's forums?
    In case no one here has any experience with using end notes in LO.

    Comment


      #3
      I see no reason why the exact same problem would not arise with footnotes. The only difference I can see is the note's location (one is at the bottom of a page; the other one has all of a document's notes at the end of the document).

      I've had pretty good luck with this forum, but I agree with your suggestion that I also post the problem on some LibreOffice forums. Thanks for replying.

      Comment


        #4
        Originally posted by wtb32141 View Post
        I’m running Ubuntu 22.04
        But you posted in 23.04. Shall I move this thread?
        Using Kubuntu Linux since March 23, 2007
        "It is a capital mistake to theorize before one has data." - Sherlock Holmes

        Comment


          #5
          Yes, please. I was unaware of the multiple groups.

          Comment


            #6
            I think I found the solution on the LibreOffice website and I just tried it with endnotes:

            "Footnotes are controlled by three styles: one paragraph style for the actual text (called, appropriately “Footnote”) and two character styles for the footnote indicator, the first one used to format the footnote “anchor” (the number you see on the text area) and called “Footnote anchor” and the other used on the footnote area and called “Footnote characters”. Just open the styles and formatting editor (F11) and modify those styles according to your needs."
            (https://ask.libreoffice.org/t/contro...te-style/21385)

            This also works for me with endnotes: After I pressed [F11] I made a right-click on "Endnote characters" in the second tab and then changed the position to "Superscript".
            Last edited by Schwarzer Kater; May 22, 2023, 01:38 PM.
            Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
            Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13"

            get rid of Snap scriptreinstall Snap for release-upgrade scriptinstall traditional Firefox script

            Comment


              #7
              Off topic rant:
              I really wish writers stick to footnotes only; endnotes are really hard to follow.

              Comment


                #8
                Thanks Schwarzer Kater for the info you sent me.i Some of that info dates to Oct. 2016, but it works better than my current version of Writer when it comes to endnotes. LibreOffice 7.5 Help says, “To change the format of a footnote, click in the footnote, press F11 to open the Styles window, right-click "Footnote" in the list, and then choose Modify. […] To change the formatting that LibreOffice applies to footnotes and endnotes, choose Tools - Footnotes and Endnotes.” That quoted text does not say to use F11 in editing an endnote; it says to use the Tools munu’s ‘Footnotes and Endnotes” option, which I did (but should not have done!). Since reading your post, I have found F11 to be the solution to my problem!

                Upon selecting the Tools menu’s “Footnotes and Endnotes…” option, a dialog box opens with 2 sides. The left side concerns the endnote’s numbering; the right side has styling data for 4 items: Paragraph, Page, Text Area, and Endnotes Area. The numbering side is straightforward; so no problems there. My problems have been with the right-hand side’s Text Area and Endnotes Area. I’m writing this text to you in Writer; I’ll copy and paste it into the forum’s note space. The Text Area’s rectangle begins with “Endnote Anchor”; the “Endnotes Area” rectangle begins with “Endnote Characters”. I view the “Endnote Anchor” as the endnote’s unique ID (i.e., its number). If I right click on “Endnote Anchor”, a rectangle containing 2 items appears. From top to bottom, the 2 items are “Footnotes” and “Endnotes”. That's a dead end!

                Now let’s examine F11’s use (instead of the prior paragraph’s Tool’s menu’s “Footnotes and Endnotes…” option) to edit endnotes. I have inserted into this text an endnote (number 1). It’s in the superscript position in the document’s text area, and in the normal position in the endnotes area. The endnote appears as follows:

                1xxx

                Thus, the number 1 is in the normal position as are the 3 x’s. With the cursor between the 1 and the first x, I will hit the F11 key. Then choose (highlight) the character style. Then right click on Endnote Anchor. Select Modify. Then select the Normal position and hit OK. The endnote’s number in the text area changes from the superscript position to the Normal position. Using the same procedure, I can restore it to the superscript position.

                Now let’s focus on the endnotes area. Hit F11. Again choose the Character style. Right click this time on “Endnote Characters”. Then choose “Modify”. You can change the endnote’s number in the endnotes area back and forth between Normal position and Superscript position and without changing the endnotes area’s endnote text (the 3 x’s). In other words, the endnote’s number changes position without the endnote’s text changing position.

                Conclusions: First, using the F11 key solves my endnotes problem! Second, I find it odd that “Endnote Characters” rather than "Endnote Anchor" modifies the endnote number’s position (Normal v. Superscript) in the endnotes area. Third, be sure to select the Character style when wanting to change the position of the endnote’s number in either the text area or the endnotes area.

                So Schwarzer Kater, thank you very much for your help!


                ixxx

                Last edited by wtb32141; May 24, 2023, 09:07 AM.

                Comment

                Working...
                X