Announcement

Collapse
No announcement yet.

Disabling system sounds

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Disabling system sounds

    I'm trying to disable all system sounds. After looking for a simple "disable all system sounds" setting, I found that the only way seems to be to turn them off one by one. I went into System Settings -> Notifications -> Applications and then disabled all sound effects for each one individually.

    However, I can't seem to find a way to disable the sound effect that accompanies the warning for closing Firefox with multiple tabs open. I would still like to get the warning (I have Firefox set not to remember any tabs between sessions, so this warning helps prevent accidents), but I don't like the sound effect.

    Any suggestions on how to disable this last remaining sound effect? Am I just missing something in the settings?

    #2
    You could have gone into System Settings > Audio and set Playback Streams > Notification Sounds to 0% (mutes notification sounds). As to Firefox and its ilk, it/they use the GTK+ toolkit, whereas as Kubuntu uses the QT toolkit. That usually means that controls for GTK+ developed applications are built into the application and must be used to affect the application. So look in Firefox for a notification setting.
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holme

    Comment


      #3
      Looking into that setting, I now remember setting this to 0% earlier, when I just started using Kubuntu 21.10. After upgrading to 22.04, I started hearing notification sounds again, but had forgotten all about muting them before. It was still set to 0%, but for some reason the system ignored this setting after updating.

      The first solution to try when dealing with any technical problem is turning it off and on again, so I unmuted and muted again, and it did the trick!

      All notification sounds are now muted, including the one from Firefox.

      Firefox itself seems to only have a setting to disable the warning entirely (which I didnt want to do) instead of muting it, so I'm happy this solution worked.

      Thank you!
      Last edited by Orflovir; Jun 07, 2022, 06:48 AM.

      Comment

      Working...
      X