No announcement yet.

Laptop monitor only works at native resolution after system upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

    Laptop monitor only works at native resolution after system upgrade

    I'm posting here because, although I'm using regular Ubuntu (to comply with company policies), I run Plasma with Kubuntu backports, so please bear with me if if this is not the right place to ask.

    My laptop has an AMD Ryzen 7 5800H processor with a Radeon APU and a dedicated GeForce RTX 3060 Mobile. I always work on my desk, so laptop is connected to an external monitor (USB-C to DisplayPort cable) and that monitor is connected to a second external monitor (HDMI and Multi-Stream Transport). It’s a work laptop used for coding. It has secure boot and an encrypted LVM volume. After installing Ubuntu upgrades, that seemingly included a 6.2 to 6.5 kernel upgrade, the buitlin monitor stopped working at any resolution but the native one. That's tiny for me, and I'm using X11 so I cannot have per-monitor scaling. Whenever I try to lower it, I only get flickering white noise.

    Trying different solutions I read in online forums, I only managed to misconfigure X11 altogether for all three monitors. Right now, I'm back to the scenario I described: all monitors work, but I'm stuck with tiny native resolution in builtin panel. I couldn't manage to revert the kernel upgrade, but if I start with 6.2 kernel using Grub menu, the problem persist anyway.

    I've learnt that, apparently, the external monitors are handled by Nvidia card and builtin monitor is handled by Radeon, and it's this one at fault. I tried to get drivers from but they won't install:

    Setting up rocm-clang-ocl ( ...
    Setting up rocm-utils ( ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    What troubleshooting can I do?

    It solved itself the next time I did `sudo apt upgrade` :-?


    • jlittle
      jlittle commented
      Editing a comment
      thank you for telling us

    Originally posted by kAlvaro View Post
    It solved itself the next time I did `sudo apt upgrade` :-?
    You will be better served if you use sudo apt full-upgrade instead. Continued use of sudo apt upgrade can/will eventually cause problems.

    upgrade is used to install available upgrades of all packages currently installed on
    the system from the sources configured via sources.list(5). New packages will be
    installed if required to statisfy dependencies, but existing packages will never be
    removed. If an upgrade for a package requires the remove of an installed package the
    upgrade for this package isn't performed.​
    full-upgrade performs the function of upgrade but will remove currently installed
    packages if this is needed to upgrade the system as a whole.​
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes