Announcement

Collapse
No announcement yet.

Can't install steam, partners repo not working? [Installed from ubuntu-server]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Can't install steam, partners repo not working? [Installed from ubuntu-server]

    Hi!

    First, I made this new installation of Ubuntu with the help of ubuntu-server image. The reason was purely educational; I wanted to do a network installation. As I much more prefer KDE Plasma over whatever it is Ubuntu uses per default, and Kubuntu iuses the same repositories, I though the same end result should be achieved. After installation, I noticed there is no kubuntu-full - maybe it has been removed on more recent releaces? So, I proceeded to install kubuntu-desktop only.

    Now, there may be something left over from the server installation which prevents things to work correctly? I can not install steam-installer, since there is not steam package at all:

    Code:
    $ LANG=C sudo apt install steam-installer
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
    steam-installer : Depends: steam (>= 1:1.0.0.70-2ubuntu1) but it is not installable
    E: Unable to correct problems, you have held broken packages.
    However, I can clearly see it should be in multiverse.

    It seems I have multiverse in sources.list, but apt update never fetches multiverse. Thinking maybe my sources.list syntax is wrong for some reason, I tried to change the sources via GUI. Software-properties-qt wants to be run with pkexec or lxqt-sudo. However:

    Code:
    $ pkexec software-properties-kde    
    qt.qpa.xcb: could not connect to display  
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    
    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
    
    Aborted (core dumped)
    (after typing my password in the dialog)... uh oh.

    Well, plain sudo works for software-properties. I've disabled and re-enabled all software sources. Now multiverse get's synced, but steam package is still not found.


    Code:
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 21.10
    Release:        21.10
    Codename:       impish
    sources.list:
    Code:
    $ cat sources.list
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish universe
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish multiverse
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu impish partner
    # deb-src http://archive.canonical.com/ubuntu impish partner
    
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-security main restricted
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-security universe
    # deb-src http://fi.archive.ubuntu.com/ubuntu impish-security multiverse
    deb http://archive.ubuntu.com/ubuntu impish main universe restricted multiverse
    Any ideas what is going on?

    If this is caused by installation from ubuntu-server image, then any ideas on what it is it could have done differently than installing from desktop image are welcome. I've already set up many things the way I like and would rather not go trough another re-install and juggling my home dir files around. Also, this could be a nice educational exercise ;-)

    Thanks!

    p.s. As a sidenote: the installation created a netplan file in /etc/netplan for my Wifi, for which I gave credentials during installation. I'm not sure if this is the reason, but I can not manage WiFi at all trough KDE Plasma at the moment. Should KDE Plasma integrate netplan currently? I hope this a fluke left by the server installation (which presumes the user will not install a GUI - it would make sense) - which I can fix by deleting the netplan files - but if not, that is another issue in another thread...

    #2
    It has been kubuntu-desktop for quite some time, probably since after 18.04

    The Software Sources tool will be software-properties-qt, as it is now shared with Lubuntu. It hides in Discover's settings area, under Software Sources.


    You are missing some key sources - Security and Updates, which are probably what is causing a dependency problem preventing Steam from installing.

    Code:
    deb http://archive.ubuntu.com/ubuntu/ impish main restricted universe multiverse 
    deb http://security.ubuntu.com/ubuntu/ impish-security main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ impish-updates main restricted universe multiverse
    If you haven't already, you will also need to enable 32 bit support for Stem games:
    Code:
    sudo dpkg --add-architecture i386
    The Partner repo is essentially useless, I'd disable it if fixing your sources doesn't also fix this,
    Last edited by Snowhog; Dec 30, 2021, 07:37 PM.
    Your personal search bot

    Comment


      #3
      I made a mistake while posting; while troubIeshooting, I had disabled and re-enabled the repositories (multiple times actually) with software-properties-qt, and forgot to enable those on the second tab (and didn't actually check the sources.list while posting).

      However, enabling 32bit seems to be mandatory. After enabling 32bit steam package is picked up!

      Thanks, marking as solved =).

      As a sidenote: I though there are many 64bit games and steam itself is also 64bit these days? If that is right, isn't it a bit odd 32bit is enforced? Or is there still something odd going on with my system? Or, perhaps 32bit support enabled per default in desktop installs? Not being able to install steam without any sensible error message / pointer to enabling 32bit is something which could be easily fixed...

      (current sources.list - note, earlier I made a mistake while posting, the culprit seems to be not enabling 32bit

      Code:
      deb http://archive.ubuntu.com/ubuntu/ impish main restricted universe multiverse
      deb http://security.ubuntu.com/ubuntu/ impish-security main restricted universe multiverse
      deb http://archive.ubuntu.com/ubuntu/ impish-updates main restricted universe multiverse
      
      deb http://archive.ubuntu.com/ubuntu impish-backports multiverse restricted main universe
      deb http://archive.ubuntu.com/ubuntu impish-proposed multiverse restricted main universe

      Cheers!

      Comment


        #4
        Just a few remarks in case someone has some problems (and comes here via a search):

        I noticed that software-properties-qt is supposed to be started via muon. Not sure what it does differently, but via it's menus software properties runs just fine, while manually from command line with pkexec or lxqt-sudo I get the mentioned errors. One might ask why I run it from the command line in the first place? Well, I'm using KDE Plasma in Finnish and it can be a bit difficult to find applications via search, which complicates finding the applications for package management a bit, if using the search (synthetic language and pattern matching is even less perfect / difficult...). Anyways, somehow I managed to find that executable before finding muon. Then I noticed muon has been sitting in the menu hierarchy all the time - and managing sources.list via a GUI works just fine that way =). However, maybe there is a minor bug here in that software-properties dumps core if started this way as standalone?

        Also, removing the netplan configuration files (in /etc/netplan) indeed "releases" the WiFi adapter so that user in KDE Plasma can manage it via GUI =). The case may have actually been same for the wired connection, too (but I didn't check). But this is probably a problem a user might only face if using the server-install (I guess)!
        Last edited by WildPenguin; Dec 31, 2021, 07:18 AM.

        Comment


          #5
          Many actual games are 32 bit, so Steam wants the i386 libraries available.

          Software Sources be accessed from Muon or Synaptic - which are already running with sudo. It can also be accessed from Discover.

          Standalone, you would need to specify more environmental variables with pkexec:
          Code:
          pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY  software-properties-qt
          This is probably how Discover's button is calling it

          Click image for larger version

Name:	Screenshot_20211231_090558-1.png
Views:	35
Size:	92.2 KB
ID:	659301
          Attached Files
          Your personal search bot

          Comment

          Working...
          X