Announcement

Collapse
No announcement yet.

Startx doesn't launch on boot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Startx doesn't launch on boot

    Laptop acer aspire e3-112 (celeron, integrated graphics), kubuntu 20.04
    Two days ago after updating the system asked for a reboot. And didn't go well : after reboot all I have is black screen with mouse cursor.
    I looked in the Internet and tried a lot of fixes without luck.
    It's possible to get the terminal with ctrl+alt+F2. Then I can launch startx from the command line and I get the desktop running.
    But I don't know why it doesn't launch directly.
    I remember that I enabled autologin for my user. I don't remember having done anything specific before it stopped working.
    I checked systemctl status display-manager and systemctl status sddm and both were active and running.
    Thanks for the help

    Edit:
    systemctl get-default
    graphical.target

    cat /etc/X11/default-display-manager
    /usr/bin/sddm
    Last edited by Jarod5001; May 15, 2022, 01:04 PM. Reason: Solved

    #2
    When you are in the terminal, try typing: sudo apt update && sudo apt install plasma-desktop
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holme

    Comment


      #3
      Originally posted by Snowhog View Post
      When you are in the terminal, try typing: sudo apt update && sudo apt install plasma-desktop
      thanks;
      it says that I already have the latest version 4:5.18.8-0ubuntu0.1 and it is changed to "manually installed".

      Comment


        #4
        Per Arch SDDM wiki:
        Blank screen with cursor, but no greeter shows


        Greeter crashes if there is no available disk space. Check your disk space with df -h.

        If disk space is not the issue, it may be due to a bug. Switch to another TTY, and then try loginctl unlock-session session_id or to restart SDDM.
        After switching to TTY2, you could try:
        Code:
        sudo systemctl stop sddm
        Code:
        sudo loginctl unlock-sessions
        Code:
        sudo systemctl start sddm
        and see if that has any effect
        Last edited by rab0171610; May 11, 2022, 09:36 PM.

        Comment


          #5
          Code:
          ⋊> ~ df -h 19:35:53
          Filesystem Size Used Avail Use% Mounted on
          udev 1,9G 0 1,9G 0% /dev
          tmpfs 382M 3,1M 379M 1% /run
          /dev/sda5 110G 98G 6,0G 95% /
          tmpfs 1,9G 0 1,9G 0% /dev/shm
          tmpfs 5,0M 4,0K 5,0M 1% /run/lock
          tmpfs 1,9G 0 1,9G 0% /sys/fs/cgroup
          /dev/loop0 168M 168M 0 100% /snap/codium/253
          /dev/loop1 128K 128K 0 100% /snap/bare/5
          /dev/loop3 165M 165M 0 100% /snap/gnome-3-28-1804/161
          /dev/loop2 168M 168M 0 100% /snap/codium/254
          /dev/loop4 55M 55M 0 100% /snap/hugo/12662
          /dev/loop5 151M 151M 0 100% /snap/git-cola/136
          /dev/loop6 150M 150M 0 100% /snap/joplin-desktop/27
          /dev/loop7 62M 62M 0 100% /snap/core20/1434
          /dev/loop8 66M 66M 0 100% /snap/gtk-common-themes/1519
          /dev/loop9 45M 45M 0 100% /snap/snapd/15534
          /dev/loop10 81M 81M 0 100% /snap/lxd/23037
          /dev/loop11 56M 56M 0 100% /snap/core18/2344
          /dev/loop12 44M 44M 0 100% /snap/snapd/15177
          /dev/loop13 249M 249M 0 100% /snap/gnome-3-38-2004/99
          /dev/loop14 81M 81M 0 100% /snap/lxd/23001
          /dev/loop16 153M 153M 0 100% /snap/skype/206
          /dev/loop15 111M 111M 0 100% /snap/core/12834
          /dev/loop17 153M 153M 0 100% /snap/skype/209
          /dev/loop18 55M 55M 0 100% /snap/hugo/12606
          /dev/loop19 62M 62M 0 100% /snap/core20/1405
          /dev/loop20 56M 56M 0 100% /snap/core18/2284
          /dev/loop21 168M 168M 0 100% /snap/codium/250
          /dev/loop22 111M 111M 0 100% /snap/core/12821
          /dev/sda1 511M 4,0K 511M 1% /boot/efi
          tmpfs 382M 12K 382M 1% /run/user/1000
          tmpfs 1,0M 0 1,0M 0% /var/snap/lxd/common/ns
          `sudo systemctl sddm stop` gave error so I tried `sudo systemctl stop sddm` and `sudo systemctl start sddm`

          But after reboot I still have the same black screen with mouse cursor.
          Could restoring using timeshift fix the problem?

          Comment


            #6
            `sudo systemctl sddm stop` gave error so I tried `sudo systemctl stop sddm`
            LOL it should give you an error, I will correct that!!

            Comment


              #7
              Have you had any luck? I have been at work all day. What is going on with your situation now?

              Comment


                #8
                Originally posted by rab0171610 View Post
                Have you had any luck? I have been at work all day. What is going on with your situation now?
                Nothing. Still same issue. I tried with timeshift a snapshot of a week ago but didn't work. I have an older snapshot, 5 months old 🙄. I prefer not to use it. I'll wait to see if I can get it fixed before that.

                Comment


                  #9
                  Did you try deleting ~.Xauthority?
                  Does this give you any clues?
                  Code:
                  sudo journalctl | grep sddm
                  To search for a specific date:
                  Code:
                  sudo journalctl | grep sddm | grep "May 12"
                  I had this issue recently and could not get if fixed, but it was on a different distribution. It worked fine on Arch, Kubuntu sharing same home folder. But not Gentoo.
                  Is this a dual monitor setup?
                  Last edited by Snowhog; May 12, 2022, 11:49 AM.

                  Comment


                    #10
                    Just a thought: Do the timeshift backups also include hidden files in your home folder? Or do you have it set to only restore/save root system files? If the latter, then that could mean the answer lies in a hidden folder or file in your home folder.

                    Comment


                      #11
                      rab0171610's thought suggests adding another user to see if the problem occurs for that user. If it doesn't, there's something in your home directory causing trouble.
                      Regards, John Little

                      Comment


                        #12
                        Sorry for the late feedback. A lot of work

                        So, I have disabled auto login and now I see a login screen. After entering the password it just freezes. So I switched to tty3 and launched startx and I logged in but the 'sddm-greeter' window was frozen. I had to close it manually.
                        I tried to add a new user as suggested by jlittle and the new user logged in flawlessly. So there is something wrong in my home dir. But what should I check ?
                        I have configured timeshift for system files only and I'm using nextcloud to sync my documents folder only. So I think that timeshift won't fix my issue.
                        Is there any log where I should check or what files or folders in home dir are responsible for that ?
                        Thanks a lot for guiding me and for your time.

                        Comment


                          #13
                          You could try copying directories one at a time to the new user home folder from the old user. For example, start with .cache, .config, .local, etc,and then try logging in and out until you get the same problem. It is likely in one of those three folders. Then you will at least know which folder it is in and then go from there. Also try moving the hidden files that are directly in the path of the home directory one at a time, .Xsession, etc.

                          Comment


                            #14
                            Possibly try ~/.local/share/plasma/
                            Maybe some theme or settings are corrupt.

                            Comment


                              #15
                              I found it.
                              I have installed fish shell months ago but didn't set it as default, as I wanted to test it before. I looked days ago for a tutorial how to set it as default and one of them proposed to add '/usr/bin/fish' at the end of the '~/.profile' file. I forgot about it because I didn't reboot since that time.
                              Now I have removed that line from the profile and sddm-greeter doesn't freeze anymore.
                              But I don't understand why this line made it freeze!
                              Thanks for everyone who helped me and taught me new things.

                              Comment

                              Working...
                              X