Announcement

Collapse
No announcement yet.

disable touchpad when mouse plugged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] disable touchpad when mouse plugged in

    In previous versions of Kubuntu, I had a choice to disable the touchpad if my mouse was plugged in. I kept in my CherryTree notes how to do it:

    Alt+F2
    Type "Touchpad"
    Choose "Touchpad Settings"
    The Alt+F2 and then typing "Touchpad" brings up the same thing as this:

    System Settings ⇒ Input Devices ⇒ Touchpad
    Either way, there used to be a checkbox where I chose "disable touchpad when mouse is plugged in." I did notice that page shows my touchpad as:
    SynPS/2 Synaptics Touchpad
    My laptop is a Lenovo Ideapad Z570. I think on that Touchpad page it used to list a Lenovo touchpad, but I'm not certain. I'm wondering if during this install of 20.04 maybe my Z570 somehow didn't get its proper driver. The touchpad does run with that PS/2 Synaptics one. I would just like to be able to automatically disable it when I plug a mouse in. If I'm using a mouse, I never use the touchpad. I prefer that, as I can't accidentally touch the touchpad causing the cursor to move off to somewhere that I did not intend.

    So I'm wondering if I have the wrong touchpad driver and need to hunt down the right one. Or, alternatively, maybe there's some kind of utility out there that can monitor if a mouse gets plugged in and then will disable the touchpad.
    Kubuntu 20.04 (desktop & laptop), Windows 7 (via VirtualBox on desktop PC)
    ================================

    #2
    My guess is that the newer kubuntu is using the newer libinput xorg-input driver by default. The older synaptics driver is on it's way out (but still installable and working) that currently offers more configuration options (and a different config dialog for system settings).

    I'd first check which driver is in use, by running:
    Code:
    xinput list
    Note the id number for your touchpad in the output.
    Then run:
    Code:
    xinput list-props <id>
    replace "<id>" with the id number you got from the previous command:

    Do you see references to "libinput" or "synaptics" on the configuration output.
    If it's "libinput", install "xserver-xorg-input-synaptics" package and reboot.

    Then check the xinput commands that the config has changed to Synaptics.
    Now access the System Settings Input devices configuration and you should see a different dialog, in which you can set "disable when mouse plugged" (you can exclude certain mice devices as well, like a trackpoint).

    EDIT: The libinput driver should have automatic "palm detection" and "disable while typing" features, AFAICT, but there is always a chance it's not working for you (or doesn't fit what you need to prevent accidental cursor movements), in which case trying out the synaptics driver and it's options is probably a good idea (at least for the time being).
    Last edited by kubicle; Dec 11, 2020, 03:13 AM.

    Comment


      #3
      you need to install the package xserver-xorg-input-synaptics
      Mark Your Solved Issues [SOLVED]
      (top of thread: thread tools)

      Comment


        #4
        Originally posted by sithlord48 View Post
        you need to install the package xserver-xorg-input-synaptics
        ^This. I just want to add that after installing it, you may need to open and close System Settings more than once before it finally shows up in its touchpad settings; this is what it should look like, with five tabs:

        Click image for larger version

Name:	tmp_touchpad.jpg
Views:	2
Size:	65.1 KB
ID:	644988
        Xenix/UNIX user since 1985 | Linux user since 1991 | Was registered Linux user #163544

        Comment


          #5
          Originally posted by kubicle View Post
          If it's "libinput", install "xserver-xorg-input-synaptics" package and reboot.
          I can see how that might get lost in the details. Glad you both agree, though

          Comment


            #6
            I'm sorry, @kubicle! I even scanned your post [with my old, tired, blurry, awful eyes], looking for that, and didn't see it! Kind of sums up how things have been going for me lately.
            Xenix/UNIX user since 1985 | Linux user since 1991 | Was registered Linux user #163544

            Comment


              #7
              Thanks, everyone! That worked perfectly. I've saved this info in my settings notes (in CherryTree) so that I have it if I ever need to install Kubuntu from scratch again.

              Thank you all so much for your help.

              Btw, one of these days I'll make a post about how I document in detail all my OS installs in CherryTree. That way I have a record of exactly everything I did, making any new OS install go quickly and smoothly.

              Here's what it changed. What a difference!

              Click image for larger version

Name:	disabletouchpad.jpg
Views:	1
Size:	86.5 KB
ID:	644989
              Last edited by Tom_ZeCat; Dec 12, 2020, 08:17 PM.
              Kubuntu 20.04 (desktop & laptop), Windows 7 (via VirtualBox on desktop PC)
              ================================

              Comment


                #8
                Originally posted by DoYouKubuntu View Post
                I'm sorry, @kubicle!
                No need to be sorry, no harm done...and I'm quite adept in missing what other people have previously said myself.

                I just don't wish people to absurdly think that there is a question I don't know the answer to

                Comment


                  #9
                  Aw, shucks, @kubicle, you're too kind.

                  Seriously, I like to give credit where credit is due, so it bothers me when someone supplied the correct answer but I didn't even notice it.

                  At any rate, I for one will NEVER absurdly think there's a question you don't know the answer to!
                  Xenix/UNIX user since 1985 | Linux user since 1991 | Was registered Linux user #163544

                  Comment


                    #10
                    Originally posted by Tom_ZeCat View Post
                    Thanks, everyone! That worked perfectly. I've saved this info in my settings notes (in CherryTree) so that I have it if I ever need to install Kubuntu from scratch again.

                    Thank you all so much for your help.
                    You're welcome. I'm really glad you were able to get the results you wanted.

                    I keep notes, too, just in a running text file that's been going for...a looooooong time. The newest info always goes at the top, and I date and label each entry. If I need to find out how I...hmmmm...disabled the touchpad on 20.04 since it no longer offered that option, I look it up! Just search for 'touchpad' and it hits. I'd be very interested in seeing how you do yours.
                    Xenix/UNIX user since 1985 | Linux user since 1991 | Was registered Linux user #163544

                    Comment


                      #11
                      Originally posted by kubicle View Post
                      I can see how that might get lost in the details. Glad you both agree, though
                      Reading is hard sometimes
                      Mark Your Solved Issues [SOLVED]
                      (top of thread: thread tools)

                      Comment

                      Working...
                      X