Announcement

Collapse
No announcement yet.

Time is off at every boot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Time is off at every boot

    The title says it all.

    At every boot my computer time is off by an hour and I have to reset it at avery boot.

    This started a few days ago and am not sure why.

    What an I missing?
    HP Pavilion dv6 core i7 (Main)
    4 GB Ram
    Kubuntu 18.10

    #2
    Hm. The US, Canada, and a number of little nearby island nations switched to daylight time on Sunday 10 March. All our clocks moved an hour ahead. Normally, computers handle this on their own (*). But IIRC, you're on the other side of the planet, so this shouldn't be affecting you yet?

    (*) One time in Remond (**), we shipped an update for Vista to update its set of timezone rules. The version of the update for Australian English actually missed all the US-related changes. That means people in Australia would be given incorrect information about what time it was in the US. Sheesh. One of our Australian systems engineers publicly ridiculed SteveB in front of a 5000-person internal meeting for shipping crappy updates with such silly mistakes. He became an instant hero. But not for long.

    (**) I'm going to start using this phrase to introduce every Microsoft story I tell.

    Comment


      #3
      Hi Steve, I thought of that as well and changinging the timeserver to: europe.pool.ntp throws a "cannot authenticate" error. (Forgot to mention that in my first post )

      There used to be a "set dailight savings time automaticly" function or sinilar which one could deactivate. That was a long time ago and I can't seem to be able time find it anymore.
      HP Pavilion dv6 core i7 (Main)
      4 GB Ram
      Kubuntu 18.10

      Comment


        #4
        I think that should be europe.pool.ntp.org.

        Is your hardware clock still set to the correct UTC?

        Also, hmm... http://forums.linuxmint.com/viewtopi...28267&p=697881

        Comment


          #5
          Oh, and to fiddle with the KCM for date and time, you have to
          Code:
          kdesudo systemsettings
          That module doesn't self-elevate properly.

          Comment


            #6
            I think that should be europe.pool.ntp.org.

            Is your hardware clock still set to the correct UTC
            ?

            It is europe.pool.ntp.org, I was just too lazy to type the .org here

            No, UTC is turned off (I always do that first)

            I still get the error when changing time server in
            Code:
            kdesudo systemsettings
            HP Pavilion dv6 core i7 (Main)
            4 GB Ram
            Kubuntu 18.10

            Comment


              #7
              Have you tried scrolling over the clock? We discovered this fixes 90% of clock related issues in Kubuntu.

              Comment


                #8
                Have you tried scrolling over the clock?
                Please enlighten me. What do you mean by that?
                HP Pavilion dv6 core i7 (Main)
                4 GB Ram
                Kubuntu 18.10

                Comment


                  #9
                  Originally posted by Fintan View Post
                  Please enlighten me. What do you mean by that?
                  If you have more than one time zone ticked (e.g. whatever your local time zone is + UTC), then moving your mouse cursor over the system clock and then rolling the mouse wheel will switch between them.
                  sigpic
                  "Let us think the unthinkable, let us do the undoable, let us prepare to grapple with the ineffable itself, and see if we may not eff it after all."
                  -- Douglas Adams

                  Comment


                    #10
                    Thanks. No I only have my time zone active.
                    HP Pavilion dv6 core i7 (Main)
                    4 GB Ram
                    Kubuntu 18.10

                    Comment


                      #11
                      Originally posted by Fintan View Post
                      Thanks. No I only have my time zone active.
                      Do you dual boot with any other distros or OSs? If yes, name then please.

                      Comment


                        #12
                        Just win 7
                        HP Pavilion dv6 core i7 (Main)
                        4 GB Ram
                        Kubuntu 18.10

                        Comment


                          #13
                          The hardware clock is what's set in your firmware (BIOS or UEFI). Curiously, in fiddling around with KDE's time zone stuff, I managed to completely hose what the operating system was saying. It told me that both London (UTC) and Los Angeles (what I have to pick for Seattle) were the same!

                          So first I deselected all time zones with a check mark in Digital Clock Settings | Time Zones. Then I rebooted my computer and went to the firmware settings. I confirmed that the time there (that's the "hardware clock") was set to UTC. Then I booted Kubuntu, but didn't log in when LightDM started. Instead, I went to a TTY and ran
                          Code:
                          sudo dpkg-reconfigure tzdata
                          and reselected my local time zone. Then I typed
                          Code:
                          date
                          to verify all was proper. I rebooted once more, and this time, logged into the desktop. Now the clock is correct.

                          Seems like there's some overall wonkiness that needs looked at here...

                          Comment


                            #14
                            Thanks Steve. That did it. Wonder what caused this??
                            HP Pavilion dv6 core i7 (Main)
                            4 GB Ram
                            Kubuntu 18.10

                            Comment


                              #15
                              Cosmic rays.

                              Comment

                              Working...
                              X