Results 1 to 5 of 5

Thread: Secondary hard drive won't auto-mount

  1. Back To Top    #1
    Junior Member
    Join Date
    Jun 2012
    Posts
    23
    Threads
    7
    Local Date
    Aug 17th 2017
    Local Time
    03:41 AM

    Secondary hard drive won't auto-mount

    Kubuntu recently decided to quit mounting my second hard drive. I'm not sure what caused this, but I think it came with an update. When I run kcmshell4 device_automounter_kcm, the box for "Automount on Login" is checked for the drive. When I run sudo fdisk -l, the drive is listed, but underneath it in red it says

    Code:
    Partition 2 does not start on physical sector boundary.
    I found that if I manually create a mount point, I can get it to mount with the "mount" command, and everything seems to work fine. I wonder if I found a bug in KDE, and, if so, which part.

  2. Back To Top    #2
    Ghost in the Machine Teunis's Avatar
    Join Date
    Jun 2006
    Location
    The Netherlands, 5m. below sea level.
    Posts
    3,420
    Threads
    145
    Local Date
    Aug 17th 2017
    Local Time
    05:41 AM
    Is this drive included in /etc/fstab?

  3. Back To Top    #3
    Master Skribe OneLine's Avatar
    Join Date
    Nov 2011
    Posts
    777
    Threads
    75
    Local Date
    Aug 17th 2017
    Local Time
    06:41 AM

    Post Automount

    Automount with the fstab

    Ubuntu Community Fstab: https://help.ubuntu.com/community/Fstab


    Automount with the KDE Removeable Devices (Kubuntu 15.04)

    Long: http://askubuntu.com/questions/61331...devices-option

    Short:

    The Kubuntu 15.04 is using KDE System Settings that can show KDE Control Modules (kcm) for the KF5/Plasma5. The removeable devices kcm is from the KDE4. With the KF5 - http://commit-digest.org/issues/2014...33bdd71a7b743/ :

    Remove solid-device-automounter

    This should be ported to systemd so any automount happens within
    systemd user session startup and we do not depend on kded being started.

    Also, The current code is not working well, it keeps mounting things
    after you remove the item from the list, it mounts things twice making
    it bad for encrypted disks (you get the dialog twice), the model gets
    ****ed up etc.

    So, for the time being lets just remove it, and restore it the moment
    we have a maintainer and somebody to make this rock.
    Meanwhile - with the kded4/kcmshell4:

    1) Change the /usr/share/kde4/services/kded/device_automounter.desktop line X-KDE-Kded-phase=1 to X-KDE-Kded-phase=0

    2) Start 'Removable Device Automounter' from the Service Manager. Command: kcmshell4 kcmkded.

    3) Pick the right options from the KDE 'Removable Devices module'. Command: kcmshell4 device_automounter_kcm


    Partition does not start on physical sector boundary?

    AskUbuntu: http://askubuntu.com/questions/15699...ector-boundary
    Last edited by OneLine; May 4th 2015 at 08:33 AM.

  4. Back To Top    #4
    Junior Member
    Join Date
    Jun 2012
    Posts
    23
    Threads
    7
    Local Date
    Aug 17th 2017
    Local Time
    03:41 AM
    Thanks! That works.

  5. Back To Top    #5
    Senior Member LinkBot's Avatar
    Join Date
    Mar 2015
    Posts
    222
    Threads
    16
    Local Date
    Aug 17th 2017
    Local Time
    03:41 AM

    Post KDE review board

    solid-device-automounter - Port to KF5: https://git.reviewboard.kde.org/r/124730/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •