Results 1 to 8 of 8

Thread: I get a pop-up from the Taskbar 'Logout prevented by /usr/bin/clemantine '

  1. Back To Top    #1
    Junior Member
    Join Date
    Oct 2016
    Posts
    16
    Threads
    4
    Local Date
    Jun 6th 2020
    Local Time
    11:46 AM

    I get a pop-up from the Taskbar 'Logout prevented by /usr/bin/clemantine '

    This has only started since I upgraded my system to Kubuntu 20.04. When I select 'Log Out', 'Shutdown' or 'Restart' from the KDE Menu, I get a pop-up from the Taskbar that says; 'Logout prevented by /usr/bin/clemantine '. This only lasts for a few seconds and then disappears. If I then try again, it works.

    Someone on my local LUG found this:
    https://github.com/clementine-player...ne/issues/6401.
    So it is known about, but no fix yet.

    Clearly this more of an irritation than anything, but if there's a fix for this it would be useful to know.

    I'm sure that if I were to shut down Clementine before attempting to log out, this would prevent the message, but I like leaving Apps that I use every day running at shutdown so they come up automatically the next time I boot up.

    Can anyone help?

  2. Back To Top    #2
    Insert Pithy Nothingness here claydoh's Avatar
    Join Date
    Sep 2005
    Location
    Savannah GA
    Posts
    8,242
    Threads
    228
    Local Date
    Jun 6th 2020
    Local Time
    06:46 AM
    Homepage: Go to claydoh's homepage
    The last release of clementine is from 2016, so that might have something to do with it.

    Wait, this is Focal, which is using a recent development release candidate, and is actually debian's packaging for this
    Either try a more recent snapshot
    https://github.com/clementine-player...ntine/releases

    Or try out Strawberry, which is a a more up to date fork of Clementine (itself a fork of of the ancient KDE3-era Amarok), and sees much more development, so it may be worth looking at
    https://www.strawberrymusicplayer.org/
    https://github.com/strawberrymusicplayer/strawberry

    https://launchpad.net/~jonaski/+arch...ntu/strawberry (ppa)

    It looks and acts just like Clementine, fwiw.

  3. Back To Top    #3
    Junior Member
    Join Date
    Oct 2016
    Posts
    16
    Threads
    4
    Local Date
    Jun 6th 2020
    Local Time
    11:46 AM
    claydoh,

    Thanks for that. I've downloaded and installed both packages. The latest RC of Clemantine still exhibits the same problem, so I'll try out Strawberry for a few days.

  4. Back To Top    #4
    Kubuntu as a Second Language jglen490's Avatar
    Join Date
    Jul 2006
    Location
    Montgomery AL
    Posts
    1,613
    Threads
    53
    Local Date
    Jun 6th 2020
    Local Time
    05:46 AM
    If you just leave the Clementine icon in the tray, it comes back. Clementine does not have to be running.
    I feel more like I do now than I did when I got here.
    Home Brew PC: ASRock H110M-HDS R3.0, 120GB+500GB, 16GB RAM
    Kubuntu 18.04.4.LTS Bionic, 5.3.0-53-generic x86_64, Plasma 5.12.9

  5. Back To Top    #5
    Junior Member
    Join Date
    Oct 2016
    Posts
    16
    Threads
    4
    Local Date
    Jun 6th 2020
    Local Time
    11:46 AM
    Quote Originally Posted by jglen490 View Post
    If you just leave the Clementine icon in the tray, it comes back. Clementine does not have to be running.
    I'm not sure how that helps when the problem is at shutdown, not startup.

  6. Back To Top    #6
    Esteemed Member SpecialEd's Avatar
    Join Date
    Feb 2017
    Location
    Wilmington, DelaWHERE?
    Posts
    655
    Threads
    57
    Local Date
    Jun 6th 2020
    Local Time
    06:46 AM
    Why not set Clementine to autostart at startup?
    If you think Education is expensive, try ignorance.

    The difference between genius and stupidity is genius has limits.

  7. Back To Top    #7
    Senior Member Beerislife's Avatar
    Join Date
    May 2016
    Location
    Tokyo
    Posts
    111
    Threads
    22
    Local Date
    Jun 6th 2020
    Local Time
    07:46 PM
    Isn't there a setting in Clementine to disable the tray icon?

  8. Back To Top    #8
    Junior Member
    Join Date
    Oct 2016
    Posts
    16
    Threads
    4
    Local Date
    Jun 6th 2020
    Local Time
    11:46 AM
    Quote Originally Posted by Beerislife View Post
    Isn't there a setting in Clementine to disable the tray icon?
    That was it! It's not Clementine the application that causing this behaviour, it's the tray icon. I just disabled it in Preferences, Shut Down; no problem :)

    Quote Originally Posted by jglen490 View Post
    If you just leave the Clementine icon in the tray, it comes back. Clementine does not have to be running.
    Is that what you meant?

    Quote Originally Posted by SpecialEd View Post
    Why not set Clementine to autostart at startup?
    It is and was setup to do that.

    BTW. I tried Strawberry, but now I've got a solution for this problem, I think I'll go back to Clementine; it has a fair few features that are simply not in Strawberry (yet perhaps; it is a very early version). (Similarly, Clementine lacks a few features that were in Amarok, but that isn't available in the repository anymore.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •