Results 1 to 6 of 6

Thread: Need help with PDFs opening in browser

  1. Back To Top    #1
    Senior Member
    Join Date
    Apr 2012
    Posts
    135
    Threads
    38
    Local Date
    Jun 5th 2020
    Local Time
    07:56 AM

    Need help with PDFs opening in browser

    We are doing schooling from home, and i can't figure out why PDFs open in window rather than inside the browser. This happens both in Chromium and Firefox. What setting is doing this? I am attaching a screenshot of windowed PDF as opposed to what i see on my desktop PC (where it gets opened inside the browser).

    My work around is to save them first, then open them in Okular, but for kids it is easier if it open in browser and if they can switch between tabs as they look up at the instructions. two of them have to share one small laptop on large kitchen desk, as we were just in the process of remodelling our desktop tables to provide more space for writing when the virus limitations struck.
    Attached Thumbnails Attached Thumbnails Screenshot_20200330_094710.jpg   Screenshot_20200331_083653.jpg  

  2. Back To Top    #2
    RSDC of the Loyal Order of Loosejaw woodsmoke's Avatar
    Join Date
    Oct 2010
    Location
    midwest U.S.A. (ummm that is...flyover country to the elites)
    Posts
    6,416
    Threads
    1227
    Local Date
    Jun 5th 2020
    Local Time
    12:56 AM
    Hi
    You pose an interesting question, thank you!

    It just so happens that the college whereat I teach dropped Adobe to use Chrome browser to view .pdfs and I view a LOT of them because I use them with a projector for my lectures.

    a) I do not see this behaviour with Chrome at the college.
    b) I do not see this behavour with Firefox on my Neon work computer at home running 72.0.1

    I see what you see in the LOWER image.

    I looked through "all of the settings" and could not find a "setting" or extension or whatever in Firefox for how to handle ,pdf.

    So I thought I would search and did not find anything so went on the net and APPARENTLY the situation is the particular "word".

    The way that FF handles images can be found in "settings" and the way to find it is to search using the word "preview".

    So, maybe go to the symbol at the top right with the three horizontal bars and click it.

    Go to preferences and you will be in the GENERAL tab.

    Go up to the top right to a box which should be labled "find in preferences".

    Type in "preview"

    You will land a a page that says something like "APPLICATIONS choose how Firefox handles ... and below there is a box with a listing of a bunch of things like "jpeg" ".doc" whatever

    scroll down and you will eventually find

    Portable Document Format . PDF

    FOR ME..it says : "preview in Firefox".

    HOWEVER there is a little black down arrow and there options like "always ask" "use GNU Image Manipulation" and others.

    You might try switching to "preview in Firefox" if it is on something else.

    Anyway, holler back if that does not work and I am sure that somebody much more knowledgable than me will stop by with a good answer.

    woodsmoke
    Last edited by woodsmoke; Mar 31st 2020 at 10:42 AM.
    Love Thy Neighbor Baby!

  3. Back To Top    #3
    Senior Member
    Join Date
    Apr 2012
    Posts
    135
    Threads
    38
    Local Date
    Jun 5th 2020
    Local Time
    07:56 AM
    i already have it set to be previewed in Firefox. you are right there doesn't appear to be such a setting. i also checked.

    but i was thinking that maybe it is scripted (or defaulted) on the page to open in a new window. I've noticed that i am blocking some scripts on one PC the other day. It looks like i need to do some testing. But today i had to go to work at the office, so this will have to wait at least until i get home.

    cause i find it strange that it does this on chromium as well. pops up the same kind of window.

  4. Back To Top    #4
    RSDC of the Loyal Order of Loosejaw woodsmoke's Avatar
    Join Date
    Oct 2010
    Location
    midwest U.S.A. (ummm that is...flyover country to the elites)
    Posts
    6,416
    Threads
    1227
    Local Date
    Jun 5th 2020
    Local Time
    12:56 AM
    ok!
    holler back!
    woodsmoke
    Love Thy Neighbor Baby!

  5. Back To Top    #5
    Senior Member
    Join Date
    Apr 2012
    Posts
    135
    Threads
    38
    Local Date
    Jun 5th 2020
    Local Time
    07:56 AM
    looks like the have it made in a way that PDF is opening in new (popup) windows. not sure how or why they've made it like that. but i guess they are self taught web designers.

    using noscript script blocker addon in Firefox it blocks this behaviour and the PDF is opened in new tab and inside Firefox. a work around and is working quite well. the boys are now able to share the screen better and almost no printing is necessary. productivity is through the roof!!! * not really, i mean who can be productive with all the toys lying around and all those Steam & GOG games available in next room.

  6. Back To Top    #6
    RSDC of the Loyal Order of Loosejaw woodsmoke's Avatar
    Join Date
    Oct 2010
    Location
    midwest U.S.A. (ummm that is...flyover country to the elites)
    Posts
    6,416
    Threads
    1227
    Local Date
    Jun 5th 2020
    Local Time
    12:56 AM
    Hi
    thanks for the info! I deal with PDFs. all the time from the college, this is good info.
    woodsmoke
    Love Thy Neighbor Baby!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •