Results 1 to 5 of 5

Thread: Unable to use wirelles network in Kubuntu 12.10

  1. Back To Top    #1
    Newbie
    Join Date
    Oct 2012
    Posts
    4
    Threads
    1
    Local Date
    Jun 3rd 2020
    Local Time
    08:44 PM

    Unable to use wireless network in Kubuntu 12.10

    I can not check the "Enable wireless" option. If I click this option it unselect itself. The option is available and not grayed out.

    I've first encountered problem afrer upgrainug Kubuntu 12.04 to new kernel yesterday. I hoped that the problem will be solved after upgrading to latest Kubuntu version.

    I believe that wireless card is not supported by kernel ie. I do not have the right drivers installed. Unfortunately I do not know which package to install or which configuration file I must change.

    Data about my hardware.

    Code:
    x:/home/uros# lspci | grep -i net
    02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
    
    x:~$ iwconfig wlan0 
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    Any help or pointers in right direction would be greatly appreciated.
    Last edited by beardman; Oct 25th 2012 at 12:27 PM. Reason: fixed typo in title

  2. Back To Top    #2
    Junior Member
    Join Date
    Oct 2012
    Posts
    10
    Threads
    1
    Local Date
    Jun 3rd 2020
    Local Time
    08:44 PM
    Please check system for iwlwifi. For example:
    Code:
    lsmod | grep iwlwifi
    If iwlwifi is installed, check /etc/modprobe.d/iwlwifi.conf file.
    Your wifi card is ubuntu certified
    There is some information about using Centrino Wireless-N 2230 in Ubuntu: http://ubuntuforums.org/showthread.php?t=2050475 Maybe it will be useful for you.

  3. Back To Top    #3
    Newbie
    Join Date
    Oct 2012
    Posts
    4
    Threads
    1
    Local Date
    Jun 3rd 2020
    Local Time
    08:44 PM
    I seems iwlwifi is installed.
    Code:
    :~$ lsmod | grep iwlwifi
    iwlwifi               386826  0 
    mac80211              539908  1 iwlwifi
    cfg80211              206566  2 iwlwifi,mac80211
    The contents of /etc/modprobe.d/iwlwifi.conf

    Code:
    # /etc/modprobe.d/iwlwifi.conf
    # iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
    # microcode file installed on the system.  When removing iwlwifi, first
    # remove the iwl?vm module and then iwlwifi.
    remove iwlwifi \
    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
    && /sbin/modprobe -r mac80211
    Changing the parameters as suggested in linked thread did not help.

  4. Back To Top    #4
    Newbie
    Join Date
    Oct 2012
    Posts
    4
    Threads
    1
    Local Date
    Jun 3rd 2020
    Local Time
    08:44 PM
    Some additional info. I've tried to run Kubuntu 12.10 from USB with same result. I've also tried Ubuntu 12.10 where I can connect to wireless network. I believe there is a bug in the way KDE handles wireless networks and not in the configuration, because iwlist finds networks and I am able to connect from command-line.

  5. Back To Top    #5
    Newbie
    Join Date
    Oct 2012
    Posts
    4
    Threads
    1
    Local Date
    Jun 3rd 2020
    Local Time
    08:44 PM
    I've found workaround. You must click "Manage connections" and manually add wireless network.

Similar Threads

  1. Unable to connect to hidden Network
    By ntuple in forum Network Support
    Replies: 2
    Last Post: Oct 11th 2014, 10:59 PM
  2. Replies: 12
    Last Post: Nov 29th 2012, 05:16 AM
  3. [Solved] Unable to get network to work
    By vinnig in forum Network Support
    Replies: 10
    Last Post: Nov 4th 2008, 11:29 PM
  4. Unable to configure network settings
    By tameboy in forum Network Support
    Replies: 16
    Last Post: Aug 20th 2008, 08:35 AM
  5. Unable to Network connect Internet
    By simbiwa in forum Hardware Support
    Replies: 33
    Last Post: Sep 27th 2006, 09:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •