Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Can't install anything, bad libsqlite3-0:amd64

  1. Back To Top    #1
    Newbie
    Join Date
    Feb 2009
    Posts
    3
    Threads
    1
    Local Date
    May 28th 2020
    Local Time
    09:04 PM

    Can't install anything, bad libsqlite3-0:amd64

    Hi,
    I'm already tryed cleaning all the way but this error continue:

    asf100@mj-117105:~$ LANG=C;sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libsqlite3-0:i386
    The following packages will be upgraded:
    libsqlite3-0:i386
    1 upgraded, 0 newly installed, 0 to remove and 290 not upgraded.
    2 not fully installed or removed.
    Need to get 354 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Get:1 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main libsqlite3-0 i386 3.7.9-2ubuntu1.1 [354 kB]
    Fetched 354 kB in 0s (467 kB/s)
    dpkg: error processing libsqlite3-0:i386 (--configure):
    libsqlite3-0:i386 3.7.9-2ubuntu1 cannot be configured because libsqlite3-0:amd64 is in a different version (3.7.9-2ubuntu1.1)
    dpkg: error processing libsqlite3-0 (--configure):
    libsqlite3-0:amd64 3.7.9-2ubuntu1.1 cannot be configured because libsqlite3-0:i386 is in a different version (3.7.9-2ubuntu1)
    Errors were encountered while processing:
    libsqlite3-0:i386
    libsqlite3-0
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    asf100@mj-117105:~$ LANG=C;sudo apt-get --fix-missing install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    libsqlite3-0 : Breaks: libsqlite3-0:i386 (!= 3.7.9-2ubuntu1.1) but 3.7.9-2ubuntu1 is installed
    libsqlite3-0:i386 : Breaks: libsqlite3-0 (!= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is installed
    E: Unmet dependencies. Try using -f.

    Anyone knows what is?

  2. Back To Top    #2
    Pan-Galactic Quordlepleen SteveRiley's Avatar
    Join Date
    Jul 2011
    Location
    Seattle, WA, USA
    Posts
    9,636
    Threads
    350
    Local Date
    May 28th 2020
    Local Time
    01:04 PM
    Hm, somehow there's a version mismatch between the 32-bit and 64-bit libraries currently installed on your machine. There are some brute-force ways to clean this up. But first, I'd like a closer look at what you have. Please show the output of these three commands:

    Code:
    dpkg -l | grep libsqlite
    
    apt-cache policy libsqlite3-0:amd64
    
    apt-cache policy libsqlite3-0:i386

  3. Back To Top    #3
    Newbie
    Join Date
    Feb 2009
    Posts
    3
    Threads
    1
    Local Date
    May 28th 2020
    Local Time
    09:04 PM
    Quote Originally Posted by SteveRiley View Post
    Hm, somehow there's a version mismatch between the 32-bit and 64-bit libraries currently installed on your machine. There are some brute-force ways to clean this up. But first, I'd like a closer look at what you have. Please show the output of these three commands:

    Code:
    dpkg -l | grep libsqlite
    
    apt-cache policy libsqlite3-0:amd64
    
    apt-cache policy libsqlite3-0:i386
    Hi Steve, grateful for your concern. Here is the code:

    Code:
     
    asf100@mj-117105:~$ dpkg -l | grep libsqlite
    iU  libsqlite3-0                          3.7.9-2ubuntu1.1                        SQLite 3 shared library
    iF  libsqlite3-0:i386                     3.7.9-2ubuntu1                          SQLite 3 shared library
    asf100@mj-117105:~$ apt-cache policy libsqlite3-0:amd64
    libsqlite3-0:
      Instalado: 3.7.9-2ubuntu1.1
      Candidato: 3.7.9-2ubuntu1.1
      Tabela de versão:
     *** 3.7.9-2ubuntu1.1 0
            500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
            100 /var/lib/dpkg/status
         3.7.9-2ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
    asf100@mj-117105:~$ LANG=C;apt-cache policy libsqlite3-0:amd64
    libsqlite3-0:
      Installed: 3.7.9-2ubuntu1.1
      Candidate: 3.7.9-2ubuntu1.1
      Version table:
     *** 3.7.9-2ubuntu1.1 0
            500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
            100 /var/lib/dpkg/status
         3.7.9-2ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
    asf100@mj-117105:~$ LANG=C;apt-cache policy libsqlite3-0:i386
    libsqlite3-0:i386:
      Installed: 3.7.9-2ubuntu1
      Candidate: 3.7.9-2ubuntu1.1
      Version table:
         3.7.9-2ubuntu1.1 0
            500 http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
     *** 3.7.9-2ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
            100 /var/lib/dpkg/status
    asf100@mj-117105:~$
    Thanks.

  4. Back To Top    #4
    Pan-Galactic Quordlepleen SteveRiley's Avatar
    Join Date
    Jul 2011
    Location
    Seattle, WA, USA
    Posts
    9,636
    Threads
    350
    Local Date
    May 28th 2020
    Local Time
    01:04 PM
    OK, that's what I suspected. I'm not able to precisely recreate your situation to test, but here's a procedure that I suspect will get you going. We'll manually download and install each package. I'll explain each step.

    1. Download the 64-bit version:
    Code:
    apt-get download libsqlite3-0:amd64
    2. Download the 32-bit version:
    Code:
    apt-get download libsqlite3-0:i386
    3. Forcibly remove the existing 64-bit version:
    Code:
    sudo dpkg --force-depends --purge libsqlite3-0:amd64
    4. Forcibly remove the existing 32-bit version:
    Code:
    sudo dpkg --force-depends --purge libsqlite3-0:i386
    5. Manually install the 64-bit version:
    Code:
    sudo dpkg --install libsqlite3-0*amd64.deb
    6. Manually install the 32-bit version:
    Code:
    sudo dpkg --install libsqlite3-0*i386.deb

  5. Back To Top    #5
    Newbie
    Join Date
    Feb 2009
    Posts
    3
    Threads
    1
    Local Date
    May 28th 2020
    Local Time
    09:04 PM
    Dear Steve,

    You are the master of the universe. Everything is working now, even the system update are OK.

    Thanks.

  6. Back To Top    #6
    Pan-Galactic Quordlepleen SteveRiley's Avatar
    Join Date
    Jul 2011
    Location
    Seattle, WA, USA
    Posts
    9,636
    Threads
    350
    Local Date
    May 28th 2020
    Local Time
    01:04 PM
    Glad it's working for you.

  7. Back To Top    #7
    Newbie
    Join Date
    May 2010
    Posts
    3
    Threads
    1
    Local Date
    May 28th 2020
    Local Time
    09:04 PM
    I tried your solution, and was not successful. It complains that libsqlite3-0:amd64 3.7.13-1~bpo60+1 cannot be configured because libsqlite3-0:i386 is in a different version (3.7.9-2ubuntu1.1)

    Any help would be appreciated.
    Thanks,
    Steve

    Code:
    % /usr/bin/sudo apt-get download libsqlite3-0:amd64
    Get:1 Downloading libsqlite3-0 3.7.13-1~bpo60+1 [453 kB]
    Fetched 453 kB in 0s (942 kB/s)      
    % /usr/bin/sudo apt-get download libsqlite3-0:i386
    Get:1 Downloading libsqlite3-0 3.7.9-2ubuntu1.1 [354 kB]
    Fetched 354 kB in 0s (394 kB/s)       
    % /usr/bin/sudo dpkg --force-depends --purge libsqlite3-0:amd64
    dpkg: libsqlite3-0: dependency problems, but removing anyway as you requested:
     libmono-sqlite2.0-cil depends on libsqlite3-0 (>= 3.6.13).
     libsqlite3-dev depends on libsqlite3-0 (= 3.7.9-2ubuntu1.1).
     unity-lens-music depends on libsqlite3-0 (>= 3.5.9).
     libpackagekit-glib2-14 depends on libsqlite3-0 (>= 3.5.9).
     libnss3 depends on libsqlite3-0 (>= 3.5.9).
     libkrb5-26-heimdal depends on libsqlite3-0 (>= 3.5.9).
     f-spot depends on libsqlite3-0.
     telepathy-salut depends on libsqlite3-0 (>= 3.5.9); however:
      Package libsqlite3-0 is to be removed.
     libcamel-1.2-29 depends on libsqlite3-0 (>= 3.6.0).
     libmono-sqlite4.0-cil depends on libsqlite3-0 (>= 3.6.13).
     libedata-book-1.2-11 depends on libsqlite3-0 (>= 3.5.9).
     libsunpinyin3 depends on libsqlite3-0 (>= 3.5.9).
     libqtwebkit4 depends on libsqlite3-0 (>= 3.5.9).
     libebackend-1.2-1 depends on libsqlite3-0 (>= 3.6.0).
     python2.7-dbg depends on libsqlite3-0 (>= 3.5.9).
     libyelp0 depends on libsqlite3-0 (>= 3.5.9).
     libdbd-sqlite3 depends on libsqlite3-0 (>= 3.5.9).
     python2.7 depends on libsqlite3-0 (>= 3.5.9).
     libsvn1 depends on libsqlite3-0 (>= 3.6.22).
     ibus-pinyin depends on libsqlite3-0 (>= 3.6.11); however:
      Package libsqlite3-0 is to be removed.
     xmms2-core depends on libsqlite3-0 (>= 3.5.9).
     libaprutil1-dbd-sqlite3 depends on libsqlite3-0 (>= 3.5.9).
     libwebkitgtk-3.0-0 depends on libsqlite3-0 (>= 3.5.9).
     telepathy-gabble depends on libsqlite3-0 (>= 3.5.9); however:
      Package libsqlite3-0 is to be removed.
     indicator-appmenu depends on libsqlite3-0 (>= 3.5.9).
     zeitgeist-core depends on libsqlite3-0 (>= 3.5.9).
     libsasl2-modules-sql depends on libsqlite3-0 (>= 3.5.9).
     libgpod4 depends on libsqlite3-0 (>= 3.5.9).
     libtelepathy-logger2 depends on libsqlite3-0 (>= 3.5.9).
     sqlite3 depends on libsqlite3-0 (= 3.7.9-2ubuntu1.1).
     libqt4-sql-sqlite depends on libsqlite3-0 (>= 3.5.9).
     colord depends on libsqlite3-0 (>= 3.5.9).
     libsoup-gnome2.4-1 depends on libsqlite3-0 (>= 3.5.9).
     libwebkitgtk-1.0-0 depends on libsqlite3-0 (>= 3.5.9).
     shotwell depends on libsqlite3-0 (>= 3.5.9).
    (Reading database ... 419084 files and directories currently installed.)
    Removing libsqlite3-0 ...
    Purging configuration files for libsqlite3-0 ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    % /usr/bin/sudo dpkg --force-depends --purge libsqlite3-0:i386
    dpkg: libsqlite3-0:i386: dependency problems, but removing anyway as you requested:
     libkrb5-26-heimdal:i386 depends on libsqlite3-0 (>= 3.5.9).
    (Reading database ... 419080 files and directories currently installed.)
    Removing libsqlite3-0:i386 ...
    Purging configuration files for libsqlite3-0:i386 ...
    dpkg: warning: while removing libsqlite3-0:i386, directory '/usr/share/doc/libsqlite3-0' not empty so not removed.
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    % /usr/bin/sudo dpkg --install libsqlite3-0*amd64.deb
    Selecting previously unselected package libsqlite3-0.
    (Reading database ... 419075 files and directories currently installed.)
    Unpacking libsqlite3-0 (from libsqlite3-0_3.7.13-1~bpo60+1_amd64.deb) ...
    Setting up libsqlite3-0 (3.7.13-1~bpo60+1) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    % /usr/bin/sudo dpkg --install libsqlite3-0*i386.deb
    Selecting previously unselected package libsqlite3-0:i386.
    (Reading database ... 419083 files and directories currently installed.)
    Unpacking libsqlite3-0:i386 (from libsqlite3-0_3.7.9-2ubuntu1.1_i386.deb) ...
    De-configuring libsqlite3-0 ...
    dpkg: error processing libsqlite3-0:i386 (--install):
     libsqlite3-0:i386 3.7.9-2ubuntu1.1 cannot be configured because libsqlite3-0:amd64 is in a different version (3.7.13-1~bpo60+1)
    dpkg: error processing libsqlite3-0 (--install):
     libsqlite3-0:amd64 3.7.13-1~bpo60+1 cannot be configured because libsqlite3-0:i386 is in a different version (3.7.9-2ubuntu1.1)
    Errors were encountered while processing:
     libsqlite3-0:i386
     libsqlite3-0
    %
    Last edited by SteveRiley; Oct 8th 2012 at 10:53 PM. Reason: wrapped output in CODE tags

  8. Back To Top    #8
    Pan-Galactic Quordlepleen SteveRiley's Avatar
    Join Date
    Jul 2011
    Location
    Seattle, WA, USA
    Posts
    9,636
    Threads
    350
    Local Date
    May 28th 2020
    Local Time
    01:04 PM
    This...
    Code:
    % /usr/bin/sudo apt-get download libsqlite3-0:amd64
    Get:1 Downloading libsqlite3-0 3.7.13-1~bpo60+1 [453 kB]
    Fetched 453 kB in 0s (942 kB/s)
    % /usr/bin/sudo apt-get download libsqlite3-0:i386
    Get:1 Downloading libsqlite3-0 3.7.9-2ubuntu1.1 [354 kB]
    Fetched 354 kB in 0s (394 kB/s)
    ...is why. Notice that the version numbers are different. It should be 3.7.9-2ubuntu1.1 for both 64-bit and 32-bit, but for some reason your package manager is pulling in a newer version of the 64-bit library. Let's find out where from. Please run:
    Code:
    apt-cache policy libsqlite3-0:amd64

  9. Back To Top    #9
    Newbie
    Join Date
    Mar 2013
    Posts
    4
    Threads
    0
    Local Date
    May 28th 2020
    Local Time
    10:04 PM
    Hi,
    I get the similar error while installing sqlite3 on Ubuntu 12.04 x64.
    Code:
    The following packages have unmet dependencies:
     sqlite3 : Depends: libsqlite3-0 (= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is to be installed
    In my case there is no mismatch between x86 and x64 libsqlite3-0 version.
    I tried to force version 3.7.9-2ubuntu1 instead of 3.7.9-2ubuntu1.1 using synaptic but it requries removing few packages like skype, amarok... So I don't think that's a good way to do it.

    Could you give me a hand?

  10. Back To Top    #10
    Pan-Galactic Quordlepleen SteveRiley's Avatar
    Join Date
    Jul 2011
    Location
    Seattle, WA, USA
    Posts
    9,636
    Threads
    350
    Local Date
    May 28th 2020
    Local Time
    01:04 PM
    What are you trying to install that requires sqlite3?

Page 1 of 2 12 LastLast

Similar Threads

  1. K 9.10 AMD64 install snafu
    By jetgraphics in forum Help the New Guy
    Replies: 8
    Last Post: Apr 24th 2010, 05:37 PM
  2. amd64 9.10 Wubi Install
    By spaulding in forum Help the New Guy
    Replies: 10
    Last Post: Nov 3rd 2009, 03:33 PM
  3. AMD64 Install Lockups
    By EzInKy in forum Installation and Boot
    Replies: 5
    Last Post: Oct 12th 2007, 07:13 AM
  4. Install Skype on AMD64
    By Kdar in forum Software Support
    Replies: 2
    Last Post: Apr 21st 2007, 09:19 AM
  5. How to install RealPlayer in Kubuntu 6.06[amd64]
    By eskimokid in forum Software Support
    Replies: 4
    Last Post: Feb 2nd 2007, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •