Announcement

Collapse
No announcement yet.

No wi-fi reported

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No wi-fi reported

    Hey,

    I am new to KUbuntu and after a few years of distro hopping, I have landed on KUbuntu (because I like KDE) and hope to stay :-)

    However, before I fully dive into it, I thought to do a test run through a VM. Everything works great, except for the wifi.

    I have a TP Link AC600 USB adapter. I followed the steps to install the drivers and everything went well. I rebooted my the VM and tried to check for the wifi. It is not showing up.

    How do I get it work? I feel if I can sort this out, I can go ahead and install KUbuntu into my main HDD.

    Thank you!

    #2
    Originally posted by hkarthi View Post
    I have a TP Link AC600 USB adapter. I followed the steps to install the drivers and everything went well. I rebooted my the VM and tried to check for the wifi. It is not showing up.
    The wifi dongle working in the host OS, I assume, and the hardware device has been passed through to the virtual machine, and that the guest OS detects the hardware ?
    Running the lsusb command in Kubuntu VM will show the device ID if it has been successfully passed through. My Virtualbox skills are quite rusty, and my VMWare ones are nonexistent, but in VB it should be fairly straightforward to attach the USB dongle to the virtual machine.
    If attaching the dongle IS is working , and the device does show up, paste the relevant device info from the lsusb command so we can see which specific chip this is using. Sometimes there are variants, or the manufacturer moves to a different version, etc.

    I'll ask Jeeves

    Comment


      #3
      hkarthi,
      First, a disclaimer: I am not an expert in Kubuntu, though I've been using it for a dozen years. (That I am a "Veteran Member" is merely testimony to my age, not my skill.) What VM software are you using? I gather from claydoh's post it is Virtualbox, with which I am unfamiliar (I use WMware and have K as my host system with a Windows VM). If Virtualbox is at all like VMware, you should check the type of connection for your network in the VM. Is it NAT or is it bridged? Whichever one it is, try the other one and see if that helps.

      Comment


        #4
        Thank you for the response. And sorry for not providing proper details (such a noob move )

        1. Yes I am using Oracle Virtualbox to test KUbuntu.
        2. Yes the USB adapter is being detected by my Windows 10.
        3. Here is the result from lsusb command.

        Code:
        khr@GraySkull:~$ lsusb
        Bus 001 Device 002: ID 12d1:4321 Huawei Technologies Co., Ltd. HiCamera
        Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
        Bus 002 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
        Bus 002 Device 003: ID 0d8c:0005 C-Media Electronics, Inc. Blue Snowball
        Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
        Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
        
        ​
        I don't see TP Link here in the list.

        @Don: I also tried changing the network selection from NAT to Bridged (and by choosing TP Link Adapter) and I still don't see WIFI option enabled. It shows only the wired network. The settings I have in my Virtualbox is:

        Code:
        Network:
        
        Adapter 1: Intel PRO/1000 MT Desktop (Bridged Adapter, TP-Link Wireless USB Adapter)
        Thanks for your help!

        Comment


          #5
          On V.B. you do not normally access the network device directly like in a Harddrive install. You have to pass the network on from the Host machine. In your case windows.
          this page may be of help. Good Luck.
          In this article, we will describe a straightforward method of setting up a network between a guest virtual machines and the Linux host in oracle virtualbox.
          Dave Kubuntu 20.04 Registered Linux User #462608

          Wireless Script: http://ubuntuforums.org/showthread.p...5#post12350385

          Comment


            #6
            Originally posted by hkarthi View Post
            I don't see TP Link here in the list.
            Yes, you won't necessarily see a brand name, but the actual chip manufacturer that the brand uses, probably Realtek.

            But as kc1di mentions, in a virtual machine, networking is usually passed through, or shared, from the host to the guest. This is often via a virtualized network, usually a 'fake' wired Ethernet connection, so you won't normally see a wifi connection at all in the VM.

            Now, if you want to see how well your specific wifi dongle works (or proboably, doesn't work), and what is needed to get a driver set up for it in Linux, you probably need to install Virtual Box's Extension Pack to allow USB support, then try passing the dongle directly to the Guest. It *should* show up in lsusb then.
            I'll ask Jeeves

            Comment


              #7
              kc1di

              Thank you for the links. I will check it out.

              claydoh

              I did some more googling and found that for some of the folks the WIFI worked right out of the box (not in VM). But nevertheless, let me check the links and see if I can try some of the steps mentioned.

              But I feel that I can try installing Kubuntu in the system and start using it. I will keep posted on how that goes.

              Comment

              Working...
              X