No announcement yet.

No Repository List

  • Filter
  • Time
  • Show
Clear All
new posts

    No Repository List

    I upgraded to 24.04 and so far it is working fine. But I can't find the list of my repositories. I tried Stacer, and it says that no APT repositories can be found. I then tried Synaptic, and it said nothing at all. So where are they, and how can I access them? Any help would be appreciated.

    They are separate files in /etc/apt/sources.list.d, same as PPAs and other addon repos, to fit with Debian's newer source file format option.
    Ubuntu's 24.04 release notes on this.
    The spec for it.

    Check the Software Sources tool in Discover's settings area.
    For Synaptic, you can replace its rudimentary sources tool with the Gtk version of the Software Sources tool software-properties-gtk.

    Either of these *should* show the sources using the new format, but not 100% sure.

    Stacer will need to update to support this, which started happening in 23.10.
    and maybe
    Last edited by claydoh; Jun 22, 2024, 09:37 PM.


      They are listed now as individual files inside
      Easy enough to manipulate with the konsole and text editor. Neither Discover or Synaptic versions in 24.04 are able to use the new format (at least in my installation). Been the case since 23.10 and took me a while to figure it out.
      Processor: AMD FX-8320 Eight-Core @ 4.00GHz (8 Cores,) Motherboard: ASUS M5A97 R2.0, Memory: 32768MB
      Disk: 2000GB ST2000DM001-9YN1 + 1000GB ST31000340AS, Network: Realtek RTL8111/8168/8411
      Graphics: ASUS AMD Radeon HD 7850, Audio: C-Media CMI8788, Monitor: S220HQL