No announcement yet.

Is Wayland compatible with Intel 12th Gen CPUs? (Solved)

  • Filter
  • Time
  • Show
Clear All
new posts

    Is Wayland compatible with Intel 12th Gen CPUs? (Solved)

    I'm not sure if I'm putting this in the right location or not. But How well does Wayland run with Intel 12th gen CPUs? I looked online and according to some info it does work and others aren't a 100% clear if it does. The reason I put this question here is because I thought I heard Ubuntu 23.10 and beyond ships by default with Wayland.

    Why would you think that these CPUs would not work with Wayland? Or do you mean the iGPUs?
    Intel is still more common than AMD, even in the Linux world - and there would most certainly have been many, many reports by now if there was a major problem with Intel's newer CPUs/iGPUs and Wayland.

    I have not had the situation that Wayland would not work with Intel's 12th and 13th gen CPUs. But I only did test this for a very short period each time, because the desired default session type was X11. I could log into a Wayland session and I did not see anything unusual - these were machines I installed Linux on for other people.

    PS: Kubuntu is shipped with Wayland for some time now (others may exactly know since when) - but the default session is still X11 (you can try this by booting from an USB with a live session).

    PPS: From the Kubuntu 23.10 release notes: "A Plasma Wayland session is available for testing, but is not supported. A Wayland session can be started by selecting it at the login screen."

    Ubuntu's 23.10 default session is Wayland on the other hand…
    Last edited by Schwarzer Kater; Dec 14, 2023, 04:56 PM. Reason: added PS & PPS and typos… *sigh*
    Debian KDE & LXQt • Kubuntu & Lubuntu • openSUSE KDE • Windows • macOS X
    Desktop: Lenovo ThinkCentre M75s • Laptop: Apple MacBook Pro 13" • and others

    get rid of Snap script (20.04 +)reinstall Snap for release-upgrade script (20.04 +)
    install traditional Firefox script (22.04 +)​ • install traditional Thunderbird script (24.04)



      I don't know what you are looking at for info, but
      It isn't the CPU that might be problematic, it is Nvidia graphics on Plasma, for some. Not sure how it fares on these GPUs in Gnome.
      It works fine on Intel and AMD graphics, as far as I can tell, not only in my own usage. Even on older systems - 4th gen and 6th gen intel graphics, in my case. Things are fine on my 13th gen "Gaming!" PC with an AMD RX6650.

      Log in to a Wayland session and try it out. Worst that can happen is you log back in to a X11 session if you have any sort of issues, or if the differences you find are bothersome.

      With Wayland, much any Linux related topic, there will be a LOT of outdated information out there muddying the water. You have to look at the dates for recency and relevancy. Then, you have to discount the overtly political garbage, the knee-jerking, dog-piling, and the attention seeking posts on the topic.


        Thanks both of you. On my Kubuntu 22.04 system it defaulted to X11 instead Wayland when I installed it that was part of the reason I thought that there might be a problem with Wayland with Intel CPUs, and I'm using a Intel 12th Gen Core i7 12700. So its great to know that there aren't any issues with Intel at all with Wayland.