No announcement yet.

Verification failed: (0x1A) Security Violation after installing Kubuntu 22.04.2

  • Filter
  • Time
  • Show
Clear All
new posts

    Verification failed: (0x1A) Security Violation after installing Kubuntu 22.04.2


    I have recently downloaded and installed Kubuntu 22.04.2 (verified SHA256) for testing on my Dell OptiPlex PC. Everything worked well as planned which is great. However, when I went to reinstall my main OS, Linux Mint 21.1, back to the same PC, I get a blue screen ERROR Verification failed: (0x1A) Security Violation message.

    Upon researching, it seems that Kubuntu's latest version has some updated security keys that install to the BIOS.

    Now, everything that I have used in the past ((Linux Mint 21.1 and Clonezilla) no longer works and just gives the error message.

    Is there a way to revert back to the old security keys, or are they forever gone? Will I have to wait for my other distros to update their ISO's?

    Thanks in advance,


    No OS, not even Windows, writes anything to a PCs BIOS.
    Using Kubuntu Linux since March 23, 2007
    "It is a capital mistake to theorize before one has data." - Sherlock Holme


      Originally posted by Snowhog View Post
      No OS, not even Windows, writes anything to a PCs BIOS.
      Not quite true, they can set the default boot order, this is how Windows can hijack this, and reset itself as the first bott OS after an update. Also efibootmgr in linux, either from an OS intstall, or just to make changes on the cli, and for System Settings option to "After next restart Enter EFI setup screen", i.e the 'BIOS'.

      Also, this IS at least partially an Ubuntu bug
      One explanation

      Your post in the Mint forums already has all this info, though.

      Try disabling secure boot, see if there are options to clear any keys or authentication in your bios
      Or just leave secure boot disabled, for now at least.

      This just popped up, but the only reports I see on the web are mostly yours lol.


        Thanks for your replies.

        I have disabled secure boot and installed Linux Mint with no issue. Once there, I used mokutil to clear any keys, but this didn't fix the issue. Still getting the Verification failed message when secure boot is re-enabled and the Mint installer is run. I also looked at the Dell BIOS menu, and reset everything there too and still no change.

        I feel I may just have to wait until the distros update their ISOs to be inline with the latest changes to match the current configuration. Maybe it's just something I have to accept and move forward. However, I will keep researching, because I feel this is very strange.

        Thanks again and any further input will be extremely helpful.