Announcement

Collapse
No announcement yet.

Fresh 20.04 install -- GCC broken

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fresh 20.04 install -- GCC broken

    Brand new install of Kubuntu 20.04.2 on a new Asus / Intel i5-12600K with nVidia Quadro RTX 4000 graphics card.
    ASUS motherboard does NOT have built-in WiFi, so I purchased a TP-Link AC1300 USB dongle / thingie / antenna.

    So, after installation, no network... as the TP-LINK USB dongle is not recognized.

    Now, I managed to wade through this installation (mess) on a different computer, but with an nVidia GTX-1060 graphics card a few weeks ago... but on this system... no joy.

    Symptoms:
    1) After installation, unable to connect to network via WiFi (duh.... TP-LINK USB adapter not recognized).
    2) However, unable to install WiFi adapter (via various drivers available via Git Hub (per Ask Ubuntu forum posts))... because DKMS & Build-Essential packages are missing.
    3) I can download those packages from Ubuntu website... BUT they will *not* install because GCC is not installed.

    % sudo apt install gcc

    fails, however, with a number of unmet dependencies... primarily relating to GCC version 9. Drilling down further... GCC 9 depencies are NOT being installed because.... GCC 10 & related are *not* installed.

    Huh?

    Well... no sh*t Sherlock... GCC 9 is not going to install if GCC 10 is not installed.

    What am I missing?

    This is a brand new Kubuntu 20.04 install (20.04.2, I believe).

    Is this mess fixed in 20.04.4? (Or 22.04?)

    TIA.

    #2
    Your problem is that with no internet connection, installing anything not in the iso fails, as the packages are downloaded from repositories on the internet.

    Conceivably, a later Kubuntu will recognize the dongle, but how do you get the later Kubuntu? Presumably you have some access to the internet, since you post here.

    If you have physical access to the Wi-Fi router, an ethernet cable might sort it all out for you. Using the cable would be a temporary arrangement.
    Regards, John Little

    Comment


      #3
      What's the actual error output when installing build-essential?
      Originally posted by steve2267 View Post
      3) I can download those packages from Ubuntu website
      if you are manually down loading individual debs, that unfortunately won't work easily, as you are seeing all the dependencies needed, so thjere will be quite a few packages still needed.
      HOWEVER: (I just remembered)
      All the packages you need are on the installer disk.

      The easiest way to use this is to grab your 20.04 installer disk, and plug it in. Open it in Dolphin to make sure it is mounted.
      Then open Discover, or Muon, and find the Software Sources tool.

      Under Other Software you will see some options highlighted below:

      Click image for larger version  Name:	Screenshot_20220424_190715.png Views:	0 Size:	178.2 KB ID:	662462

      I *think* this feature still works , don't think I have used it in over a decade maybe.
      The installer USB is still seen as a CD-ROM, just not sure iof simply checking the box for 'cdrom' or if you need to use the 'add cdrom'.
      Once that is done , you should be able to install build-essential and dkms

      I am still trying to find a pictorial or video of this being used. Multitasking here, as is my usual SOP
      I may try a demo if I can find a free moment or three.


      Nope, it does 't seem possible, it is looking for a physical optical drive (/dev/sr0), however the files ARE on the installer disk under /pool/main/

      I'd still suggest using Ethernet or wifi tethering, probably easier and less hassle, though again, all the dependencies are on the installer image, it would just be a bit tedious.

      On another computer, you might try a script such as the one here: https://askubuntu.com/questions/1283...thout-internet..
      Then install the packages using sudo dpkg -i /path-to/ther_files/*.deb
      Last edited by claydoh; Apr 24, 2022, 05:59 PM.
      I'll ask Jeeves

      Comment


        #4
        Here is an update...

        Re-reading my original post... it appears I failed to state that after installation, I had copied the Kubuntu 20.04 ISO image to the hard drive and hand loop-back mounted it to /media/kubuntu.

        I.e.:
        % sudo mkdir /media/kubuntu
        % sudo mount -o loop /path_to_kubuntu_20.04_iso_file /media/kubuntu
        % cd /etc/apt
        % sudo cp sources.list sources.list.backup
        % sudo vi sources.list --> deleted ALL deb http:// lines (there were 10) and added a line:
        deb file:///media/kubuntu focal mail multiverse restricted universe
        <saved the file>

        % sudo apt update

        Now... originally this did not work. So today in desperation, since this was a new build anyway, I tarballed what I had in /home/username to an external USB drive, then re-installed Kubuntu 20.04.

        Same behaviour -- could not install GCC. apt sh*t all over itself.

        Well... for some reason, I thought I had Kubuntu 20.04, and I saw that the latest version for download was Kubuntu 20.04.4. So I downloaded it, updated my Ventoy boot media USB stick, and burned it down / re-installed a second time. Further inspection, though... showed that the file I had previously used was 20.04.4 as well.

        BUT... this time it worked!?! Go figure. I went through the same process I described above, but after the "sudo apt update"... a "sudo apt install gcc" worked! I do not understand. But with gcc installed, I was able to 'sudo apt install build-essential'.

        I found a thread, I think it was on Ask Ubuntu, where someone documented the (appeared to be exact) same problem I was experiencing. That person stated they had downloaded the .deb files for the packages:
        • libdpkg-perl
        • dkms
        and manually installed via 'dpkg -i <path to .deb file>'

        I was going to put that other thread in here for documentation sake, but I have so many Firefox windows & tabs open, I cannot find it right now. If I do, I will try to update this thread.

        In summary, my problem was:
        • New Kubuntu install
        • no network because not physically near the router and Kubuntu 20.04.4 did not recognize / install a driver for a TP-Link AC1300 USB WiFi dongle
        • could not pull the drivers available on github and install because 'dkms' was broken / not installed, and also libdpkg-perl was borked as well
        • downloading .deb files on another system and transferring via USB to install was not working because I quickly descended into a dependency h*ll. Oh... I tried to follow that on the borked system by running 'sudo apt-cache policy' on various packages. gcc needed gcc-9 which needed gcc-9-dev (or something) etc etc etc. Then I got to one package that said it needed gcc-10-* Well... of course that wouldn't work because I didn't even have gcc-9. So I realized something was really screwed up. (Hence the burn-down and try again approach.
        Somehow...
        • downloading a fresh Kubuntu 20.04.4 image and doing YAI (yet another install) worked enough to enable 'sudo apt update / sudo apt install gcc' to work.
        • Then I could manually install 'dkms' and 'libdpkg-perl' from .deb files.
        So now I will try to install an AC1300 driver from github.

        One additional note. This system has an NVIDIA Quadro RTX 4000 graphics card. I prefer to use the NVIDIA proprietary drivers. After the first build, I recall wrestling with getting an NVIDIA driver installed. I surmise that somehow installing a proprietary NVIDIA driver may have somehow borked my APT install system / broken dependencies etc. I do not know how. I do not know why. I do not understand. I do know that after my last install... I did *nothing* with the NVIDIA card. So if someone finds this thread and they have a borked APT install and also have an NVIDIA graphics card... you may wish to delay screwing around with drivers for the NVIDIA card until *after* you have a working network interface. FWIW.

        Thanks to all who responded.

        Comment

        Working...
        X