No announcement yet.

Dolphin Find not working

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Dolphin Find not working

    I'm running an updated 18.04.
    In the last week, my Dolphin has been unable to search for keywords. Both from the Home folder and within individual folders, I've tried searching and it immediately returns 0 folder/0 files.
    The odd thing is that the ONLY search term that works is "jpg". If I give it the EXACT name of a jpg file, it finds it. But any part of the name or any search for another file instantly returns the 0 folder/0 files message.
    At this point, it is unusable. I tried Kfind, but it just gets busy forever and never seems to find anything.

    I'm afraid I can't be of much help to you, other than says Dolphin search is working correctly here. So it must be something unique to your install there.
    Have you tried reinstalling dolphin?
    Dave Kubuntu 20.04 Registered Linux User #462608

    Wireless Script:


      If there's an issue with config files in the user's home folder, re-installing may not help.

      Snowhog's suggestion to create a new user maybe worth looking at.
      Kubuntu 20.04


        After more than a week of not working properly, dozens of restarts, and reinstalling Dolphin, it suddenly started to work properly again. While I'm grateful, this bothers me.
        I'll mark this solved for now.


          Dolphin uses a KDE component called baloo for its searches.

          Baloo builds an index of file content, not just names, of any file it thinks it understands, reading all those files. This read gives performance problems for a lot of people, flattening their systems when they login. On some, it churns away seemingly not getting anywhere; that's my experience. So we disable baloo and do without find in dolphin. There's lots of other ways to search for files; spinning hard drives were relatively slow at bouncing around lots of directories (every directory another head access) so a lot of effort went into indexes and such. But, now with SSDs simple searching is usually fine.

          In your case, I suspect that baloo was having trouble, but now has successfully built its index.

          (I suspect that a lot of the people here in this forum have disabled baloo and so not quick to reply to your post. But maybe in the northern hemisphere they're on holiday.)

          Regards, John Little
          Last edited by jlittle; Aug 20, 2018, 04:48 PM. Reason: fix incorrect auto-correction
          Regards, John Little


            I leave it on, the search is fast and useful for me. I leave it enabled on my lowly Chromebook, too. For me, it does not hog resources or churn the drive, but it does take a while to index. I think it throttles back, or is supposed to, anyway. It seems to for me, especially on my PC with a spinning 1Tb drive plus an external USB 1Tb drive I have both added to be indexed. Neither are very full, maybe 20% full, but a large number of individual text documents.


              Originally posted by jlittle View Post
              Dolphin uses a KDE component called baloo for its searches.

              Baloo builds an index of file content, not just names, of any file it thinks it understands,
              Wasn't baloo supposed to index only filenames, not content, in a clean 18.04? Maybe the upgrade allowed OP's old baloo-related config files to remain active thereby by indexing content as well?

              For me, using baloo with content indexing is working fine but I made a lot of additional exclusions (which I think should have been there by default). Plus I have a somewhat simple home folder.
              Kubuntu 20.04


                I looked into this again. If I started baloo with balooctl start, /usr/bin/baloo_file crashed shortly after, then a few minutes later it runs and crashed again. I think my crash matched Bug #1766648, but I'm sure the crash is now different from the one I had some months ago. balooctl status shows Indexed 11584 / 11584 files, but find in dolphin did not find some files.

                After much poking around, google, launchpad searches, and the like, the blindingly obvious occurred to me, and I deleted baloo's index files:
                rm .local/share/baloo/*
                balooctl start
                and baloo is good for me now. Even with indexing file content the indexer takes only a few seconds; I have only about 2 GB and most of that is pictures and music.

                So, OP, if you've bothered to return to this thread, and read this post, and you have trouble with dolphin file search again, you might try "balooctl stop", edit ~/.config/baloofilerc to set "first run=true", then the commands above. Wait till "balooctl status" shows the indexer status is idle, and try dolphin file search again.

                Originally posted by chimak111 View Post
                Wasn't baloo supposed to index only filenames, not content, in a clean 18.04?
                Yes, eventually I have concluded this. There is a "only basic indexing" configuration item, which has to be set to false to index file content. Unchecking the box in system settings doesn't set this to true, it removes it; confusing IMO. Eventually I've decided that indexing file content isn't the problem for me now.
                Regards, John Little