Results 1 to 5 of 5

Thread: Audio not working with Kazam or Skype

  1. Back To Top    #1
    Kubuntu as a Second Language NoWorries's Avatar
    Join Date
    Jun 2007
    Location
    Adelaide, South Australia
    Posts
    1,409
    Threads
    160
    Local Date
    Jun 6th 2020
    Local Time
    07:41 PM

    Audio not working with Kazam or Skype

    I have been trying to record video and sound from an application on my desktop using Kazam. I use Pulseaudio to control the recording. Unfortunately, no output is detected by Pulseaudio > Recording. It just says that "No application is currently recording audio". Kazam records the video with no sound? I can hear sound through my speakers and I know that my microphone works as I tested both with Audacity.

    The approach that I took in the past with Kazam worked at the end of 2019 but the documentation that I took then no longer works now.

    I believe a related issue is that, while I seldom use Skype, I have now found that when I use the Skype Echo/Sound Test Service, I can hear the speaker but I get no response as the other end is not getting any audio from me.

    I get exactly the same behaviour on both the Kubuntu 20.04 and 20.10 systems.

    Does anyone have any idea on how to solve this problem?

  2. Back To Top    #2
    Kubuntu Padawan Don B. Cilly's Avatar
    Join Date
    Nov 2012
    Location
    Ibiza, Spain
    Posts
    1,150
    Threads
    57
    Local Date
    Jun 6th 2020
    Local Time
    12:11 PM
    Have you tried SimpleScreenRecorder?
    It works for me on any conceivable ;·) distro.

    And I must say... it's one of the best examples of well-written code I've seen in a while. Simple, fast, efficient. No frills, no nags, does the job.

  3. Back To Top    #3
    Kubuntu as a Second Language NoWorries's Avatar
    Join Date
    Jun 2007
    Location
    Adelaide, South Australia
    Posts
    1,409
    Threads
    160
    Local Date
    Jun 6th 2020
    Local Time
    07:41 PM
    I have tried and successfully used SimpleScreenRecorder. PulseAudio certainly recognizes it and I was able to set the audio recording so that it used "Built-in Audio Analogue Stereo". Thanks very much for letting me know about this recorder.

    PulseAudio used to work with Kazam which now seems totally blind to PulseAudio. I am not sure if the problem is with PulseAudio or Kazam, but something needs to be done to fix this and the problems with Skype audio as well.

  4. Back To Top    #4
    Esteemed Member kyonides's Avatar
    Join Date
    Jan 2009
    Posts
    683
    Threads
    108
    Local Date
    Jun 6th 2020
    Local Time
    04:11 AM
    I was never able to record audio using SSR. Perhaps it happened due to not connecting any microphone to the PC at that time!?
    Multibooting: Kubuntu Focal Fossa 20.04
    Before: Precise 12.04 Xenial 16.04 and Bionic 18.04
    Win 10 sadly
    Using Linux since June, 2008

  5. Back To Top    #5
    Kubuntu as a Second Language NoWorries's Avatar
    Join Date
    Jun 2007
    Location
    Adelaide, South Australia
    Posts
    1,409
    Threads
    160
    Local Date
    Jun 6th 2020
    Local Time
    07:41 PM
    Quote Originally Posted by kyonides View Post
    I was never able to record audio using SSR. Perhaps it happened due to not connecting any microphone to the PC at that time!?
    I use a HP Spectra x360 15-ch004ng with a built-in HD Webcam and internal microphone. These work perfectly with Zoom, SimpleScreenRecorder and the audio with Audacity. Skype and Kazam both fail on sound. PulseAudio does not see Kazam when recording and Skype Echo/Sound Test Service responds after no response to what I say with "Messaging unavailable".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •