Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Jack output not working on kubuntu 20.04

  1. Back To Top    #11
    Insert Pithy Nothingness here claydoh's Avatar
    Join Date
    Sep 2005
    Location
    Savannah GA
    Posts
    8,242
    Threads
    228
    Local Date
    Jun 4th 2020
    Local Time
    03:16 AM
    Homepage: Go to claydoh's homepage
    Quote Originally Posted by Don B. Cilly View Post
    sudo apt install gedit?

    Probably the how-to used gedit, which is far more commonly used than kwrite or kate

    Sent from my LM-V600 using Tapatalk

  2. Back To Top    #12
    Newbie
    Join Date
    May 2020
    Posts
    4
    Threads
    1
    Local Date
    Jun 4th 2020
    Local Time
    07:16 AM
    Quote Originally Posted by doomedlung View Post
    Unfortunately, none of the solutions worked described in the link here: https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/

    However, I think I found the cause of my issue with the audio jack not working,.. it seems every time I've plugged a pair of headphones into my laptop, the "Microphone" option under System Settings -> Audio Volume Settings -> Recording Devices, is selected and muted. Selecting the "Internal Microphone" and unmuting it brings back sound to the audio jack. I've been able to re-produce this every single time.

    For now I can live with this, but plugging in my headphones shouldn't de-select my "Internal Microphone" to a "Microphone" option, when my headphones don't have a mic attached.

    Anyways, I'll hopefully raise a bug with the Kubuntu team and maybe try to find a solution to prevent the switch of mics.

    I verified that this happens on my system as well, so i found a workaround that should do the work. Basically you need to disable the 'Microphone' port that it's enabled by default when you plug in headphones. To do this you can run the commands

    Code:
    cd /usr/share/pulseaudio/alsa-mixer/paths
    sudo mv  analog-input-headphone-mic.conf analog-input-headphone-mic.config.backup
    Then restart.

    This only changes the name of the file leaving the option for you to go back if the method doesn't work.

    You shoul'd verify fist that "analog-input-headphone-mic" is the port that's giving you problems, you can do that issuing the command:
    Code:
    pacmd list-sources

  3. Back To Top    #13
    Junior Member
    Join Date
    Jul 2017
    Location
    Zoolooland, RSA
    Posts
    10
    Threads
    2
    Local Date
    Jun 4th 2020
    Local Time
    09:16 AM
    I had this same issue on my Dell laptop
    I don't think that this has anything to do with the kernel because on Ubuntu (20.04) the headphones work as expected
    so this seems to be a Kubuntu problem
    so far... none of the "solutions" that I'd seen and tried have worked
    I use my headphone jack for my external speakers so I really need that stuff to work...
    my recourse was to go back to 19.10 (on Kubuntu with backports not latest Gnome) and wait to see how the next "Groovy Gorilla" performs...

  4. Back To Top    #14
    Junior Member
    Join Date
    Jan 2010
    Posts
    13
    Threads
    2
    Local Date
    Jun 4th 2020
    Local Time
    07:16 AM
    On my Dell laptop I changed the option "Microphone" to "Headset Microphone" in the Audio settings and all of a sudden my headset connector worked and played sound.
    Strange because my laptop doesn't have a microphone connector and I just plugged in a bunch of speakers.

  5. Back To Top    #15
    Kubuntu Padawan Don B. Cilly's Avatar
    Join Date
    Nov 2012
    Location
    Ibiza, Spain
    Posts
    1,149
    Threads
    57
    Local Date
    Jun 4th 2020
    Local Time
    09:16 AM
    Quote Originally Posted by Ignitem View Post
    Strange because my laptop doesn't have a microphone connector
    Oh, that must be your malware malfunctioning, then Click image for larger version. 

Name:	icon_smile_evil.gif 
Views:	12 
Size:	5.7 KB 
ID:	8878
    Just kidding, obviously. Most laptops have a built-in mic though.

    Still, it's interesting that it's so "easy" to use your speakers/headphones as microphones...

  6. Back To Top    #16
    Newbie
    Join Date
    May 2020
    Posts
    4
    Threads
    1
    Local Date
    Jun 4th 2020
    Local Time
    07:16 AM
    Quote Originally Posted by Ignitem View Post
    On my Dell laptop I changed the option "Microphone" to "Headset Microphone" in the Audio settings and all of a sudden my headset connector worked and played sound.
    Strange because my laptop doesn't have a microphone connector and I just plugged in a bunch of speakers.
    The solution I posted up here does exactly the same thing by removing the 'Microphone' option so you don't need to switch out of it every time you connect the headphones ;) .

    Most of recent laptops just have a single jack port for both in and out by the way .

  7. Back To Top    #17
    Junior Member
    Join Date
    May 2020
    Posts
    13
    Threads
    1
    Local Date
    Jun 4th 2020
    Local Time
    08:16 AM
    Quote Originally Posted by Somix View Post
    I verified that this happens on my system as well, so i found a workaround that should do the work. Basically you need to disable the 'Microphone' port that it's enabled by default when you plug in headphones. To do this you can run the commands

    Code:
    cd /usr/share/pulseaudio/alsa-mixer/paths
    sudo mv  analog-input-headphone-mic.conf analog-input-headphone-mic.config.backup
    Then restart.

    This only changes the name of the file leaving the option for you to go back if the method doesn't work.

    You shoul'd verify fist that "analog-input-headphone-mic" is the port that's giving you problems, you can do that issuing the command:
    Code:
    pacmd list-sources
    Perfect! Works like a charm! Nice find, I just have to remember to remove it when I upgrade or use an actual mic lol

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •