Results 1 to 6 of 6

Thread: PC goes to sleep overnight, even with all power mangement that i know of off

  1. Back To Top    #1
    Newbie
    Join Date
    Mar 2020
    Posts
    2
    Threads
    1
    Local Date
    Jun 6th 2020
    Local Time
    04:59 PM

    PC goes to sleep overnight, even with all power mangement that i know of off

    Operating System: Kubuntu 19.10
    KDE Plasma Version: 5.16.5
    KDE Frameworks Version: 5.62.0
    Qt Version: 5.12.4
    Kernel Version: 5.3.0-42-generic
    OS Type: 64-bit
    Processors: 4 × AMD Ryzen 3 2200G with Radeon Vega Graphics
    Memory: 14.6 GiB of RAM
    (GRUB) 2.04-1ubuntu12.2
    Harddrives
    4 - 500gb Seagate
    2 - 4tb WD
    Kubuntu install on 250gb partition, no other OS installed
    week old install, only programs added Plex, Chrome, Disks

    ================================================== ====================
    Power Management
    Revision Plasma 5.7 (2016-08-26)

    Energy Settings
    checked - Screen Energy Saving = Switch off after 10 mins
    unchecked - Suspend Session
    Activity Settings
    checked - Define a special behavior - never shut down the computer or let it go to sleep

    with those setting
    monitor will turn off
    Through out the day, up to 4 hours between uses, will be ok
    overnight PC will be suspended in the morning (6-8 hours), takes 3+ mins to wake up and be able to use programs.

    programs running Chrome, single tab with Plex server.

    ===
    with above settings and

    Battery and Brightness (on Task Manager)
    Unchecked - Enable Power Management
    Monitor no longer turns off
    still goes to sleep overnight, but takes about 2 mins to start back up

    i am not sure if plex is available in this sleep state or not. have not tried any terminal commands, as everything i have found so far were years old.
    thanks

  2. Back To Top    #2
    Ascendant oshunluvr's Avatar
    Join Date
    Feb 2010
    Location
    New Bern, NC USA
    Posts
    10,660
    Threads
    435
    Local Date
    Jun 6th 2020
    Local Time
    12:59 PM
    Any chance there's a BIOS setting causing this? My desktop settings are almost identical to yours (Activity settings are set at "Do not use...").

    I honestly don't know what you mean by "Task Manager". I wasn't aware we had one, so I can't comment on the Battery and Brightness settings.
    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

  3. Back To Top    #3
    Ascendant oshunluvr's Avatar
    Join Date
    Feb 2010
    Location
    New Bern, NC USA
    Posts
    10,660
    Threads
    435
    Local Date
    Jun 6th 2020
    Local Time
    12:59 PM
    It's possible ACPI (your system hardware) is doing this. You might trying editing /etc/default/acpi-support and changing

    SUSPEND_METHODS="dbus-pm dbus-hal pm-utils"

    to

    SUSPEND_METHODS="none"


    and restarting acpi with;

    sudo /etc/init.d/acpid restart
    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

  4. Back To Top    #4
    Newbie
    Join Date
    Mar 2020
    Posts
    2
    Threads
    1
    Local Date
    Jun 6th 2020
    Local Time
    04:59 PM
    Quote Originally Posted by oshunluvr View Post
    Any chance there's a BIOS setting causing this? My desktop settings are almost identical to yours (Activity settings are set at "Do not use...").

    I honestly don't know what you mean by "Task Manager". I wasn't aware we had one, so I can't comment on the Battery and Brightness settings.
    sorry, guess the proper name would be system tray



    without any hardware changes other than harddrives, this pc ran Mint Cinn 19 for almost a year and Ubuntu 19 for a month without having this issue.
    will try fiddle with the acpi in a few,
    thanks

  5. Back To Top    #5
    Ascendant oshunluvr's Avatar
    Join Date
    Feb 2010
    Location
    New Bern, NC USA
    Posts
    10,660
    Threads
    435
    Local Date
    Jun 6th 2020
    Local Time
    12:59 PM
    That makes sense. I have Battery and Brightness disabled so that explains why it didn't occur to me immediately what you meant.

    If the same Ubuntu version didn't have the issue, it must be somewhere in KDE Plasma. I can't think of where else to look at the moment. We're only a few weeks from 20.04 release so maybe that will fix it...
    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

  6. Back To Top    #6
    Kubuntu as a Second Language
    Join Date
    Apr 2008
    Location
    Auckland, New Zealand
    Posts
    1,891
    Threads
    68
    Local Date
    Jun 7th 2020
    Local Time
    04:59 AM
    Quote Originally Posted by goatface View Post
    ... takes 3+ mins to wake up ...
    That sounds like restarting from power-off and reloading a session. Return from sleep should be a very few seconds, with no firmware screen or POST, and from hibernation a few seconds from the linux start-up.
    Quote Originally Posted by goatface View Post
    ... i am not sure if plex is available in this sleep state ...
    Some hardware can do wake-on-LAN, but I've no experience with that.
    Regards, John Little

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •