Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Odd hangs with Synergy

  1. Back To Top    #11
    Senior Member megosdog's Avatar
    Join Date
    Apr 2010
    Location
    Lansing, MI
    Posts
    135
    Threads
    37
    Local Date
    Jun 2nd 2020
    Local Time
    11:16 PM
    BTW, I think I might've figured out what could be causing this. My laptop has that horrible RealTek chipset. I remember when I first setup the laptop all the pain and suffering I had just getting that working right. So I'm betting that's 90% of my issue. But, I'll take your PPA and see if I can get Barrier installed and working and see if that fixes the issue.

  2. Back To Top    #12
    Senior Member megosdog's Avatar
    Join Date
    Apr 2010
    Location
    Lansing, MI
    Posts
    135
    Threads
    37
    Local Date
    Jun 2nd 2020
    Local Time
    11:16 PM
    I finally got a chance to install Barrier. OMG what a difference! The lag I was seeing in my PC is gone, there's literally no hangup between the two machines, no slowdown, no hangs, none of that. It's just pure Pc to laptop mouse/keyboard bliss. Makes me wish I'd have made this change sooner.

  3. Back To Top    #13
    Senior Member megosdog's Avatar
    Join Date
    Apr 2010
    Location
    Lansing, MI
    Posts
    135
    Threads
    37
    Local Date
    Jun 2nd 2020
    Local Time
    11:16 PM
    Okay, interesting observations, and I think this part isn't either network, nor Barrier, but rather the laptop. With Synergy, when one would die, both would. With Barrier it's one or the other, but rarely both, and it's more like a stutter pause than a 15 second lockup, and it seems to happen in high load situations. So I think I've somewhat narrowed down more of the reasons the weird hangups were happening. But either way, Barrier is really helping a lot. Anyhow, I'm gonna mark this solved as I don't think it's the KVM software anymore with me moving to Barrier. I think the rest is just performance issues, and the infamous AMD stutter, I need to sort out.

  4. Back To Top    #14
    Cyborg sithlord48's Avatar
    Join Date
    Apr 2007
    Location
    127.0.0.1
    Posts
    2,945
    Threads
    42
    Local Date
    Jun 2nd 2020
    Local Time
    11:16 PM
    Great to hear Barrier is working well for you.
    Mark Your Solved Issues [SOLVED]
    (top of thread: thread tools)

  5. Back To Top    #15
    Senior Member megosdog's Avatar
    Join Date
    Apr 2010
    Location
    Lansing, MI
    Posts
    135
    Threads
    37
    Local Date
    Jun 2nd 2020
    Local Time
    11:16 PM
    Okay, after 6 weeks of getting my butt handed to me with work I finally got back to this. Via a tip from a fellow coworker, I fired up tcpdump. It showed me that there is a gobton of inbound and outbound traffic when the mouse is running. There's even a ton when the slave system (my laptop) hangs and the mouse/keyboard stop working for a time. So, what that tells me is there's LOTS of network activity that the kernel is seeing, meaning there's no network issue that I can find as what's happening on the host is also happening on the guest in lock step synchronicity. So, I decided to dig into the logs in barrier and I noticed that there were a number of "disconnected from server" notices. And, mind you, this is with Barrier, not Synergy. With Synergy it was WAY worse. So my thoughts are that there's something else at play here. And I know it's not the network as tcpdump on both machines showed that that was working without issue and with great speed.

    The only commonality to all situations is the laptop, which is presently the slave system. So I'm wondering if you guys have any ideas on how I can further troubleshoot this. I'm really scratching my head here.

    As a note of observation, load on the laptop, while the hangs happen, is super low, so it's not a load issue. It runs a 4 core AMD A4 with 8gb of memory, so plenty of resources. Plus the HDD is an SSD, so speed there is no issue. Again, whenever the laptop is operating on its own keyboard and mouse there's no performance issues. Only when I go and try to control it with barrier. And there's no real pattern to when the hangs happen, although I have seen them to be most common with times when I'm doing drag and drop, be it a file, a browser tab, text, etc. Now, that's not EVERY hang, but that seems to be the best way to trigger the hangs if I'm testing. Anyhow, ideas welcome. And, if you don't have any, do you know someone or some group who might be better to talk to?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •