Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Mouse VS Touchpad change - not good

  1. Back To Top    #1
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,483
    Threads
    1169
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM

    Thumbs down Mouse VS Touchpad change - not good

    In previous versions of Plasma one could make the setting that if the USB mouse was plugged in the touchpad would be automatically disabled. If the USB mouse was unplugged the touch pad became automatically enabled. For several versions of Plasma, since 14.04 (or earlier, but I'm not sure) that method has worked perfectly (at least for me).

    Now, there is a touch pad toggle radio button to enable or disable the touch pad. IF the mouse becomes disabled or unplugged then the user is faced with using hot keys to navigate to Settings-->Input-->Touch Pad and then tab to the radio button to enable the touch pad. Personally, I don't use many hot keys, mainly because I can't remember which keys do what. I am a point & click person. When I forget how to use the mouse I will also probably not remember how to turn on the computer, and by then I won't care. Until then, it would be nice if the Plasma dev crew reverted the mouse -- touch pad key to it former relationship.

  2. Back To Top    #2
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,596
    Threads
    1012
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Is this a recent, i.e. 'today', issue? I don't have this issue (that I'm aware of) on my laptop running 20.04. I'll check later today to verify.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  3. Back To Top    #3
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,483
    Threads
    1169
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Quote Originally Posted by Snowhog View Post
    Is this a recent, i.e. 'today', issue? I don't have this issue (that I'm aware of) on my laptop running 20.04. I'll check later today to verify.
    While I did have about a 250 +- a few packaged updated yesterday, and 80 or so the day before (I don't remember exactly how many but it was a lot), I don't regularly check my touch pad. I noticed it this morning when I began typing and saw my mouse pointer move when my thumb joint touched the pad. There is a feature that is supposed to turn off the touch pad when one is typing, but obviously it doesn't work well.

  4. Back To Top    #4
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,596
    Threads
    1012
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Verify that you have package xserver-xorg-input-synaptics installed.
    Description-en: Synaptics TouchPad driver for X.Org server
    This package provides an input driver for the X.Org X server to enable
    advanced features of the Synaptics Touchpad including:
    .
    * Movement with adjustable, non-linear acceleration and speed
    * Button events through short touching of the touchpad
    * Double-Button events through double short touching of the touchpad
    * Dragging through short touching and holding down the finger on the touchpad
    * Middle and right button events on the upper and lower corner of the touchpad
    * Vertical scrolling (button four and five events) through moving the finger
    on the right side of the touchpad
    * The up/down button sends button four/five events
    * Horizontal scrolling (button six and seven events) through moving the finger
    on the lower side of the touchpad
    * The multi-buttons send button four/five events, and six/seven events for
    horizontal scrolling
    * Adjustable finger detection
    * Multifinger taps: two finger for middle button and three finger for right
    button events. (Needs hardware support. Not all models implement this
    feature.)
    * Run-time configuration using shared memory. This means you can change
    parameter settings without restarting the X server (see synclient(1)).
    * It also provides a daemon to disable touchpad while typing at the keyboard
    and thus avoid unwanted mouse movements
    (see syndaemon(1)).
    Description-md5: 6f7a84d9a52f4dc44fd0ad7cc265853b
    Task: xubuntu-core, xubuntu-desktop
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  5. Back To Top    #5
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,483
    Threads
    1169
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Yes, it is installed. The option you highlighted in black is the option that failed. My settings currently are "enable touch pad" & "disable while typing". I can easily move the cursor using the touch pad while I am typing by merely sliding my thump over the touch pad while typing. Ergo, to prevent unwanted motions of the cursor while typing I disable the touch pad. Now, if my mouse fails, I have to hot key to the Touch Pad settings and enable the touch pad. I have finger and hand tremors which I can effectively control using a mouse because most of the movement is in the wrists. On a touch pad the fingers do the walking and my fingers shake involuntarily while attempting to move the cursor to a specific spot. Also, hitting the left and right touch bars at the bottom of the touch pad often result in a miss -- striking the edge of the touch pad and moving the cursor, or hitting the wrong bar. The previous touch pad setup, which worked on sensing the mouse being plugged in, worked beautifully.

  6. Back To Top    #6
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,596
    Threads
    1012
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    System Settings > Hardware > Touchpad > Enable/Disable Touchpad and ensure that Disable touchpad when mouse is plugged in is checked.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  7. Back To Top    #7
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,483
    Threads
    1169
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Quote Originally Posted by Snowhog View Post
    System Settings > Hardware > Touchpad > Enable/Disable Touchpad and ensure that Disable touchpad when mouse is plugged in is checked.
    I am running Plasma 5.18.3 fully updated and "Disable touchpad when mouse is plugged in" is NOT an option on my Touchpad setting panel.

  8. Back To Top    #8
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,596
    Threads
    1012
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    I'm running Plasma 5.18.3 on my 20.04, and that option is there.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  9. Back To Top    #9
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,483
    Threads
    1169
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    Quote Originally Posted by Snowhog View Post
    I'm running Plasma 5.18.3 on my 20.04, and that option is there.
    Here is a screen capture of my Touchpad panel

    Click image for larger version. 

Name:	touchpade.jpg 
Views:	23 
Size:	53.3 KB 
ID:	8711

  10. Back To Top    #10
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,596
    Threads
    1012
    Local Date
    Jun 5th 2020
    Local Time
    11:37 AM
    From your image, it appears that the vertical scroll bar indicates that there is 'more' below the last entry shown?
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •