Results 1 to 3 of 3

Thread: Pulseaudio error with default audio problems

  1. Back To Top    #1
    Newbie
    Join Date
    Mar 2020
    Posts
    2
    Threads
    1
    Local Date
    May 26th 2020
    Local Time
    08:39 PM

    Pulseaudio error with default audio problems

    Hello guys~

    I've just installed Kubuntu over Ubuntu and really liking the themes and all, but there's a problem I'm having with both distributions.
    I have two main audio devices on my setup, one is an usb-audio device, and the other is an line out stereo device.

    The problem happens when I try to set the line-out as my default device on the audio settings page, when doing that "~/.config/pulse/66362a324a5843d1abdd80c1779a087c-default-sink" files content changes to
    "alsa_output.pci-0000_07_00.6.analog-stereo"

    But when I reboot my pc, "66362a324a5843d1abdd80c1779a087c-default-sink"s content automatically changes to
    "alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.analog-stereo
    " which is my usb-audio device. (and the default audio device changes on the settings page too)

    So I typed pulseaudio in the terminal just to check and this error showed up


    E: [pulseaudio] pid.c: Daemon already running.
    E: [pulseaudio] main.c: pa_pid_file_create() failed.

    is this the reason the default device keeps resetting on reboot? and if it is, is there a way I can fix it?

    on Ubuntu I just used a start-up command to switch default-sink to "
    alsa_output.pci-0000_07_00.6.analog-stereo"
    but seeing the default audio option in Kubuntu really makes me want to use that feature :p




  2. Back To Top    #2
    Kubuntu as a Second Language
    Join Date
    Apr 2008
    Location
    Auckland, New Zealand
    Posts
    1,881
    Threads
    68
    Local Date
    May 26th 2020
    Local Time
    11:39 PM
    pactl is the command I think you're looking for. (It's in the package pulseaudio-utils, which IIUC you should already have.) Maybe
    Code:
    $ pactl set-default-sink alsa_output.pci-0000_07_00.6.analog-stereo
    Another user on KFN (not a new guy, he's one of the admins) reported a similar problem recently; the volume reset to zero on start up.
    Regards, John Little

  3. Back To Top    #3
    Newbie
    Join Date
    Mar 2020
    Posts
    2
    Threads
    1
    Local Date
    May 26th 2020
    Local Time
    08:39 PM
    Ok, so setting the default sink was not the problem, I had to comment out the "load-module module-switch-on-connect" line in the pulseaudio config file, I guess every time on start-up it recognizes the usb-audio device as a new connection?
    I'm not sure if this can be triggered in the settings, but if it isn't would pretty fun to learn how to create my own setting in a settings page



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •