Results 1 to 4 of 4

Thread: KDE application platform

  1. Back To Top    #1
    Senior Member mbohets's Avatar
    Join Date
    Jul 2014
    Location
    Belgium
    Posts
    155
    Threads
    36
    Local Date
    Jun 5th 2020
    Local Time
    05:12 PM

    KDE application platform

    Discover constanly flags KDE application platform as to be updated, but it always aborts the update because of error.

    It says update to version 5.14
    When I google this, I see KDE plasma and KDE framework, but nearly nothing about KDE application platforms.
    So what is this, is it another name for plasma or KDE framework ?

    And secondly how can I overcome this error.
    When I use apt or synaptic, I don't see any error, and when I look a bit more in detail in discover, I see that it is a flatpack.
    Je suis Charlie, how many more people have to die for religions
    linux user #447706 on https://linuxcounter.net
    A good place to start:
    Topic: Top 20 Kubuntu FAQs & Answers


  2. Back To Top    #2
    Insert Pithy Nothingness here claydoh's Avatar
    Join Date
    Sep 2005
    Location
    Savannah GA
    Posts
    8,242
    Threads
    228
    Local Date
    Jun 5th 2020
    Local Time
    11:12 AM
    Homepage: Go to claydoh's homepage
    This KDE platform is a flatpak, not something handles by apt at all. It contains an implementation of plasma libraries that are used as a base for KDE/plasma related flatpaks.

    I have noticed similar bugs often in flatpak packages recently, usually the Gnome platform for me. It seems like a bug on the flatpak dependencies but don't see any fixes other than uninstalling the offending package, which will also remove whatever KDE program you installed via flatpak.

    Reinstalling it may pull in a fixed package, if available.

    I stopped using flatpak for the moment as this annoyed me. I had only one thing but I can't remember what it was



    Sent from my LG-H931 using Tapatalk

  3. Back To Top    #3
    Senior Member mbohets's Avatar
    Join Date
    Jul 2014
    Location
    Belgium
    Posts
    155
    Threads
    36
    Local Date
    Jun 5th 2020
    Local Time
    05:12 PM
    Thx, I removed it, but I have no idea what impact it can have on my system, discover does not give much information about dependencies.
    I normally use synaptic or apt, but for some music notation software I needed the latest version, because the version in the normal repositories is really ancient.
    Je suis Charlie, how many more people have to die for religions
    linux user #447706 on https://linuxcounter.net
    A good place to start:
    Topic: Top 20 Kubuntu FAQs & Answers


  4. Back To Top    #4
    Insert Pithy Nothingness here claydoh's Avatar
    Join Date
    Sep 2005
    Location
    Savannah GA
    Posts
    8,242
    Threads
    228
    Local Date
    Jun 5th 2020
    Local Time
    11:12 AM
    Homepage: Go to claydoh's homepage
    It is not Discover's job to be more than an 'app store'/updater, unfortunately.
    The flatpak command will give more info, as well as update, install, remove flatpaks, though not necessarily showing anything as useful as apt does for deb packages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •