Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to use Network options in Dolphin

  1. Back To Top    #1
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    How to use Network options in Dolphin

    I just installed v10.04_x86_64 using a brand new clean HDD (kubuntu only) and I can't connect to any computer on my home network.

    1. I'm trying to use Dolphin's network features and can't use it. Please help.

    2. I also tried to make a shared folder using my documents folder and I can't do this either. Please help.
    a. I right clicked "documents folder"
    b. selected "Share Tab"
    c. It states the following "you need to be authorized to share folders" with a "Configure File Sharing" button below it.
    d. all attempts to use the "Configure File Sharing" options fail.


    I can add the following...

    1. I have the following machines on the home network
    a. kubuntu 9.04 - wired
    b. kbuntu 10.04 - wired
    c. winxp home ed - wireless

    2. I can ping all PCs from any PC. Pinging is successful from any station to any other station.

    3. Using kubuntu 9.04, I can see and transfer files to and from winxp using the command line only. Graphical access using dolphin fails.
    Ex: kub> smbclient //mywinxp_computername/my_shared_foldername <enter>
    smb:> dir <enter> (displays winxp files.)

    4. I have the following file contents on both of the PCs 9.04 and 10.04 ...
    HOSTS.ALLOW -> (modified)
    ALL: 127.0.0.1 :allow
    ALL: 192.168.0. :allow
    SSHD: 192.168.0. :allow

    HOSTS.DENY -> (modified)
    ALL: ALL EXCEPT localhostENY

    HOSTS -> (default install)


    5. I don't have any firewalls active that I know of.
    winxp -> firewall off
    wireless router firewall off
    Does 10.04 and 9.04 use firewalls by default?


    6. Using kubuntu 9.04, when I right click on a folder; select "Properties" and select "Share Tab"
    An option appears - "Share this folder in the local network", which does not appear on my 10.04 PC.
    And if I select this option, then other options become active; such as ...
    "Share with NFS" | NFS Options | Share with Samba | Samba Options

    Again, these do not appear in v10.04 - why?

    7. using the same commands on 10.04 ( smbclient //winxp_computername/my_shared_foldername -> fails. It just hangs. No error messages are displayed.


  2. Back To Top    #2
    Ascendant oshunluvr's Avatar
    Join Date
    Feb 2010
    Location
    New Bern, NC USA
    Posts
    10,660
    Threads
    435
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    You have a couple issues here but start with making sure you have nfs-common, portmap, samba-common, winbind, and smbclient and all dependancies installed to both linux machines.

    my files look like:
    /etc/host.deny
    Code:
    http-rman : ALL EXCEPT LOCAL
    
    portmap:ALL
    lockd:ALL
    mountd:ALL
    rquotad:ALL
    statd:ALL
    and hosts.allow
    Code:
    portmap: 192.168.0.
    lockd: 192.168.0.
    rquotad: 192.168.0.
    mountd: 192.168.0.
    statd: 192.168.0.
    to share directories via nfs edit /etc/exports and include the directories you want to share. Mine looks like
    Code:
    /home 192.168.1.0/255.255.255.0(async,secure,no_subtree_check,rw,anonuid=65534,anongid=560,nohide) 
    /shared 192.168.1.0/255.255.255.0(async,secure,no_subtree_check,rw,anonuid=65534,anongid=560,nohide)
    Then restart nfs and portmap with
    sudo /etc/init.d/portmap restart
    sudo /etc/init.d/nfs-common restart
    You should then be able to mount your nfs shares
    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

  3. Back To Top    #3
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    I think I'm making progress.

    I did what you suggested and checked/verified installation of packages...

    Using kpackagekit I selected "admin tools" and selected these programs...
    1. Commandline and GUI ACL utilities for the NFSv4 client
    2. NFS support files common to client and server
    3. An nfs idmapping library
    4. A Samba (SMB) share advanced browser for KDE
    (smb4k)
    5. support for NFS kernel server
    (nfs-kernel-server)

    Then I went into terminal mode...

    sudo apt-get install windbind -> this was not previously installed
    sudo apt-get install smbclient ->
    smbclient is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    sudo apt-get install samba-common ->
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    sudo apt-get install nfs-common ->
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    sudo apt-get install portmap ->
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    I also installed:
    sudo apt-get install kdenetwork-sharing -> this was not previously installed

    Now Dolphin's properties "Share Tab" exhibits different behaviors.
    Still says "You need to be authorized to share folders" | "Configure File Sharing" Button
    But now when clicked, kcmshell4 fileshare needs admin previliges. Please enter your password appears.
    I enter password.
    Then "Enable or disable file sharing" window appears with options...
    Simple sharing -> selected
    Clicked Add Button
    Added Documents folder -> now this appears in table with Samba and NFS checked.

    However, kubuntu 9.04 can't access //10.04/documents_shared_folder

    But both 10.04 and 9.04 see both PCs b/c when I select Dolphin's Places|Network (left)
    then Network (right); both PCs are listed.

    But no sharable folders appear under either PC. Even if I click 10.04 the PC I'm using which should have one sharable folder (document),
    this appears 10.04 [6c:f0:41:42:75:74:f1]

    As for access to winxp, I tried the command line and this still hangs.


    Now ready to try part 2 - modifying file /etc/exports and working with portmap

  4. Back To Top    #4
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    Part 2 - NFS success: I can view contents of PC-10.04/folder on PC-9.04

    Here's what I did.

    1. I entered terminal mode using sudo su

    then I changed the file contents using nano /etc/hosts.allow ...

    hosts.allow
    ==========
    ALL: 127.0.0.1 :allow
    ALL: 192.168.0. :allow
    SSHD: 192.168.0. :allow

    portmap: 192.168.0.
    lockd: 192.168.0.
    rquotad: 192.168.0.
    mountd: 192.168.0.
    statd: 192.168.0.

    hosts.deny
    =======
    http-rman : ALL EXCEPT LOCAL

    portmap:ALL
    lockd:ALL
    mountd:ALL
    rquotad:ALL
    statd:ALL

    exports
    ======
    /home/user/Documents 192.168.0.0/24(async,secure,no_subtree_check,rw,anonuid=65534, anongid=560,nohide)

    /etc/init.d/portmap restart <enter> (success)
    /etc/init.d/nfs-common restart <enter> (Failed)

    I had to use the following command...
    /etc/init.d/nfs-kernel-server restart <enter> (success)

    Now I switched from PC-10.04 to PC-9.04 and entered terminal mode
    1. sudo su <enter> (enter password)
    2. mkdir /mnt/PC-9.04-docs <enter>
    3. mount -t nfs PC-9.04-docs.local:/home/user/Documents /mnt/PC-9.04-docs <enter>

    Now switch to GUI-kde.
    select Dolphin
    select /mnt/PC-9.04-docs
    success - files from PC-10.04 appear!

    Comments:
    1.Although I edited PC-10.04:/etc/exports an entry had already existed for /home/user/Documents which was generated by Dolphin. This is the entry that was automatically generated by kubuntu:
    /home/user/Documents/ *(async,all_squash)
    But I commented this out by inserting a pound sign (#) as the first character so that this line would be ignored. This allowed me to manually enter the line stated above.

    2. I had to learn how to successfully ping using a computername rather than using an IP address. This was necessary b/c the correct computername was needed to successfully mount the shared folder.
    ping PC-10.04 (failed)
    ping PC-10.04.local (success)

    3. I had to learn how to mount a shared folder...
    mount -t ext4 .... ..... (failed) Even though the original filesystem format uses ext4, I needed to use filesystem nfs.
    Then I had to learn the correct syntax to form a remote mounting path which is different from samba's pathnaming scheme and from linux's normal pathnaming scheme. Note the ful-colon after the computername ( which is followed be a forward-slash (/)
    mount -t nfs remote_computername:/fullpath/to/your/remote_folder /mnt/folder (this is the local machine's placeholder for the remote folder's contents, which must exist before you attempt to mount)

    4. Lastly, I wonder why networking got much more difficult in 10.04. In 9.04, I remember installing and connecting to other linux boxes without ...
    1. installing 5+ packages ( I understand that installing an NFS server is a security risk and that the powers that be have elected to not install this functionality since most users only need to connect to their windows machines. But what happens to those of us, who wish to slowly convert our windows network to kubuntu?)
    2. editing 3 system files
    3. and finally manually mounting shared folders.

    This is why newbie's give up. This wasn't a "user friendly" experience and it required a lot of time today to figure this out. On the bright side, I learned something!

    Thanks to user "oshunluvr" for your advice. I didn't expect that I would have to perform this many steps.


    Now on to part 3 - connecting to winxp from 10.04

  5. Back To Top    #5
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    Part 3 - I figured out how to access winxp from 10.04 in terminal mode

    Note: don't forget that step one is to make at least one sharable folder on your windows PC. My winxp PC has sharable folders available for viewing. Second, you need to know a few details about your windows PC. You need the IP address and the workgroup_name of your windows PC. So you need to know the follwoing:
    IP address (enter command mode. use command ipconfig)
    workgroupname (get into device manager and select tab "computer name" look for workgroup name)
    computername (get into device manager and select tab "computer name" look for Full Computer name)
    the sharable foldername (right click folder, select properties, select tab "Sharing", look for Share Name)


    Earlier today I installed samba packages but was unable to access winxp

    here's what I installed in terminal mode:
    sudo apt-get install windbind
    sudo apt-get install smbclient
    sudo apt-get install samba-common

    After package installations I edited a system file /etc/samba/smb.conf
    sudo nano /etc/samba/smb.conf <enter>
    under the [global] heading I changed only one parameter...
    workgroup = to_my_workgroup_name ( in capital letters)
    then saved changes


    then staying in terminal mode I entered the following command however, the following command would hang...
    smbclient //winxp_computername/path_to_shared_winxp_folder -N (this command bypasses password prompt)

    then I added another command to make samba output more verbose...
    smbclient -d5 .......
    this showed the following errors...
    tdb(unnamed): tdb_open_ex: could not open file /var/run/samba/gencache.tdb: Permission denied
    gencache_init: Opening cache file /var/run/samba/gencache.tdb read-only.

    no entry for winxp_computername#20 found.
    resolve_lmhosts: Attempting lmhosts lookup for name winxp_computername<0x20>
    startlmhosts: Can't open lmhosts file /etc/samba/lmhosts. Error was No such file or directory
    resolve_wins: Attempting wins lookup for name winxp_computername<0x20>
    resolve_wins: WINS server resolution selected and no WINS servers listed.
    resolve_hosts: Attempting host lookup for name winxp_computername<0x20>

    so I tried using the ip address...
    smbclient -d5 //192.168.0.100/shared_winxp_folder -N <enter> (success)
    smb> dir <enter> -> file directory now visible
    smb> exit <enter>

    Now, I edited another system file /etc/hosts (note this is not lmhosts)
    sudo nano /etc/hosts

    added the following entry
    192.168.0.100 winxp_computername

    then I tried using the computername

    smbclient //winxp_computername/path_to_shared_winxp_folder -N <enter> (success)


    Now on to part 4 - accessing winxp using dolphin/GUI

  6. Back To Top    #6
    Ascendant Snowhog's Avatar
    Join Date
    Mar 2007
    Location
    Columbia Heights, MN
    Posts
    20,594
    Threads
    1012
    Local Date
    May 26th 2020
    Local Time
    08:20 AM

    Re: How to use Network options in Dolphin?

    Your thoroughness in documenting your adventure speaks highly of your attention to detail, and will be of great benefit to others. I see a future HOWTO member here.
    "It is a capital mistake to theorize before one has data." - Sherlock Holmes
    Using Kubuntu Linux since March 23, 2007
    Twin Cities Bicycling Club - "And miles to go before I sleep."

  7. Back To Top    #7
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    Part 4 - I figured out how to access winxp from PC-10.04

    Apparently after I modified the workgroup name in /etc/samba/smb.conf Dolphin responded.
    Again, several samba related packages were manually installed. see above for details.


    Open Dolphin (make sure Places is viewable on left side of window: Main Menu:View|Panels|Places)
    select Network
    select samba shares -> workgroup should appear
    select workgroupname
    select computername of choice
    select sharable folder of choice


    Part 5 - accessing PC-10.04 from winxp


  8. Back To Top    #8
    Ascendant oshunluvr's Avatar
    Join Date
    Feb 2010
    Location
    New Bern, NC USA
    Posts
    10,660
    Threads
    435
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    Wow, fantastic job and detailed post! Kudos on both.

    The one issue you'll likely find persistently bugging you is permissions and ownership of files. There's dozens of ways to handle this and it mostly depends on whether or not you're the only user of your system.

    Please Read Me
    Be not the first by whom the new are tried, Nor yet the last to lay the old aside. - Alexander Pope, An Essay on Criticism, 1711

  9. Back To Top    #9
    Contributing Member
    Join Date
    Apr 2008
    Posts
    62
    Threads
    17
    Local Date
    May 26th 2020
    Local Time
    09:20 AM

    Re: How to use Network options in Dolphin?

    Part 5 - I got winxp to access samba shares on 10.04


    This was difficult only because I assumed that samba was installed by default. I made this mistaken assumption only b/c samba appears in several locations by default. When you select "network" in Dolphin's "Places", it shows you "Samba Shares". So I assumed Samba was installed. Secondly, when you select a folder's properties and select the "share" tab, you have the ability to create a samba share. Again, I assumed that meant samba was installed by default.
    But to my consternation, IT IS NOT.


    As was mentioned earlier, I also installed several samba packages ...
    using kpackagekit, I installed...
    A Samba (SMB) share advanced browser for KDE (smb4k)

    from terminal mode I installed...
    sudo apt-get install windbind
    sudo apt-get install smbclient
    sudo apt-get install samba-common

    Here again, after installing several packages, I once again assumed that I had installed samba. I did not.



    And so here's how I managed to get winxp to access samba shares on 10.04...

    First, I still needed to install yet another package...

    sudo apt-get install samba (this is the package that creates the two necessary daemons: smbd and nmbd)


    next I edited the system file /etc/samba/smb.conf for the second time (first time I changed the workgroup)
    this time I inserted a line under the workgroup entry:
    netbios name = PC-1004 (replace with your computername here)
    next I changed two entries;
    server string = SambaServerPC1004 (replace with your description here)
    name resolve order = hosts lmhosts wins bcast (Note: 1. I shuffled the order 2. I changed host to hosts b/c there is no "host" system file. This is a BUG that I squashed.)
    and saved the changes

    Next I edited yet another system file /etc/hosts ...
    in terminal mode ....

    sudo nano /etc/hosts

    I added two lines ...
    192.168.0.100 PC-1004 (replace with your computername)
    192.168.0.200 PC-904 (replace with your computername)

    Note: this file should contain 127.0.1.1 PC-1004 by default, but I needed another entry to specify the IP address of the current PC. This way windows when it accesses samba, it can now resolve the kubuntu computernames.

    save and exit



    At this point, I switched to my winxp PC and selected Start | "My Network Places"
    then I selected "View Workgroup Computers" (left side)
    and viola... PC1004 was displayed
    then I selected PC1004 and a password prompt appeared
    so I entered my PC-10.04 username and password. This FAILED!

    So my kubuntu 10.04 username and password didn't work. I didn't know why, so I googled this.
    This meant that I needed a samba password. You keep the same username, but you need to create a samba password. BTW, it can be the same as your kubuntu login password, it's just that you need to create a samba password.

    So I went back to my PC-10.04 in terminal mode and entered the following command...

    smbpasswd -a my_user_name <enter>
    new SMB password: xxxxxx <enter>
    retype new SMB pasword: xxxxxx <enter>


    Now back to the winxp PC, and I typed in my_user_name and my_samba_password. Viola... I can now see my samba shares from my PC-10.04 on my winxp.

    Eureka! I did it. Finished.


    ================================================== ==============
    Part 6 - how to access sharable folders from a linux/kubuntu machine (PC-9.04) using a windows (ntfs) filesystem
    ================================================== ==============

    This fortunately is relatively easy after figuring out how to access PC-kub10.04 files from PC-kub9.04.
    But in this case, PC-kub9.04 contains a HDD that was formatted using the ntfs filesytem instead of the default linux filesystem, which typically uses ext3 or ext4. So my PC-kub9.04 has two HDDs: one uses the ext4 filesystem and the other uses the ntfs filesystem.

    This unfortunately complicates sharing folders. In the first instance, the steps required are outined above. These steps apply to linux filesystems: ext3 and ext4. I honestly do not know if they apply to other filesystems (reiserfs, etc) b/c I don't have any experience with these other filesystems.

    Secondly, if you don't think you need to do this. Think about this. How would transfer 1000s of MP3s from your windowsPC to your kubuntuPC? It turns out that this type of access now makes it easy for you to simply extract your windows formatted HDD from your windows PC and plug it into your kubuntu PC. So when you start it up, you can access the windows formatted files and copy your files (such as Large MP3 Music Libraries or Video Libraries) directly which is much faster. Plus, this way you don't need a dual boot machine. But I'm digressing.


    As for my windows formatted HDD (ntfs), here's how you mount a windows formatted sharable folder...

    mount -t cifs //remote_computer_name_PC-9.04/home/user_name/sharable_folder_full_pathname /local_mnt/tmp -o user=your_local_username,password=your_local_passw ord <enter>


    Note that the filetype specified is cifs not ntfs. This is critical. You don't use ntfs even though the HDD is ntfs formatted. You must use cifs. For more info use command: "man mount.cifs <Enter>"

    Remember, I'm trying to access a windows formatted HDD installed on a kubuntu PC not from a windows PC. So, I'm trying to access a sharable folder on a remote linux machine from my new linux PC-kub10.04, which has a linux formatted HDD (ext4 filesystem).

    This is how you deconstruct the mount command ...
    First, you're in front of your local machine (PC-kub10.04) and you want to access the other computer (remote pc PC-kub9.04). The first address refers to the sharable folder from the remote machine. The second address refers to an existing folder on the local machine. Then you must provide the current username and password (your current login) of the machine your working with; not the remote computer's username and password.

    After mounting, you should able to see the contents of the PC-kub9.04 windows formatted sharable folder on your linux formatted PC-kub10.04 - sharing between two kubuntu/linux machines. Using Dolphin, just click on the newly mounted local_folder (/local_mnt/tmp) and you should see the contents of the remote_sharable_folder. Or you can use konqueror to do the same thing. Or from terminal mode you could view using CD and DIR or LS commands.


    In my case, konqueror worked perfectly, but Dolphin didn't. I don't know why and I haven't figured this out yet.



    FINISHED. I've figured out how to access any computer or HDD on my home network and any PC can reach/access any other PC (windows or linux)

    PS - The only nagging thing left to figure out is why Dolphin doesn't behave as expect when trying to view the contents of my windows formatted (ntfs) sharable folder. For now, I can use konqueror but I don't know why Dolphin doesn't work.


    Lastly, This was quite a hack to get this interoperability to succeed. And I applied the gunshot approach when I'm sure a more elegant solution exists. I know that I installed extraneous packages which really aren't require, but I don't know any better. Perhaps someone with more knowledge can indentify the bare minimum packages required for 10.04.

    I wrote this b/c it seems that most of the answers regarding kubuntu always refer to previous documentation which is now slowly becoming obsolete because of subtle version changes and divergences between kde and gnome. kubuntu really deserves its own documentation not just references to ubuntu docs.


  10. Back To Top    #10
    Ascendant GreyGeek's Avatar
    Join Date
    Feb 2009
    Posts
    16,475
    Threads
    1168
    Local Date
    May 26th 2020
    Local Time
    08:20 AM

    Re: How to use Network options in Dolphin?

    Your work is so good you should remove the "?" from your subject line and make this thread your HOWTO.

    I am going to make it a sticky.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: Jan 24th 2011, 01:06 AM
  2. MOVED: How to use Network options in Dolphin?
    By Snowhog in forum Help the New Guy
    Replies: 0
    Last Post: Sep 8th 2010, 07:56 PM
  3. Howto use Network options in Dolphin
    By nhtrader in forum How To's
    Replies: 0
    Last Post: Sep 8th 2010, 06:50 PM
  4. Replies: 3
    Last Post: Nov 8th 2008, 03:40 AM
  5. Configuring non-gui options in Network Manager
    By lexxonnet in forum Network Support
    Replies: 0
    Last Post: May 31st 2006, 11:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •