No announcement yet.

Cannot charge over USB-C when in KDE

  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot charge over USB-C when in KDE

    I know this sounds like a hardware issue, but hear me out...

    In the past, I used some other flavors of Linux and charging seemed to work fine. All Ubuntu-based -- I only really swapped to Kubuntu because I really liked KDE and didn't want to try to get a new GUI by myself. Exclusively when I am in Kubuntu, my charging will stop working. This is why I believe it has to be a software error. I suspect my laptop is not recognizing it as a valid charger for some reason, because GRUB will sometimes give me a loudly beeping warning about the charger's wattage being too low when selecting to boot into Kubuntu (despite it being the original charger). It sometimes will begin working again after some number of reboots and varying when I plug in the charger (eg before reboot, in GRUB, in BIOS, on startup...). Usually though, if I reboot then this "working" state will go away and the charger stops again. It's frustrating because it feels very inconsistent which solutions work, and which actions revert to the broken state. I am using the OEM USB-C charger the laptop came with.

    Things I have tried:
    - Bought a third-party barrel jack charger. This charger works exactly as expected - no issues, it's just a bit crappy since it's third-party.
    - Verified the USB-C charger works when in Windows (dual-boot), or when the laptop is powered off.
    - Done full software upgrades - in fact, this issue has persisted over many full upgrades over a year.
    - Tried some known-good USB-C chargers from work, all of which had the same Kubuntu-only ailments.

    I know the barrel jack charger works, but it's clunkier, slower, and gets pretty hot. I really want to use the original hardware here.

    System info:

    Model: Lenovo Flex 5-14ALC05 Laptop (ideapad) - Type 82HU
    KDE Plasma Version: 5.24.7
    KDE Frameworks Version: 5.92.0
    Kernel Version: 5.15.0-72-generic (64-bit)
    Using dual boot?: Yes, with Win11 (problem existed before upgrading from Win10, though)
    inxi output:
      Host: amelia Kernel: 5.15.0-72-generic x86_64 bits: 64 compiler: gcc
        v: 11.3.0 Desktop: KDE Plasma 5.24.7 tk: Qt 5.15.3 wm: kwin_x11 vt: 1
        dm: SDDM Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
      Type: Convertible System: LENOVO product: 82HU v: IdeaPad Flex 5 14ALC05
        serial: <superuser required> Chassis: type: 31 v: IdeaPad Flex 5 14ALC05
        serial: <superuser required>
      Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
        serial: <superuser required> UEFI: LENOVO v: GJCN22WW date: 04/28/2021
      ID-1: BAT0 charge: 9.0 Wh (18.6%) condition: 48.4/52.5 Wh (92.2%)
        volts: 11.8 min: 11.5 model: SMP L19M3PD6 type: Li-poly serial: 2518
        status: Charging cycles: 183
      Info: 8-core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
        type: MT MCP smt: enabled arch: Zen 2 rev: 1 cache: L1: 512 KiB L2: 4 MiB
        L3: 8 MiB
      Speed (MHz): avg: 1423 high: 1819 min/max: 1400/1800 boost: enabled
        cores: 1: 1398 2: 1396 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1392
        9: 1397 10: 1397 11: 1397 12: 1397 13: 1396 14: 1397 15: 1397 16: 1819
        bogomips: 57491
      Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
      Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel pcie:
        speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: HDMI-A-1
        bus-ID: 04:00.0 chip-ID: 1002:164c class-ID: 0300
      Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:2
        chip-ID: 5986:212a class-ID: 0e02
      Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
        loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa gpu: amdgpu
        display-ID: :0 screens: 1
      Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
        s-diag: 582mm (22.9")
      Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9")
        diag: 355mm (14")
      OpenGL: renderer: RENOIR (renoir LLVM 15.0.6 DRM 3.42 5.15.0-72-generic)
        v: 4.6 Mesa 22.2.5 direct render: Yes
      Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
        v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 04:00.1 chip-ID: 1002:1637
        class-ID: 0403
      Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
        vendor: Lenovo driver: N/A pcie: speed: 8 GT/s lanes: 16 bus-ID: 04:00.5
        chip-ID: 1022:15e2 class-ID: 0480
      Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
        v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
        class-ID: 0403
      Sound Server-1: ALSA v: k5.15.0-72-generic running: yes
      Sound Server-2: PulseAudio v: 15.99.1 running: yes
      Sound Server-3: PipeWire v: 0.3.48 running: yes
      Device-1: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
        vendor: Lenovo driver: rtw89_pci v: kernel pcie: speed: 2.5 GT/s lanes: 1
        port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8852 class-ID: 0280
      IF: wlp2s0 state: up mac: 74:4c:a1:db:76:9d
      IF-ID-1: docker0 state: down mac: 02:42:b8:34:ef:3f
      Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
        bus-ID: 3-4:4 chip-ID: 0bda:4852 class-ID: e001 serial: 00e04c000001
      Report: hciconfig ID: hci0 rfk-id: 2 state: up address: 74:4C:A1:DB:76:9E
        bt-v: 3.0 lmp-v: 5.2 sub-v: 6d7a hci-v: 5.2 rev: dfb7
      Local Storage: total: 476.94 GiB used: 240.45 GiB (50.4%)
      ID-1: /dev/nvme0n1 vendor: Western Digital
        model: PC SN530 SDBPMPZ-512G-1101 size: 476.94 GiB speed: 31.6 Gb/s
        lanes: 4 type: SSD serial: 2114GK473216 rev: 21160001 temp: 31.9 C
        scheme: GPT
      ID-1: / size: 191.19 GiB used: 63.55 GiB (33.2%) fs: ext4
        dev: /dev/nvme0n1p5
      ID-2: /boot/efi size: 256 MiB used: 41 MiB (16.0%) fs: vfat
        dev: /dev/nvme0n1p1
      Alert: No swap data was found.
      System Temperatures: cpu: 41.0 C mobo: 36.0 C gpu: amdgpu temp: 38.0 C
      Fan Speeds (RPM): N/A
      Processes: 322 Uptime: 11m wakeups: 5 Memory: 15 GiB used: 1.79 GiB (11.9%)
      Init: systemd v: 249 runlevel: 5 Compilers: gcc: 11.3.0 alt: 11
      Packages: 2628 apt: 2615 snap: 13 Shell: Zsh v: 5.8.1 running-in: konsole
      inxi: 3.3.13 zz0.e278gm4awazz

    The problem here is that KDE has nothing to do with the hardware level support of such things, that is entirely and 100% identical to Ubuntu, as both are the same exact OS, assuming the same release version.
    So remedies and fixes will involve the same troubleshooting and hunting.

    Could there be different kernel versions between the different installs you have been using successfully?
    How about during live sessions of various distros?

    I do see you are on the original 22.04 kernel - 5.15, from the original ISO releases. It is at 5.19 now. This could be the difference between the different *buntu variations you have tried.

    If the most current *buntu 22.04.2 iso image works properly in a live session, you can easily add the HWE kernel and driver stack, which does not remove the existing 5.15.

    23.04 has a 6.2 kernel, and that may be worth testing as well.


      Thanks so much - this all makes sense. I've gone ahead and installed the HWE package since past Ubuntu variations worked when they were installed. Swapped to 5.19 in GRUB and it's looking good so far. First time I haven't gotten the super loud beeping from GRUB on boot in a while.

      Since you say this doesn't really pertain to KDE/Kubuntu forums, I'll carry any other issues I have over to the official Ubuntu forums. Thanks a ton!

      Summarizing for any future Googlers that just want to know:

      sudo apt install --install-recommends linux-generic-hwe-22.04
      Then booted to GRUB, then under "Advanced Settings for Ubuntu" I swapped to the 5.19 regular kernel. Nevermind, this is just default after the above command.
      Last edited by bepri; May 24, 2023, 08:09 AM.


        Originally posted by bepri View Post
        I'll carry any other issues I have over to the official Ubuntu forums
        It doesn't hurt to ask - more eyeballs can't hurt
        I had a charging issue on a Lenovo ideapad once, though it was due to a bad BIOS, and an update fixed it.
        It would not charge when booted.
        I had no Windows installed on it, so it was single-boot.
        I was *sure* it was a Linux problem after ruling out the charge port, because of course you blame that first

        Originally posted by bepri View Post
        Then booted to GRUB, then under "Advanced Settings for Ubuntu" I swapped to the 5.19 regular kernel.
        The 5.19 should be the default choice now.


          Originally posted by claydoh View Post
          It doesn't hurt to ask - more eyeballs can't hurt
          Haha, thanks. I'll remember this - this was definitely the fastest I've had an issue of mine fixed up quick.

          Originally posted by claydoh View Post
          because of course you blame that first

          I honestly thought doing my apt update's and apt upgrade's would land me on newer firmwares! I've been on Linux for about two years now mostly for personal project coding, so I don't really mess with the nitty-gritty unless I have to lol.

          Originally posted by claydoh View Post
          The 5.19 should be the default choice now.
          Oh, cool. I'll leave a footnote on that reply of mine then to not mislead the search engine nomads.